Boş Hücrelerin Değerlendirilmesi

Önceleri, boş hücreler 0 olan sayısal değerlikli kabul ediliyordu ve diğerlerine göre de boş metinler idi. Direk karşılaştırmalar haricinde A1=0 ve A1="" olan karşılaştırmalarda A1 boş ise her iki değerde DOĞRU oluyordu. Şimdi boşluk kullanılana kadar saklı kalmaktadır, böylece her iki durumda da arama işlemi sonucu boş bir hücre dönüyor ise, =DÜŞEYARA(...)=0 ve =DÜŞEYARA(...)="" DOĞRU değerini verirler.

Boş bir hücre için basit bir başvuru 0 olarak sayısal görüntüleniyorken, sayısal bir değer olarak düşünülmesi gereksizdir. Bu yolla referans hücrenin karşılaştırma işlemlerinde umulan sonuçları vermesi sağlanır.

Takip eden örneklerde, A1 bir sayı içerir. B1 boştur, C1 hücresi, B1 hücresine başvuru içerir:

Durum

Formül

Sonuçlar ve açıklamalar

A1: 1
B1:

C1: =B1

Displays 0

=B1=0

DOĞRU

=B1=""

DOĞRU

=C1=0

DOĞRU

=C1=""

DOĞRU (önceki değer: YANLIŞ)

=ISNUMBER(B1)

YANLIŞ

=ISNUMBER(C1)

YANLIŞ (önceki değer: DOĞRU)

=ISNUMBER(VLOOKUP(1;A1:C1;2))

FALSE (B1)

=ISNUMBER(VLOOKUP(1;A1:C1;3))

YANLIŞ (C1, önceki değer: DOĞRU)

=ISTEXT(B1)

YANLIŞ

=ISTEXT(C1)

DOĞRU

=ISTEXT(VLOOKUP(1;A1:C1;2))

YANLIŞ (B1, önceki değer: DOĞRU)

=ISTEXT(VLOOKUP(1;A1:C1;3))

YANLIŞ (C1)

=ISBLANK(B1)

DOĞRU

=ISBLANK(C1)

DOĞRU

=ISBLANK(VLOOKUP(1;A1:C1;2))

DOĞRU (B1, önceki değer: YANLIŞ)

=ISBLANK(VLOOKUP(1;A1:C1;3))

YANLIŞ (C1)


Not Simgesi

Mikrosoft Excel'in farklı davrandığını not edelim, bir boş hücreye yapılan başvuru daima bir sayı ile döner veya boş olan hücreye başvuru içeren bir formüllü hücre sonucu da sayısaldır. Örneğin:


Durum

Formül

Sonuçlar ve açıklamalar

A1:

B1: =A1

0 Gösterir, fakat bu sadece boş hücre için bir referanstır.

=ISNUMBER(A1)

YANLIŞ

=ISTEXT(A1)

YANLIŞ

=A1=0

DOĞRU

=A1=""

DOĞRU

=ISNUMBER(B1)

YANLIŞ (Microsoft Excel: DOĞRU)

=ISTEXT(B1)

YANLIŞ

=B1=0

DOĞRU

=B1=""

DOĞRU (Microsoft Excel: YANLIŞ)

C1: =VLOOKUP(...) with empty cell result

boş gösterir (Microsoft Excel: 0 gösterir)

=ISNUMBER(VLOOKUP(...))

YANLIŞ

=ISTEXT(VLOOKUP(...))

YANLIŞ

=ISNUMBER(C1)

YANLIŞ (Microsoft Excel: DOĞRU)

=ISTEXT(C1)

YANLIŞ


Lütfen bizi destekleyin!