HATA.TÜRÜ işlevi

Belirli bir Hata türüne karşılık gelen bir sayı, eğer böyle bir hata yoksa #N/A hata değerini döndürür.

tip

This function is available since LibreOffice 5.0.


Syntax

HATA.TÜRÜ(Hata_değeri)

Hata_değeri – gerekli değişkendir. Hata değeri veya değerleri incelenmek istenen hücreye bir referans.

Hata değeri

Döndürür

Err:511

1

#DIV/0!

2

#VALUE!

3

#REF!

4

#NAME?

5

#NUM!

6

#N/A

7

Başka bir şey

#N/A


Not Simgesi

Bu fonksiyon Ofis Uygulamaları (OpenDocument) standardının sürüm 1.2 Açık Belge Biçiminin bir parçasıdır. (ISO/IEC 26300:2-2015)


Example

Basit kullanım

=HATA.TÜRÜ(#N/A)

7 döndürür, çünkü 7 #N/A hata değerinin dizin numarasıdır.

=HATA.TÜRÜ(A3)

A3, sıfır ile bölüme eşdeğer bir ifade içeriyorsa, işlev 2 değerini döndürür, çünkü 2, #DIV/0! hata değerinin dizin numarasıdır

Daha gelişmiş bir yolla

A1 ve A2 hücrelerinin bölümünde A2 sıfır olabilir, bu durumla şöyle başa çıkabilirsiniz:

=EĞER(EHATALIYSA(A1/A2);EĞER(HATA.TÜRÜ(A1/A2)=2;"payda sıfır olamaz");A1/A2)

EHATALIYSA işlevi, bir hata olup olmadığına bağlı olarak DOĞRU veya YANLIŞ değerini döndürür. Hata meydana gelirse, EĞER işlevi ikinci argümanı ele alır, hata yoksa, bölünmenin sonucunu döndürür. İkinci bağımsız değişken, belirli hata türünü temsil eden dizin numarasını denetler ve 2'ye eşitse, belirtilen metni "payda sıfır olamaz" ifadesini veya aksi halde 0 döndürür. Böylece, açık metin, bölmeyi sıfır ile gösterir, bölünmenin sonucu bölünme başarılı olduğunda görüntülenecek veya örneğin başka bir türde bir hata olduğunda sıfır döndürülecektir.

Uyarı Simgesi

EĞER işlevinin durumu olarak HATA.TÜRÜ işlevi kullanılırsa veHATA.TÜRÜ #N/A döndürürse, EĞER işlevi #N/A değerini de döndürür. Yukarıdaki örnekteki gibi önlemek için EHATALIYSA kullanın.


Please support us!