Manage Templates

The Template Manager dialog makes it easy to manage templates and allows you to start new documents using templates.

Барои ин фармонро дастрас кардан...

Choose menu File - New – Templates.

Choose menu File – Template – Manage Templates.

Enter +Shift+N in any LibreOffice module.

Press the Templates button in the Start Center.

Select any template type from the Templates button of the Start Center.


Templates save editing time by starting new documents with pre-filled contents and formatting. The Template Manager allows you to access and organize templates in LibreOffice.

LibreOffice comes with a set of built-in templates that can be used to create documents, presentations, spreadsheets or drawings. You may use templates available in the template manager, create your own templates or browse online for additional templates.

Main Window – Template Choices

Previews of available templates show up in the main window based on your search and filtering choices. Double-click on any template icon to open a new document with the contents and formatting of the template.

Choose Thumbnail View or List View, at the top right, to change how the templates are displayed.

Thumbnail View Icon

Thumbnail View

List View Icon

Listview

note

To show templates from another folder in the My Templates category, choose LibreOffice - Paths, select Templates, press Edit, then press Add to open the file dialog for selecting the folder to add.


Search

You may search for a template by entering text in the search box at the top left. The Main window shows the templates found.

Filter

You may filter for: All Applications, Text Documents, Spreadsheets, Presentations or Drawings by choosing an option from the dropdown box at the top-center. The main window displays the filtered templates.

Categories

Categories are folders where you place your templates. You may choose from the default categories: All Categories, My Templates, Business Correspondence, MediaWiki, Other Business Documents, Personal Correspondence and Documents, Presentations or Styles. You may also create new categories for your personal use. Use the Tools icon of the Template Manager to create a new category.

note

Categories inside a category are not allowed.


Tools

Click on the Tools icon at the bottom left to open the Tools menu. The options are: New Category, Rename Category, Delete Category, and Refresh. If the default template for an application is changed from the initial default setting, then an additional option, Reset Default Template, is available, which allows you to reset the default template for an application back to its initial default.

Tools Icon

Tools icon

Move

If you want to move templates to a different category, then choose a template, or use +click to select additional templates, then press the Move button at the bottom right to open a dialog box, where you can choose to move your selection to a different category or to a new category. Default templates cannot be moved, but copies can be created in other categories.

Export

Choose a template in the main window, or use +click to select additional templates, and then press the Export button at the bottom right to export your selection to a folder on your computer.

Export Icon

Export button

tip

To move or export all templates in a Category, press +A, then choose Move or Export.


Import

If you want to import one or more templates into the Template Manager, then press the Import button at the bottom right, choose the Category where the imported templates should be placed, then select the files to be imported.

Import Icon

Import button

Extensions

To browse for more templates online, click on the Extensions icon at the bottom right to open a search window. You can also search for templates at https://extensions.libreoffice.org.

Extensions Icon

Extensions icon

Actions with Individual Templates

Open

Select a template in the main window and right-click and then choose Open, press Enter or double click to open a new document using that template.

You can also use the Open button on the bottom left to open a new document using the selected template.

Edit

Select a template in the main window and right-click and then choose Edit to edit the template. This function is only available for templates that are not built-in.

Set as Default

Select a template in the main window and right-click and then choose Set as Default to set the template as the default template. This will cause a green tick to appear over the template and the template will automatically load when a new document is created using the matching application.

Rename

Select a template in the main window and right-click and then choose Rename to rename the template. This will cause a dialog box to appear where a new name may be chosen for the template. Type in the name and then choose OK or choose Cancel to revert to the name that is already set.

Delete

Select one or more templates to delete in the main window and press the Delete key, or right-click then choose Delete to delete the selected template(s). A dialog box will appear requesting confirmation. Choose Yes to delete or No to cancel.

note

Built-in templates cannot be edited, renamed or deleted.


Examples

Example 1 – Creating a Business Letter

  1. Open LibreOffice Writer

  2. Press +Shift+N or choose File - New - Templates to open the Template Manager

  3. Type “business letter” into the search box

  4. Choose one of the templates from the main window by double-clicking on it or select and press Enter.

  5. A new document using that template is created in a new instance of LibreOffice Writer

  6. Change text and logo as needed

Example 2 – Import Template – Personal Budget Spreadsheet

  1. Open LibreOffice Calc

  2. Press +Shift+N or choose File - New - Templates to open the Template Manager

  3. Click on the Extensions icon to browse for online templates.

  4. Search for the Personal Budget Template, then download it

  5. Open Template Manager and choose the Import button

  6. Select a category to save the new template in, for example, My Templates, and press OK.

  7. Browse to the folder where you downloaded the template, select it and press Open

  8. The Template is now available in the category you chose.

Example 3 – LibreOffice Impress – Presentation Template

  1. Open LibreOffice Impress

  2. The Template Manager opens automatically when you open LibreOffice Impress

  3. Choose a template for your presentation, filter by categories or search

  4. You may also use the context menu, import a template, or search online for a template.

  5. A few features in the Template Manager are not available when first opened automatically. After starting LibreOffice Impress you may run the Template Manager again to access all features.

tip

Make use of categories to organize your templates. Create new templates or download templates and organize in the Template Manager. Use templates to save time for repetitive documents.


Refer to https://extensions.libreoffice.org for templates to download.

See Chapter 3 – Using Styles and Templates in the Getting Started Guide.

See Creating a Document Template for related information.

See Templates and Styles for related information.

Please support us!