Adresser och referenser, absoluta och relativa

Relativ adressering

Med A1 adresseras cellen i kolumn A och rad 1. Ett omrÄde av intilliggande celler adresserar du genom att ange det vÀnstra övre hörnet av omrÄdet och sedan sÀtta ett kolon. Ange slutligen den högra undre cellen av omrÄdet. Det kvadratiska omrÄdet av de första fyra cellerna i hörnet uppe till vÀnster heter dÄ A1:B2.

Vid den hÀr typen av adressering av ett omrÄde Àr referensen till A1:B2 en relativ referens. Relativ betyder hÀr att referensen till det hÀr omrÄdet anpassas nÀr du kopierar formlerna.

Absolut adressering

Absolute referencing is the opposite of relative addressing. A dollar sign is placed before each letter and number in an absolute reference, for example, $A$1:$B$2.

Symbolen Tips

LibreOffice can convert the current reference, in which the cursor is positioned in the input line, from relative to absolute and vice versa by pressing F4. If you start with a relative address such as A1, the first time you press this key combination, both row and column are set to absolute references ($A$1). The second time, only the row (A$1), and the third time, only the column ($A1). If you press the key combination once more, both column and row references are switched back to relative (A1)


LibreOffice Calc shows the references to a formula. If, for example, you click the formula =SUM(A1:C5;D15:D24) in a cell, the two referenced areas in the sheet will be highlighted in color. For example, the formula component "A1:C5" may be in blue and the cell range in question bordered in the same shade of blue. The next formula component "D15:D24" can be marked in red in the same way.

NÀr anvÀnds relativa och nÀr anvÀnds absoluta referenser?

Vad utmÀrker en relativ referens? Anta att du i cell E1 vill berÀkna summan av cellerna i omrÄdet A1:B2. Skriv följande formel i E1: =SUMMA(A1:B2). Om du senare infogar en ny kolumn framför kolumn A, kommer de element som du vill addera att finnas i B1:C2 och formeln att placeras i F1, inte i E1. NÀr du har infogat den nya kolumnen mÄste du dÀrför kontrollera och korrigera alla formler i tabellen, och eventuellt i andra tabeller.

DessbÀttre gör LibreOffice arbetet Ät dig. NÀr du har infogat en ny kolumn A uppdateras formeln =SUMMA(A1:B2) automatiskt till =SUMMA(B1:C2). Radnummer justeras ocksÄ automatiskt nÀr en ny rad 1 infogas. Absoluta och relativa referenser justeras alltid i LibreOffice Calc nÀr ett referensomrÄde flyttas. Om du kopierar formler bör du vara aktsam eftersom endast de relativa referenserna justeras, inte de absoluta.

Absoluta referenser anvÀnds nÀr en berÀkning refererar till en viss cell i tabellen. Om en formel som refererar till exakt den hÀr cellen kopieras relativt till en cell nedanför den ursprungliga cellen, flyttas Àven referensen nedÄt om du inte definierar cellkoordinaterna som absoluta.

Bortsett frÄn nÀr nya rader och kolumner infogas kan referenser Àndras ocksÄ nÀr en befintlig formel som refererar till vissa celler kopieras till ett annat omrÄde i tabellen. Anta att du matade in formeln =SUMMA(A1:A9) i rad 10. Om du vill berÀkna summan för kolumnen nÀrmast till höger kopierar du bara den hÀr formeln till cellen till höger. Kopian av formeln i kolumn B justeras automatiskt till =SUMMA(B1:B9).

Please support us!