Hantering av tomma celler

I tidigare programvaruversioner tolkades tomma celler antingen som numeriskt 0 eller som tomma strÀngar, beroende pÄ sammanhanget, förutom i direkt jÀmförelse dÀr =A1=0 och =A1="" bÄda resulterade i SANT om A1 var tom. Nu Àrvs tomheten tills den anvÀnds, sÄ bÄde =LETARAD(...)=0 och =LETARAD(...)="" ger SANT om sökningen resulterade i att en tom cell returnerades.

En enkel referens till en tom cell visas fortfarande som numerisk 0 men behöver inte lÀngre vara numerisk, sÄ Àven jÀmförelser med den refererade cellen fungerar som vÀntat.

I följande exempel innehÄller A1 ett tal, B1 Àr tom och C1 en referens till B1.

Case

Formula

Results and comments

A1: 1
B1: <Empty>

C1: =B1

Displays 0

=B1=0

TRUE

=B1=""

TRUE

=C1=0

TRUE

=C1=""

TRUE (previously was FALSE)

=ISNUMBER(B1)

FALSE

=ISNUMBER(C1)

FALSE (previously was TRUE)

=ISNUMBER(VLOOKUP(1;A1:C1;2))

FALSE (B1)

=ISNUMBER(VLOOKUP(1;A1:C1;3))

FALSE (C1, previously was TRUE)

=ISTEXT(B1)

FALSE

=ISTEXT(C1)

TRUE

=ISTEXT(VLOOKUP(1;A1:C1;2))

FALSE (B1, previously was TRUE)

=ISTEXT(VLOOKUP(1;A1:C1;3))

FALSE (C1)

=ISBLANK(B1)

TRUE

=ISBLANK(C1)

TRUE

=ISBLANK(VLOOKUP(1;A1:C1;2))

TRUE (B1, previously was FALSE)

=ISBLANK(VLOOKUP(1;A1:C1;3))

FALSE (C1)


Symbolen Info

Observera att Microsoft Excel fungerar annorlunda. DĂ€r returneras alltid ett tal som resultat av en referens till en tom cell eller till en formelcell med resultatet av en tom cell. T.ex.:


Case

Formula

Results and comments

A1: <Empty>

B1: =A1

Displays 0, but is just a reference to an empty cell.

=ISNUMBER(A1)

FALSE

=ISTEXT(A1)

FALSE

=A1=0

TRUE

=A1=""

TRUE

=ISNUMBER(B1)

FALSE (Microsoft Excel: TRUE)

=ISTEXT(B1)

FALSE

=B1=0

TRUE

=B1=""

TRUE (Microsoft Excel: FALSE)

C1: =VLOOKUP(...) with empty cell result

displays empty (Microsoft Excel: displays 0)

=ISNUMBER(VLOOKUP(...))

FALSE

=ISTEXT(VLOOKUP(...))

FALSE

=ISNUMBER(C1)

FALSE (Microsoft Excel: TRUE)

=ISTEXT(C1)

FALSE


Please support us!