Logiska funktioner

This category contains the Logical functions.

Handling non-logical arguments in logical functions

SÄ hÀr anvÀnder du det hÀr kommandot...

Insert - Function - Category Logical


ÄRSAKNAD

Returnerar SANT om alla celler innehÄller felvÀrdet #SAKNAS (vÀrdet finns inte).

Om ett fel intrÀffar returnerar funktionen FALSKT.

Syntax

ÄRSAKNAD(VĂ€rde)

vÀrde Àr vÀrdet eller ett uttryck som ska kontrolleras.

Example

=ÄRSAKNAD(D3) returnerar FALSKT som ett resultat.

OMFEL

Returnerar vÀrdet om cellen inte innehÄller ett felvÀrde, annars ges ett alternativt vÀrde.

tip

This function is available since LibreOffice 4.0.


Syntax

IFERROR(Value; Alternate_value)

VÀrde Àr det vÀrde eller uttryck som ska returneras om det inte Àr lika med eller resulterar i ett fel.

Alternativt_vÀrde Àr det vÀrde eller uttryck som ska returneras om uttrycket eller vÀrdet frÄn VÀrde Àr lika med eller resulterar i ett fel.

Example

=OMFEL(C8;C9) om cell C8 innehÄller =1/0 returneras vÀrdet i C9, eftersom 1/0 Àr ett fel.

=OMFEL(C8;C9) om cell C8 innehÄller =13 returneras 13, eftersom vÀrdet i C8 inte Àr nÄgot fel.

IFS

IFS is a multiple IF-function.

SWITCH

SWITCH compares expression with value1 to valuen and returns the result belonging to the first value that equals expression. If there is no match and default_result is given, that will be returned.

ELLER

Returnerar SANT om minst ett argument Àr SANT. Den hÀr funktionen returnerar FALSKT om alla argument har det logiska vÀrdet FALSKT.

Argumenten Àr antingen sjÀlva logiska uttryck (SANT, 1<5, 2+3=7, B8<10) som returnerar logiska vÀrden eller matriser (A1:C3) som innehÄller logiska vÀrden.

Syntax

OR(Logical 1 [; Logical 2 [; 
 [; Logical 255]]])

Logical 1, Logical 2, 
 , Logical 255 are boolean values, references to cells or to cell ranges of logical values.

note

This function ignores any text or empty cell within a data range. If you suspect wrong results from this function, look for text in the data ranges. To highlight text contents in a data range, use the value highlighting feature.


Example

De logiska vÀrdena i posterna 12<11; 13>22 och 45=45 ska kontrolleras:

=ELLER(12<11;13>22;45=45) returnerar SANT.

=ELLER(FALSKT;SANT) returnerar SANT.

FALSKT

Returnerar det logiska vÀrdet FALSKT. Funktionen FALSKT() krÀver inga argument och returnerar alltid det logiska vÀrdet FALSKT.

Syntax

FALSKT()

Example

=FALSKT() returnerar FALSKT

=ICKE(FALSKT()) returnerar SANT

ICKE

Komplementerar (inverterar) ett logiskt vÀrde.

Syntax

ICKE(Logiskt vÀrde)

Logiskt vÀrde Àr alla vÀrden som ska komplementeras.

Example

=ICKE(A). Om A=SANT sÄ kommer ICKE(A) att returnera FALSKT.

OCH

Returnerar SANT om alla argument har vÀrdet SANT. Om minst ett av elementen Àr FALSKT, returneras vÀrdet FALSKT.

Argumenten Àr antingen sjÀlva logiska uttryck (SANT, 1<5, 2+3=7, B8<10) som returnerar logiska vÀrden eller matriser (A1:C3) som innehÄller logiska vÀrden.

Syntax

AND(Logical 1 [; Logical 2 [; 
 [; Logical 255]]])

Logical 1, Logical 2, 
 , Logical 255 are boolean values, references to cells or to cell ranges of logical values.

note

This function ignores any text or empty cell within a data range. If you suspect wrong results from this function, look for text in the data ranges. To highlight text contents in a data range, use the value highlighting feature.


Example

De logiska vÀrdena i posterna 12<13, 14>12 och 7<6 ska kontrolleras:

=OCH(12<13;14>12;7<6) returnerar FALSKT.

=OCH (FALSKT;SANT) returnerar FALSKT.

OM

Anger ett logiskt test som ska utföras.

Syntax

IF(Test [; [ThenValue] [; [OtherwiseValue]]])

Test Àr vilket vÀrde eller uttryck som helst som kan vara SANT eller FALSKT.

Sedan vÀrde (valfritt) Àr det vÀrde som returneras om det logiska testet Àr SANT.

Annars vÀrde (valfritt) Àr det vÀrde som returneras om det logiska testet Àr FALSKT.

I LibreOffice Calc-funktioner kan de parametrar som markeras som "valfria" bara utelÀmnas nÀr inga efterföljande parametrar finns. I till exempel en funktion med fyra parametrar, dÀr de tvÄ sista parametrarna markeras som "valfria", kan du utelÀmna parameter 4 eller parametrarna 3 och 4, men inte utelÀmna enbart parameter 3.

Example

=IF(A1>5;100;"too small") If the value in A1 is greater than 5, the value 100 is returned; otherwise, the text too small is returned.

=IF(A1>5;;"too small") If the value in A1 is greater than 5, the value 0 is returned because empty parameters are considered to be 0; otherwise, the text too small is returned.

=IF(A1>5;100;) If the value in A1 is less than 5, the value 0 is returned because the empty OtherwiseValue is interpreted as 0; otherwise 100 is returned.

SANT

Det logiska vÀrdet anges till SANT. Funktionen SANT() krÀver inga argument och returnerar alltid det logiska vÀrdet SANT.

Syntax

SANT()

Example

Om A=SANT och B=FALSKT visas följande exempel:

=OCH(A;B) returnerar FALSKT

=ELLER(A;B) returnerar SANT

=ICKE(OCH(A;B)) returnerar SANT

XELLER

Returnerar sant om ett udda antal argument Àr lika med sant.

Argumenten Àr antingen sjÀlva logiska uttryck (SANT, 1<5, 2+3=7, B8<10) som returnerar logiska vÀrden eller matriser (A1:C3) som innehÄller logiska vÀrden.

tip

This function is available since LibreOffice 4.0.


Syntax

XOR(Logical 1 [; Logical 2 [; 
 [; Logical 255]]])

Logical 1, Logical 2, 
 , Logical 255 are boolean values, references to cells or to cell ranges of logical values.

Example

=XELLER(SANT;SANT) returnerar FALSKT.

=XELLER(SANT;SANT;SANT) returnerar SANT.

=XELLER(FALSKT;SANT) returnerar SANT.

Please support us!