Logiska funktioner

This category contains the Logical functions.

Handling non-logical arguments in logical functions

Så här använder du det här kommandot...

Insert - Function - Category Logical


ÄRSAKNAD

Returnerar SANT om alla celler innehåller felvärdet #SAKNAS (värdet finns inte).

Om ett fel inträffar returnerar funktionen FALSKT.

Syntax

ÄRSAKNAD(Värde)

värde är värdet eller ett uttryck som ska kontrolleras.

Example

=ÄRSAKNAD(D3) returnerar FALSKT som ett resultat.

OMFEL

Returnerar värdet om cellen inte innehåller ett felvärde, annars ges ett alternativt värde.

tip

This function is available since LibreOffice 4.0.


Syntax

IFERROR(Value; Alternate_value)

Värde är det värde eller uttryck som ska returneras om det inte är lika med eller resulterar i ett fel.

Alternativt_värde är det värde eller uttryck som ska returneras om uttrycket eller värdet från Värde är lika med eller resulterar i ett fel.

Example

=OMFEL(C8;C9) om cell C8 innehåller =1/0 returneras värdet i C9, eftersom 1/0 är ett fel.

=OMFEL(C8;C9) om cell C8 innehåller =13 returneras 13, eftersom värdet i C8 inte är något fel.

IFS

IFS is a multiple IF-function.

SWITCH

SWITCH compares expression with value1 to valuen and returns the result belonging to the first value that equals expression. If there is no match and default_result is given, that will be returned.

ELLER

Returnerar SANT om minst ett argument är SANT. Den här funktionen returnerar FALSKT om alla argument har det logiska värdet FALSKT.

Argumenten är antingen själva logiska uttryck (SANT, 1<5, 2+3=7, B8<10) som returnerar logiska värden eller matriser (A1:C3) som innehåller logiska värden.

Syntax

OR(Logical 1 [; Logical 2 [; … [; Logical 255]]])

Logical 1, Logical 2, … , Logical 255 are boolean values, references to cells or to cell ranges of logical values.

note

This function ignores any text or empty cell within a data range. If you suspect wrong results from this function, look for text in the data ranges. To highlight text contents in a data range, use the value highlighting feature.


Example

De logiska värdena i posterna 12<11; 13>22 och 45=45 ska kontrolleras:

=ELLER(12<11;13>22;45=45) returnerar SANT.

=OR(FALSE();TRUE()) returns TRUE.

FALSKT

Returnerar det logiska värdet FALSKT. Funktionen FALSKT() kräver inga argument och returnerar alltid det logiska värdet FALSKT.

Syntax

FALSKT()

Example

=FALSKT() returnerar FALSKT

=ICKE(FALSKT()) returnerar SANT

ICKE

Komplementerar (inverterar) ett logiskt värde.

Syntax

ICKE(Logiskt värde)

Logiskt värde är alla värden som ska komplementeras.

Example

=ICKE(A). Om A=SANT så kommer ICKE(A) att returnera FALSKT.

OCH

Returnerar SANT om alla argument har värdet SANT. Om minst ett av elementen är FALSKT, returneras värdet FALSKT.

Argumenten är antingen själva logiska uttryck (SANT, 1<5, 2+3=7, B8<10) som returnerar logiska värden eller matriser (A1:C3) som innehåller logiska värden.

Syntax

AND(Logical 1 [; Logical 2 [; … [; Logical 255]]])

Logical 1, Logical 2, … , Logical 255 are boolean values, references to cells or to cell ranges of logical values.

note

This function ignores any text or empty cell within a data range. If you suspect wrong results from this function, look for text in the data ranges. To highlight text contents in a data range, use the value highlighting feature.


Example

De logiska värdena i posterna 12<13, 14>12 och 7<6 ska kontrolleras:

=OCH(12<13;14>12;7<6) returnerar FALSKT.

=AND(FALSE();TRUE()) returns FALSE.

OM

Anger ett logiskt test som ska utföras.

Syntax

IF(Test [; [ThenValue] [; [OtherwiseValue]]])

Test är vilket värde eller uttryck som helst som kan vara SANT eller FALSKT.

Sedan värde (valfritt) är det värde som returneras om det logiska testet är SANT.

Annars värde (valfritt) är det värde som returneras om det logiska testet är FALSKT.

I LibreOffice Calc-funktioner kan de parametrar som markeras som "valfria" bara utelämnas när inga efterföljande parametrar finns. I till exempel en funktion med fyra parametrar, där de två sista parametrarna markeras som "valfria", kan du utelämna parameter 4 eller parametrarna 3 och 4, men inte utelämna enbart parameter 3.

Example

=IF(A1>5;100;"too small") If the value in A1 is greater than 5, the value 100 is returned; otherwise, the text too small is returned.

=IF(A1>5;;"too small") If the value in A1 is greater than 5, the value 0 is returned because empty parameters are considered to be 0; otherwise, the text too small is returned.

=IF(A1>5;100;) If the value in A1 is less than 5, the value 0 is returned because the empty OtherwiseValue is interpreted as 0; otherwise 100 is returned.

SANT

Det logiska värdet anges till SANT. Funktionen SANT() kräver inga argument och returnerar alltid det logiska värdet SANT.

Syntax

SANT()

Example

Om A=SANT och B=FALSKT visas följande exempel:

=OCH(A;B) returnerar FALSKT

=ELLER(A;B) returnerar SANT

=ICKE(OCH(A;B)) returnerar SANT

XELLER

Returnerar sant om ett udda antal argument är lika med sant.

Argumenten är antingen själva logiska uttryck (SANT, 1<5, 2+3=7, B8<10) som returnerar logiska värden eller matriser (A1:C3) som innehåller logiska värden.

tip

This function is available since LibreOffice 4.0.


Syntax

XOR(Logical 1 [; Logical 2 [; … [; Logical 255]]])

Logical 1, Logical 2, … , Logical 255 are boolean values, references to cells or to cell ranges of logical values.

Example

=XOR(TRUE();TRUE()) returns FALSE

=XOR(TRUE();TRUE();TRUE()) returns TRUE

=XOR(FALSE();TRUE()) returns TRUE

Stötta oss!