Função TIPO.ERRO

Devolce o número representativo do tipo de erro ou #N/D se não existir erro.

tip

Esta função está disponível desde o LibreOffice 5.0.


Sintaxe

TIPO.ERRO(valor_erro)

expressão é obrigatório. Representa o valor de erro ou a referência à célula que deve ser testada.

Valor de erro

Devolve

Err:511

1

#DIV/0!

2

#VALOR!

3

#REF!

4

#NOME?

5

#NUM!

6

#N/D

7

Qualquer outro valor

#N/D


note

Esta função é parte integrante da norma Open Document Format for Office Applications (OpenDocument), versão 1.2 (ISO/IEC 26300:2-2015).


Exemplo

Utilização

TIPO.ERRO(#N/D)

Devolve 7, porque 7 é o número de índice do erro #N/D.

TIPO.ERRO(A3)

Se em A3 estiver uma expressão equivalente a uma divisão por zero, a função devolve 2, porque 2 é o número de ídnice do erro #DIV/0!

Utilização avançada

Se na divisão de A1 por A2, A2 pode tornar-se zero, pode gerir a situação desta forma:

=SE(É.ERROS(A1/A2);SE(TIPO.ERRO(A1/A2)=2;"o denominador não pode ser zero");A1/A2)

A função É.ERROS devolve VERDADEIRO se existir um erro e FALSO se não existir erro. Se existir um erro, a função SE devolve o segundo argumento mas se não existir erro devolve o resultado da divisão. O segundo argumento verifica o número de índice que especifica o tipo de erro e se for igual a 2, devolve o texto especificado "o denominador não pode ser zero", caso contrário devolve 0.

Ícone de aviso

Se a função TIPO.ERRO for utilizada como condição da função SE e a primeira devolver o erro #N/D, a segunda também devolve o erro #N/D. Utilize a função É.ERROS para contornar esta situação.


Necessitamos da sua ajuda!