Funções lógicas

This category contains the Logical functions.

Gerir argumentos não lógicos em funções lógicas

Para aceder a este comando...

Inserir - Função - Categoria Lógica


É.NÃO.DISP

Devolve VERDADEIRO se uma célula contiver o valor de erro #N/D (valor não disponível).

Se existir um erro, a função devolve FALSO.

Sintaxe

É.NÃO.DISP(valor)

valor é o valor ou expressão que será testada.

Exemplo

=É.NÃO.DISP(D3) devolve FALSO como resultado.

SE.ERRO

Devolve o valor se a célula não tiver um erro ou o valor alternativo se existir erro.

tip

Esta função está disponível desde o LibreOffice 4.0.


Sintaxe

IFERROR(Value; Alternate_value)

valor é o valor ou expressão a devolver se este não for nem nem resultar em erro.

valor_alternativo é o valor ou expressão a devolver se valor for ou resultar num erro.

Exemplo

=SE.ERRO(C8;C9) em que a célula C8 contém =1/0 devolve o valor de C9, uma vez que 1/0 é um erro.

=SE.ERRO(C8;C9) em que a célula C8 contém 13 devolve 13, que é o valor da célula C8 e que não é um erro.

SE.S

SE.S é uma função SE múltipla.

SWITCH

SWITCH compares expression with value1 to valuen and returns the result belonging to the first value that equals expression. If there is no match and default_result is given, that will be returned.

E

Devolve VERDADEIRO se todos os argumentos forem VERDADEIRO. Se um dos elementos for FALSO, esta função devolve o valor FALSO.

Os argumentos correspondem a expressões lógicas (VERDADEIRO, 1<5, 2+3=7, B8<10) que devolvem valores lógicos, ou a matrizes (A1:C3) que contenham valores lógicos.

Sintaxe

AND(Logical 1 [; Logical 2 [; … [; Logical 255]]])

Logical 1, Logical 2, … , Logical 255 are boolean values, references to cells or to cell ranges of logical values.

note

This function ignores any text or empty cell within a data range. If you suspect wrong results from this function, look for text in the data ranges. To highlight text contents in a data range, use the value highlighting feature.


Exemplo

Os valores lógicos das entradas 12<13; 14>12 e 7<6 serão verificados:

=E(12<13;14>12;7<6) devolve FALSO.

=E (FALSO;VERDADEIRO) devolve FALSO.

FALSO

Devolve o valor lógico FALSO. A função FALSO() não necessita de quaisquer argumentos, e devolve sempre o valor lógico FALSO.

Sintaxe

FALSO()

Exemplo

=FALSO() devolve FALSO

=NÃO(FALSO()) devolve VERDADEIRO

NÃO

Inverte um valor lógico.

Sintaxe

NÃO(valor_lógico)

valor_lógico o valor a ser invertido.

Exemplo

=NÃO(A). Se A=VERDADEIRO, então NÃO(A) será avaliado como FALSO.

OU

Devolve VERDADEIRO se existir, no mínimo, um argumento VERDADEIRO. Esta função devolve o valor FALSO se todos os argumentos possuírem o valor lógico FALSO.

Os argumentos correspondem a expressões lógicas (VERDADEIRO, 1<5, 2+3=7, B8<10) que devolvem valores lógicos, ou a matrizes (A1:C3) que contenham valores lógicos.

Sintaxe

OR(Logical 1 [; Logical 2 [; … [; Logical 255]]])

Logical 1, Logical 2, … , Logical 255 are boolean values, references to cells or to cell ranges of logical values.

note

This function ignores any text or empty cell within a data range. If you suspect wrong results from this function, look for text in the data ranges. To highlight text contents in a data range, use the value highlighting feature.


Exemplo

Os valores lógicos das entradas 12<11; 13>22 e 45=45 serão verificados.

=OU(12<11;13>22;45=45) devolve VERDADEIRO.

=OU(FALSO;VERDADEIRO) devolve VERDADEIRO.

SE

Especifica o teste lógico a ser executado.

Sintaxe

IF(Test [; [ThenValue] [; [OtherwiseValue]]])

teste é qualquer valor ou expressão que possa ser VERDADEIRO ou FALSO.

valor_se_verdadeiro (opcional) é o valor devolvido se o teste lógico for VERDADEIRO.

valor_se_falso (opcional) é o valor devolvido se o teste lógico for FALSO.

Nas funções do LibreOffice Calc, pode excluir parâmetros marcados como "opcionais" apenas quando não são seguidos por mais parâmetros. Por exemplo, numa função com 4 parâmetros, em que os dois últimos parâmetros são marcados como "opcionais", pode excluir o parâmetro 4 ou os parâmetros 3 e 4, mas não apenas o parâmetro 3.

Exemplo

=IF(A1>5;100;"too small") If the value in A1 is greater than 5, the value 100 is returned; otherwise, the text too small is returned.

=IF(A1>5;;"too small") If the value in A1 is greater than 5, the value 0 is returned because empty parameters are considered to be 0; otherwise, the text too small is returned.

=IF(A1>5;100;) If the value in A1 is less than 5, the value 0 is returned because the empty OtherwiseValue is interpreted as 0; otherwise 100 is returned.

VERDADEIRO

O valor lógico está definido como VERDADEIRO. A função VERDADEIRO() não necessita de quaisquer argumentos, e devolve sempre o valor lógico VERDADEIRO.

Sintaxe

VERDADEIRO()

Exemplo

Se A=VERDADEIRO e B=FALSO, serão mostrados os seguintes exemplos:

=E(A;B) devolve FALSO

=OU(A;B) devolve VERDADEIRO

=NÃO(E(A;B)) devolve VERDADEIRO

XOU

Devolve um "Ou exclusivo" lógico de todos os elementos.

Os argumentos correspondem a expressões lógicas (VERDADEIRO, 1<5, 2+3=7, B8<10) que devolvem valores lógicos, ou matrizes (A1:C3) que contenham valores lógicos.

tip

Esta função está disponível desde o LibreOffice 4.0.


Sintaxe

XOR(Logical 1 [; Logical 2 [; … [; Logical 255]]])

Logical 1, Logical 2, … , Logical 255 are boolean values, references to cells or to cell ranges of logical values.

Exemplo

=XOU(FALSO;FALSO) devolve FALSO

=XOU(FALSO;FALSO;VERDADEIRO) devolve VERDADEIRO

=XOU(FALSO;VERDADEIRO) devolve VERDADEIRO

Necessitamos da sua ajuda!