Tratar células vazias

Em versões antigas do software, as células vazias eram forçadas a serem numericamente iguais a zero em alguns contextos e a serem uma cadeia de caracteres vazia em outros, exceto em comparações diretas, onde =A1=0 e =A1="" ambas resultavam em VERDADEIRO se A1 fosse vazia. Agora a propriedade vazia é herdada até sua utilização, de forma que ambos =PROCV(...)=0 e =PROCV(...)="" retornam VERDADEIRO se a procura resultar em uma célula vazia.

Uma simples referência a uma célula vazia é ainda exibida como 0 numérico mas não é mais necessariamente de tipo numérico. Assim, comparações com a célula referenciada funcionam normalmente.

Para os exemplos que seguem, A1 contém um número, B1 está vazia, C1 contém uma referência a B1:

Caso

Fórmula

Resultados e comentários

A1: 1
B1:

C1: =B1

Exibe 0

=B1=0

VERDADEIRO

=B1=""

VERDADEIRO

=C1=0

VERDADEIRO

=C1=""

VERDADEIRO (previamente era FALSO)

=ÉNUM(B1)

FALSO

=ÉNUM(C1)

FALSO (previamente era VERDADEIRO)

=ÉNUM(PROCV(1;A1:C1;2))

FALSO (B1)

=ÉNUM(PROCV(1;A1:C1;3))

FALSO (C1, previamente era VERDADEIRO)

=ÉTEXTO(B1)

FALSO

=ÉTEXTO(C1)

VERDADEIRO

=ÉTEXTO(PROCV(1;A1:C1;2))

FALSO (B1, previamente era VERDADEIRO)

=ÉTEXTO(PROCV(1;A1:C1;3))

FALSO (C1)

=ÉCÉL.VAZIA(B1)

VERDADEIRO

=ÉCÉL.VAZIA(C1)

VERDADEIRO

=ÉCÉL.VAZIA(PROCV(1;A1:C1;2))

VERDADEIRO (B1, previamente era FALSO)

=ÉCÉL.VAZIA(PROCV(1;A1:C1;3))

FALSO (C1)


Ícone Nota

Note que o Microsoft Excel se comporta de forma diferente e sempre retorna um número como resultado de uma referência a uma célula vazia ou a uma célula de fórmula que resulte em uma célula vazia. Por exemplo:


Caso

Fórmula

Resultados e comentários

A1:

B1: =A1

Exibe 0, mas é só uma referência a uma célula vazia.

=ÉNUM(A1)

FALSO

=ÉTEXTO(A1)

FALSO

=A1=0

VERDADEIRO

=A1=""

VERDADEIRO

=ÉNUM(B1)

FALSO (Microsoft Excel: VERDADEIRO)

=ÉTEXTO(B1)

FALSO

=B1=0

VERDADEIRO

=B1=""

VERDADEIRO (Microsoft Excel: FALSO)

C1: =PROCV(...) com resultado de célula vazia

exibe vazio (Microsoft Excel: exibe 0)

=ÉNUM(PROCV(...))

FALSO

=ÉTEXTO(PROCV(...))

FALSO

=ÉNUM(C1)

FALSO (Microsoft Excel: VERDADEIRO)

=ÉTEXTO(C1)

FALSO


♥ Doe para nosso projeto! ♥