Formuła

Określa opcje składni formuły i ładowania LibreOffice Calc.

Aby wykonać tę operację...

Open a spreadsheet document, choose - LibreOffice Calc - Formula.


Opcje formuły

Składnia formuły

Możliwe są trzy opcje. Przyjrzyjmy się im na przykładzie. W przykładowym skoroszycie są dwa arkusze, Arkusz1i Arkusz2. W komórce A1 Arkusza1 jest odniesienie do komórki C4 w Arkuszu2.

Użyj anglojęzycznych nazw funkcji

Nazwy funkcji w LibreOffice Calc mogą być zlokalizowane. Domyślnie, to pole jest odznaczone, co oznacza, że używane są zlokalizowane nazwy funkcji. Zaznaczenie tego, spowoduje, że używane będą anglojęzyczne nazwy funkcji. Zmiana odnosi się do następujących obszarów: wprowadzanie i wyświetlanie formuł, kreator formuł i wskazówki dot. formuł. Pole można w każdej chwili odznaczyć i powrócić do zlokalizowanych nazw formuł.

Separatory

Ta grupa ustawień pozwala skonfigurować separatory w wyrażeniach formuł. Ustawienie jest przydatne, gdy np. chcemy oddzielić parametry formuły przecinkiem, zamiast średnikiem.

Na przykład, zamiast =SUMA(A1;B1;C1), można wpisać =SUMA(A1,B1,C1).

Podobnie można zmienić separatory kolumn i wierszy dla wbudowanych macierzy. Dotychczas, we wbudowanych macierzach używano średnika jako separatora kolumn i symbolu | jako separatora wierszy, więc typowe wyrażenie wbudowanej macierzy dla siatki 5 x 2 wyglądało tak:

={1;2;3;4;5|6;7;8;9;10}

Zmieniając separatory kolumn na przecinki i separatory wierszy na średniki, to samo wyrażenie będzie wyglądało w ten sposób:

={1,2,3,4,5;6,7,8,9,10}

Detailed Calculation Settings

Sets the rules for conversion from strings values to numeric values, string values to cell references, and strings values to date and time values. This affects built-in functions such as INDIRECT that takes a reference as a string value or date and time functions that takes arguments as string values in local or ISO 8601 formats.

Oblicz ponownie przy ładowaniu pliku

Ponowne obliczanie formuł może zająć dużo czasu podczas ładowania bardzo dużych plików.

Excel 2007 i nowszy:

Ładowanie dużego pliku arkusza kalkulacyjnego może zająć dużo czasu. Jeśli nie musisz od razu aktualizować danych dużego arkusza kalkulacyjnego, możesz odroczyć przeliczenie do bardziej odpowiedniego momentu. LibreOffice pozwala na odroczenie przeliczania arkuszy kalkulacyjnych Excel 2007 (i wyżej) w celu przyspieszenia czasu ładowania.

Arkusz kalkulacyjny ODF (nie zapisany przez LibreOffice):

Ostatnie wersje LibreOffice buforują wyniki formuł arkusza kalkulacyjnego w pliku ODF. Ta właściwość pomaga szybciej LibreOffice ponownie obliczyć duże pliki ODF arkusza kalkulacyjnego zapisanych przez LibreOffice.

Dla arkuszy kalkulacyjnych ODF zapisanych przez inne programy w których takie buforowane wyniki formuł mogą nie istnieć, przeliczanie można odroczyć w celu przyspieszenia ładowania plików jak z plikami Excel 2007.

Dla wyżej podanych pozycji możliwy jest następujący wybór:

tip

Zapisane arkusze kalkulacyjne ODF LibreOffice będą przestrzegały opcji Nigdy nie obliczaj ponownie i Zawsze obliczaj ponownie.


Please support us!