funkcja NR.BŁĘDU

Zwraca liczbę reprezentującą określony numer błędu lub wartość błędu #NIE DOTYCZY, jeśli błąd nie występuje.

tip

This function is available since LibreOffice 5.0.


Składnia

NR.BŁĘDU(Wartość_błędu)

Wartość_błędu – argument wymagany. Wartość błędu lub odwołanie do komórki, której wartość musi być przetworzona.

Wartość błędu

Zwraca

BŁĄD:511

1

#DZIEL/0!

2

#ARG!

3

#ODWOŁANIE!

4

#NAZWA?

5

#LICZBA!

6

#N/D

7

Cokolwiek jeszcze

#N/D


note

Funkcja ta jest częścią standardu Open Document Format for Office Applications (OpenDocument) w wersji 1.2. (ISO/IEC 26300:2-2015)


Przykład

Proste użycie

=NR.BŁĘDU(#N/D)

Zwraca 7, ponieważ 7 jest numerem indeksu wartości błędu #N/D.

=NR.BŁĘDU(A3)

Jeśli A3 zawiera równowartość wyrażenia do podziału przez zero, funkcja zwraca 2, ponieważ 2 jest numerem indeksu wartości błędu #DZIEL/0!

Bardziej zaawansowany sposób

Jeśli w dzieleniu A1 przez A2, A2 może dążyć do zera, z zaistniałą sytuacją można poradzić sobie w następujący sposób:

=JEŻELI(CZY.BŁĄD(A1/A2);JEŻELI(NR.BŁĘDU(A1/A2)=2;"mianownik nie może być równy zeru");A1/A2)

Funkcja CZY.BŁĄD zwraca PRAWDA lub FAŁSZ w zależności od tego czy błąd występuje, czy też nie. Jeśli błąd występuje, funkcja JEŻELI zwraca się do drugiego argumentu. Jeśli błąd nie występuje, zwraca wynik podziału. Drugi argument sprawdza numer indeksu reprezentujący określony numer błędu, i jeśli jest równy do 2, zwraca określony tekst "mianownik nie może być równy zeru", a w przeciwnym wypadku zwraca 0. Czysty tekst może oznaczać podział przez zero. Jeśli podział jest poprawny, wyniki zostanie zwrócony. Jeśli wystąpi błąd innego rodzaju, może zostać zwrócone zero.

Ikona ostrzeżenia

Jeśli funkcja NR.BŁĘDU jest użyta jako warunek funkcji JEŻELI i zwraca #N/D, funkcja JEŻELI także zwróci #N/D. Użyj funkcji CZY.BŁĄD, aby uniknąć opisane zachowania, tak jak jest to w przykładzie zaprezentowanym powyżej.


Please support us!