Funkcje logiczne

This category contains the Logical functions.

Obsługa nielogicznych argumentów w funkcjach logicznych

Aby wykonać tę operację...

Insert - Function - Category Logical


CZY.BRAK

Zwraca wartość PRAWDA, jeśli komórka zawiera wartość błędu #NIE DOTYCZY.

Jeśli wystąpi błąd, funkcja zwraca wartość FAŁSZ.

Składnia

CZY.BRAK(wartość)

Wartość jest testowaną wartością lub wyrażeniem.

Przykład

=CZY.BRAK(D3) zwraca FAŁSZ.

JEŻELI.BŁĄD

Zwraca wartość jeśli komórki nie zawiera wartości błędu, lub wartość alternatywną, jeśli posiada.

tip

This function is available since LibreOffice 4.0.


Składnia

IFERROR(Value; Alternate_value)

Wartość jest wartością lub wyrażeniem, które ma być zwracane, jeśli wynik nie jest równy lub jest błędem.

Wartość_alternatywna jest wartością lub wyrażeniem, które ma być zwracane jeśli wyrażenie lub wartość Wartości jest równe lub wynik jest błędem.

Przykład

=JEŻELI.BŁĄD(C8;C9) dla komórki C8 zawierającej =1/0 zwracana jest wartość C9, ponieważ 1/0 jest błędem.

=JEŻELI.BŁĄD(C8;C9) dla komórki C8 zawierającej 13 zwracana jest 13, wartość C8 nie jest błędem.

IFS

IFS is a multiple IF-function.

SWITCH

SWITCH compares expression with value1 to valuen and returns the result belonging to the first value that equals expression. If there is no match and default_result is given, that will be returned.

FAŁSZ

Zwraca wartość logiczną FAŁSZ Funkcja FAŁSZ() nie wymaga argumentów i zawsze zwraca wartość logiczną FAŁSZ.

Składnia

FAŁSZ()

Przykład

=FAŁSZ() zwraca wartość FAŁSZ

=NIE(FAŁSZ()) zwraca wartość PRAWDA

I

Zwraca PRAWDĘ jeśli wszystkie argumenty to PRAWDA. Jeśli jeden z argumentów to FAŁSZ wtedy funkcja zwraca FAŁSZ.

Argumenty to wyrażenia logiczne (PRAWDA, 1<5, 2+3=7, B8<10) zwracające wartość logiczną lub macierze (A1:C3) zawierające wartości logiczne.

Składnia

AND(Logical 1 [; Logical 2 [; … [; Logical 255]]])

Logical 1, Logical 2, … , Logical 255 are boolean values, references to cells or to cell ranges of logical values.

note

This function ignores any text or empty cell within a data range. If you suspect wrong results from this function, look for text in the data ranges. To highlight text contents in a data range, use the value highlighting feature.


Przykład

Należy sprawdzić wartości logiczne wyrażeń 12<13; 14>12 i 7<6:

=I(12<13;14>12;7<6) zwraca wartość FAŁSZ.

=I(FAŁSZ; PRAWDA) zwraca wartość FAŁSZ.

JEŻELI

Wykonuje test logiczny.

Składnia

IF(Test [; [ThenValue] [; [OtherwiseValue]]])

Test jest wyrażeniem mogącym przybierać wartość PRAWDA lub FAŁSZ.

Wtedy_wartość (parametr opcjonalny) jest wartością zwracaną przez funkcję, jeśli Test zwraca PRAWDA.

W_przeciwnym_razie_wartość (parametr opcjonalny) jest wartością zwracaną przez funkcję, jeśli Test zwraca FAŁSZ.

In the LibreOffice Calc functions, parameters marked as "optional" can be left out only when no parameter follows. For example, in a function with four parameters, where the last two parameters are marked as "optional", you can leave out parameter 4 or parameters 3 and 4, but you cannot leave out parameter 3 alone.

Przykład

=IF(A1>5;100;"too small") If the value in A1 is greater than 5, the value 100 is returned; otherwise, the text too small is returned.

=IF(A1>5;;"too small") If the value in A1 is greater than 5, the value 0 is returned because empty parameters are considered to be 0; otherwise, the text too small is returned.

=IF(A1>5;100;) If the value in A1 is less than 5, the value 0 is returned because the empty OtherwiseValue is interpreted as 0; otherwise 100 is returned.

LUB

Zwraca PRAWDĘ jeśli co najmniej jeden argument to PRAWDA. Funkcja zwraca FAŁSZ jeśli wszystkie argumenty mają wartość FAŁSZ.

Argumenty to wyrażenia logiczne (PRAWDA, 1<5, 2+3=7, B8<10) zwracające wartość logiczną lub macierze (A1:C3) zawierające wartości logiczne.

Składnia

OR(Logical 1 [; Logical 2 [; … [; Logical 255]]])

Logical 1, Logical 2, … , Logical 255 are boolean values, references to cells or to cell ranges of logical values.

note

This function ignores any text or empty cell within a data range. If you suspect wrong results from this function, look for text in the data ranges. To highlight text contents in a data range, use the value highlighting feature.


Przykład

Należy sprawdzić wartości logiczne wyrażeń 12<11; 13>22, i 45=45.

=LUB(12<11;13>22;45=45) zwraca wartość PRAWDA.

=LUB(FAŁSZ;PRAWDA) zwraca wartość PRAWDA.

NIE

Uzupełnia (odwraca) wartość logiczną.

Składnia

NIE(Wartość logiczna)

Wartość_logiczna jest wartością, która ma zostać uzupełniona.

Przykład

=NIE(A). Jeśli A=PRAWDA, funkcja NIE(A) zwróci wartość FAŁSZ.

PRAWDA

Wartość logiczna jest ustawiana na PRAWDA. Funkcja PRAWDA() nie wymaga argumentów i zawsze zwraca wartość PRAWDA.

Składnia

PRAWDA()

Przykład

Jeśli A=PRAWDA i B=FAŁSZ:

=I(A;B) zwraca wartość FAŁSZ

=LUB(A;B) zwraca wartość PRAWDA

=NIE(I(A;B)) zwraca wartość PRAWDA

XOR

Zwraca prawdę, jeśli nieparzysta liczba argumentów ma wartość PRAWDA.

Argumenty to wyrażenia logiczne (PRAWDA, 1<5, 2+3=7, B8<10) zwracające wartość logiczną lub macierze (A1:C3) zawierające wartości logiczne.

tip

This function is available since LibreOffice 4.0.


Składnia

XOR(Logical 1 [; Logical 2 [; … [; Logical 255]]])

Logical 1, Logical 2, … , Logical 255 are boolean values, references to cells or to cell ranges of logical values.

Przykład

=XOR(PRAWDA; PRAWDA) zwraca wartość FAŁSZ

=XOR(PRAWDA;PRAWDA;PRAWDA) zwraca wartość PRAWDA

=XOR(FAŁSZ;PRAWDA) zwraca wartość PRAWDA

Please support us!