Konvertera tekst til tal

Standardinnstillingane i Calc konverterer tekst i celler til dei respektive numeriske verdiane viss eintydig konvertering er mogleg. Er dette ikkje mogleg, returnerer Calc feilen #VERDI!.

Berre heiltal saman med eksponent vert konverterte , i tillegg også ISO 8601-datoar og -klokkeslett i utvida format med skiljeteikn. Alt anna, som desimalbrøkar eller andre datoar enn ISO 8601, vert ikkje konverterte fordi tekststrengen kan variera etter kva språk som er i bruk. Mellomrom før og etter vert ignorerte.

Desse ISO 8601-formata vert konverterte:

Koden CC står for hundreåret og kan ikkje sløyfast. I staden for T, som er skiljeteiknet mellom dato- og tidsformatet, kan du bruka (nøyaktig) eitt mellomrom.

Dersom ein dato er brukt, må han vere ein gyldig Gregoriansk kalenderdato. I dette tilfellet må klokkeslettet vere i intervallet 00:00 til 23:59:59.99999…

Dersom berre ein tidsstreng er gjeven, kan han ha timetal større enn 24 medan minutt og sekund ikkje må vera større enn 59.

note

Konverteringa vert gjort berre for enkeltskalare verdiar, ikkje for eit område.


Konverteringa er gjort for enkeltskalerbare verdiar, som i «= A1 + A2», eller »= "1E2" +1». Argumenta for celleområdet vert ikkje påverka. «SUMMER (A1: A2)» skill seg frå «A1 + A2» viss minst ei av dei to cellene inneheld ein konvertibel streng.

Tekststrengar i formlar vert også konverterte. T.d. vil ="1999-11-22"+42 returnera datoen 42 dagar etter 22. november 1999. Utrekningar som involverer lokaliserte datoar som ein streng inne i formlar returnerer ein feil. For eksempel kan dei lokaliserte datostrengane "11/22/1999" eller "22.11.1999" ikkje brukast i automatiske konverteringar.

warning

Når du brukar funksjonar der eitt eller fleire argument er søkjekriterium som representerer eit regulært uttrykk, vert det først prøvd å konvertera strengkriteria til tal. For eksempel vert «.0» konvertert til 0.0 og så vidare. Viss dette går bra, vil treffet ikkje vera eit vanleg uttrykk, men eit numerisk treff. Når du brukar eit språk som ikkje brukar punktum som desimalskiljeteikn, som i norsk, vil konverteringa av regulære uttrykk fungera. For å tvinga evalueringa av det regulære uttrykket i staden for eit numerisk uttrykk, bruk eit uttrykk som ikkje kan feiltolkast som numerisk, for eksempel «. [0]» eller «". \ 0» eller «(? I) .0».


Eksempel

I A1 skriv du inn inn teksten '1e2 (som internt vert omforma til talet 100).

I A2 skriv du inn = A1 + 1 (som korrekt resulterer i 101).

Formelen=SUMMER(A1:A2) returnerer 101 i staden for 201 fordi omforminga ikkje vert gjort i eit område, berre for enkeltskalare verdiar. Her vert «'1e2» handsama som ein streng som vert ignorert i SUMMER-funksjonen.

= SUMMER ("1E2"; 1) returnerer #VERDI! fordi SUMMER () og nokre andre som går over talsekvensar kontrollerer argumenttypen spesielt.

Endrar standardteksten til talkonvertering

Konvertering av tekst til tal kan tilpassast i innstillingane Detaljerte innstillingar for utrekningar.

Støtt oss!