Tekst naar getallen converteren

Standaardinstellingen in Calc converteert tekst in cellen naar de respectieve numerieke waarden, als een eenduidige conversie mogelijk is. Als er geen conversie mogelijk is, retourneert Calc een #WAARDE! fout.

Alleen gehele getallen inclusief exponent worden geconverteerd en ISO 8601 datums en tijden in hun uitgebreide opmaak met scheidingstekens. Al het andere, zoals breukgetallen met decimale scheidingstekens of datums anders dan ISO 8601, wordt niet geconverteerd, omdat de tekenreeks lokale afhankelijk is. Voorloop- en volgspaties worden genegeerd.

De volgende opmaken in ISO 8601 worden geconverteerd:

De code voor de eeuw CC mag niet worden weggelaten. In plaats van het scheidingsteken T voor datum en tijd, mag exact één spatie worden gebruikt.

Indien een datum wordt opgegeven moet het een geldige datum voor de Gregoriaanse kalender zijn. In dit geval moet de optionele tijd in het bereik 00:00 tot en met 23:59:59.99999.. liggen.

Indien alleen een tijdreeks wordt opgegeven, mag het een waarde in uren hebben die groter is dan 24, terwijl minuten en seconden een maximum waarde kunnen hebben van 59.

note

De conversie gebeurt alleen voor enkele scalaire waarden, niet binnen bereik.


De conversie wordt uitgevoerd voor enkele scalaire waarden, zoals in =A1+A2 of ="1E2"+1. Celbereikargumenten worden niet beïnvloed, dus SOM(A1:A2) verschilt van A1+A2 als ten minste één van de twee cellen een converteerbare tekenreeks bevat.

Tekenreeksen binnen formules worden ook geconverteerd, zoals in ="22-11-1999"+42, dat de datum teruggeeft die 42 dagen na 22 november 1999 ligt. Berekeningen die gelocaliseerde datums als tekenreeksen bevatten binnen de formule geven een fout terug. De gelocaliseerde datumreeks "11/22/1999" of "22.11.1999" kan, bijvoorbeeld, niet worden gebruikt voor de automatische conversie.

warning

When using functions where one or more arguments are search criteria strings that represents a regular expression, the first attempt is to convert the string criteria to numbers. For example, ".0" will convert to 0.0 and so on. If successful, the match will not be a regular expression match but a numeric match. However, when switching to a locale where the decimal separator is not the dot makes the regular expression conversion work. To force the evaluation of the regular expression instead of a numeric expression, use some expression that can not be misread as numeric, such as ".[0]" or ".\0" or "(?i).0".


Voorbeeld

Voer in A1 de tekst '1e2 in (die intern naar het getal 100 wordt geconverteerd).

Voer in A2 =A1+1 in (wat correct resulteert in 101).

The formula =SUM(A1:A2), returns 101 instead of 201 because the conversion does not occur in a range, only for single scalar values. Here, '1e2 is treated as string which is ignored for the SUM function.

=SOM("1E2";1) retourneert #WAARDE! omdat SOM() en enkele anderen die nummerreeksen herhalen, het argumenttype expliciet controleren.

De standaardtekst wijzigen in instellingen voor nummerconversie

De conversie van tekst naar nummer kan in de optie Detailed Calculation Settings worden aangepast

Help ons, alstublieft!