AANTAL.ALS-functie

Geeft het aantal cellen die aan criteria in meerdere bereiken voldoen.

tip

Deze functie is beschikbaar sinds LibreOffice 4.0.


Syntaxis

COUNTIFS(Range1; Criterion1[; Range2; Criterion2][; ... ; [Range127; Criterion127]])

Range1 – required argument. It is a range of cells, a name of a named range, or a label of a column or a row, to which the corresponding criterion is to be applied.

Criterium1 – vereist argument. Een tekenreeks die een logische voorwaarde vertegenwoordigt of een celverwijzing naar een dergelijke reeks. De expressie kan tekst, cijfers, reguliere expressies of jokertekens bevatten (indien ingeschakeld in berekeningsopties).

Bereik2 – Optioneel. Bereik2 en alle volgende hebben dezelfde betekenis als Bereik1.

Criterium2 – Optioneel. Criterium2 en alle volgende hebben dezelfde betekenis als Criterium1.

The search supports wildcards or regular expressions. With regular expressions enabled, you can enter "all.*", for example to find the first location of "all" followed by any characters. If you want to search for a text that is also a regular expression, you must either precede every character with a "\" character, or enclose the text into \Q...\E. You can switch the automatic evaluation of wildcards or regular expression on and off in - LibreOffice Calc - Calculate.

warning

When using functions where one or more arguments are search criteria strings that represents a regular expression, the first attempt is to convert the string criteria to numbers. For example, ".0" will convert to 0.0 and so on. If successful, the match will not be a regular expression match but a numeric match. However, when switching to a locale where the decimal separator is not the dot makes the regular expression conversion work. To force the evaluation of the regular expression instead of a numeric expression, use some expression that can not be misread as numeric, such as ".[0]" or ".\0" or "(?i).0".


Bereik1, Bereik2, ... en Criterium1, Criterium2, ....moeten hetzelfde formaat hebben, anders geeft de functie fout:502 - Ongeldig argument.

note

De logische relatie tussen criteria kan worden gedefinieerd als logische EN (conjunctie). Met andere woorden, als en alleen als aan alle gegeven criteria is voldaan, wordt een waarde uit de overeenkomstige cel van de gegeven Functiebereik in de berekening meegenomen.


De functie kan maximaal 255 argumenten bevatten, wat betekent dat u 127 bereiken en voorwaarden kunt opgeven.

Als een cel WAAR bevat, wordt het behandeld als 1, als een cel ONWAAR bevat als 0 (nul).

Notitiepictogram

Deze functie maakt deel uit van het Open Document Format voor Office Applications (OpenDocument) standaard versie 1.2. (ISO/IEC 26300: 2-2015)


Voorbeeld

Overweeg de volgende tabel

A

B

C

1

Productnaam

Verkopen

Ontvangsten

2

potlood

20

65

3

pen

35

85

4

kladblok

20

190

5

boek

17

180

6

etui

niet

niet


warning

In alle onderstaande voorbeelden, bevatten bereiken voor berekening de rij # 6, die genegeerd wordt omdat deze tekst bevat.


Eenvoudig gebruik

=AANTALLEN.ALS(B2:B6">=20")

Telt het aantal rijen van het bereik B2:B6 die waarden groter dan of gelijk aan 20 bevatten. Dit geeft 3, omdat de vijfde en zesde rij niet aan het criterium voldoen.

=AANTALLEN.ALS(B2:B6;">=20";C2:C6;">70")

Telt het aantal rijen dat tegelijkertijd waarden groter dan 70 bevatten in het bereik C2:C6 en waarden groter dan of gelijk aan 20 in het bereik B2:B6. Dit geeft 2, omdat de tweede, de vijfde en de zesde rij niet voldoen aan tenminste één criterium.

Met behulp van reguliere expressies en geneste functies

=AANTAL.ALS(B2:B6;"[:Alpha:]*")

Telt het aantal rijen in het bereik B2:B6 die alleen alfabetische symbolen bevatten. Dit geeft 1, want alleen de zesde rij voldoet aan het criterium.

=AANTAL.ALS(B2:B6;">"&MIN(B2:B6);B2:B6;"<"&MAX(B2:B6))

Telt het aantal rijen in het bereik B2:B6 met uitzondering van rijen die minimum en maximum waarden van dit bereik bevatten. Dit geeft 2, omdat de derde, vijfde en zesde rij niet voldoen aan tenminste één criterium.

=AANTAL.ALS(A2:A6;"pen.*";B2:B6;"<"&MAX(B2:B6))

Telt het aantal rijen die overeenkomen met alle cellen van het bereik A2:A6 die beginnen met "pen" en alle cellen van het bereik B2:B6 met uitzondering van zijn maximum. Dit geeft 1, want alleen de tweede rij voldoet aan alle criteria.

Verwijs naar een cel als een criterium

Als u een criterium gemakkelijk moet kunnen veranderen, kunt u dit in een aparte cel opvoeren en gebruik maken van een verwijzing naar deze cel in de voorwaarde van de AANTAL.ALS-functie. De bovenstaande functie kan bijvoorbeeld als volgt worden herschreven:

=AANTAL.ALS(A2:A6;E2&".*";B2:B6;"<"&MAX(B2:B6))

Als E2 = pen, geeft de functie 1, omdat de verwijzing naar de cel wordt vervangen met de inhoud ervan en het werkt als een hierboven genoemde functie.

Open bestand met voorbeeld:

Help ons, alstublieft!