Adresser og referanser, absolutte og relative

Relative adresser

Cellen i kolonne A, rad 1 adresseres som A1. Du kan adresse et område med naboceller ved å først sette inn koordinatene til den øverste, venstre cellen, så et kolon fulgt av koordinatene til den nederste, høyre cellen. For eksempel kan du adressere de fire cellene øverst til venstre med «A1:B2».

Ved å adressere området på denne måten lager du en relativ referanse til A1:B2. Her betyr relativ at referansen til området endres automatisk når du kopierer formlene.

Absolutte adresser

Absolutte referanser er det motsatte av relative adresser. Et dollartegn plasseres foran hver bokstav og hvert tall i absolutte referanser. For eksempel: «$A$1:$B$2».

Tipsikon

LibreOffice kan endre referansen markøren står i på inndatalinja, fra relativ til absolutt og omvendt ved å trykke på Shift + F4. Hvis du har en relativ adresse som «A1» den første gangen du trykker på tastekombinasjonen, blir både raden og kolonnen satt til absolutte referanser ($A$1). Den andre gangen blir bare raden absolutt (A$1), og den tredje gangen bare kolonnen ($A1). Om du trykker en gang til, blir begge deler stilt tilbake til relative (A1).


LibreOffice Calc viser referansene til en formel. Hvis du for eksempel trykker på formelen «=SUMMER(A1:C5;D15:D24)» i en celle, blir de refererte områdene i arket uthevet med en farge. For eksempel kan formelkomponenten «A1:C5» vises i blått og celleområdet vises med kantlinjer i samme farge. Den andre komponenten, «D15:D24», kan markeres i rødt på samme måte.

Bruk av relative og absolutte referanser

La oss si at du vil beregne summen av cellene i området A1:B2 i celle E1. Formelen du skriver inn i E1 ville da være: «=SUMMER(A1:B2)». Hvis du senere velger å sette inn en ny kolonne foran kolonne A, ville området du ville bruke bli B1:C2, og formelen ville være i F1, ikke E1. Etter at du hadde satt inn den nye kolonnen måtte du derfor ha undersøkt og rettet alle formlene i arket og muligens andre ark.

Heldigvis gjør LibreOffice dette for deg. Når du setter inn en ny kolonne A, blir formelen «SUMMER(A1:B2)» automatisk oppdatert til «SUMMER(B1:C2)». Rader blir også oppdatert automatisk når du setter inn en ny rad 1. Absolutte og relative referanser blir alltid justert i LibreOffice Calc når refererte områder blir flyttet. Vær oppmerksom hvis du kopierer formler, for da blir bare relative referanser endret, ikke absolutte referanser.

Absolutte referanser blir brukt når beregninger refererer til bestemte celler i arket. Hvis en formel som refererer til akkurat disse cellene blir kopiert til cellen en rad lenger ned, vil også referansen peke til celler en rad lenger ned hvis koordinatene ikke var absolutte.

Bortsett fra når nye rader og kolonner blir satt inn kan referanser også forandre seg når en formel som refererer til celler blir kopiert til et annet område i arket. Forestill deg at du har skrevet inn formelen «=SUMMER(A1:A9)» i rad 10. Hvis du vil beregne summen i nabokolonnen til høyre, kopierer du helt enkelt denne formelen til cellen til høyre. Kopien av formelen i kolonne B blir automatisk endret til «=SUMMER(B1:B9)».

Supporter oss!