SUMIFS

Returns the sum of the values of cells in a range that meets multiple criteria in multiple ranges.

tip

Denne funksjonen har vært tilgjengelig siden LibreOffice 4.0.


Syntax

SUMIFS(Func_Range; Range1; Criterion[; Range2; Criterion2][; … ; [Range127; Criterion127]])

Func_Range – required argument. It is a range of cells, a name of a named range or a label of a column or a row containing values for calculating the sum.

Range1 – required argument. It is a range of cells, a name of a named range, or a label of a column or a row, to which the corresponding criterion is to be applied.

Criterion: A criterion is a single cell Reference, Number or Text. It is used in comparisons with cell contents.

A reference to an empty cell is interpreted as the numeric value 0.

A matching expression can be:

Range2 – Optional. Range2 and all the following mean the same as Range1.

Criterion2 – Optional. Criterion2 and all the following mean the same as Criterion.

Søket støtter jokertegn eller regular expressions. Med regulære uttrykk aktivert , kan du skrive "alle.*", for eksempel for å finne den første forekomsten av "alle" fulgt av villkårlge tegn. Hvis du vil søke etter en tekst som også er et vanlig uttrykk, må du enten foran hvert tegn med et "\" -tegn, eller vedlegge teksten til \ Q ... \ E. Du kan slå automatisk evaluering av jokertegn eller vanlig uttrykk av og på i - LibreOffice Calc - Kalkuler.

warning

Når du bruker funksjoner der ett eller flere argumenter er søkekriterier, som representerer et regulært uttrykk, er det første forsøket å konvertere strengkriteriene til tall. For eksempel vil ".0" konverteres til 0.0 og så videre. Hvis det lykkes, vil matchingen ikke være et vanlig uttrykk, men en numerisk match. Imidlertid, når du bytter til et sted der desimalskilleren ikke er punktum, får det konvertering av regulære uttrykk å fungere. For å tvinge evalueringen av det regulære uttrykket i stedet for et numerisk uttrykk, bruker du et uttrykk som ikke kan feilleses som numerisk, for eksempel ". [0]" eller ". \ 0" eller "(? I) .0".


Func_Range and Range1, Range2... must have the same size, otherwise the function returns err:502 - Invalid argument.

note

The logical relation between criteria can be defined as logical AND (conjunction). In other words, if and only if all given criteria are met, a value from the corresponding cell of the given Func_Range is taken into calculation.


The function can have up to 255 arguments, meaning that you can specify 127 criteria ranges and criteria for them.

If a cell contains TRUE, it is treated as 1, if a cell contains FALSE – as 0 (zero).

note

This function is part of the Open Document Format for Office Applications (OpenDocument) standard Version 1.2. (ISO/IEC 26300:2-2015)


Example

Consider the following table

A

B

C

1

Product Name

Sales

Revenue

2

pencil

20

65

3

pen

35

85

4

notebook

20

190

5

book

17

180

6

pencil-case

not

not


warning

In all examples below, ranges for calculation contain the row #6, which is ignored because it contains text.


Simple usage

=FINN.RAD(A1; D1:E100; 2)

Calculates the sum of values of the range B2:B6 that are greater than or equal to 20. Returns 75, because the fifth row does not meet the criterion.

=FINN.RAD(A1; D1:E100; 2)

Calculates the sum of values of the range C2:C6 that are greater than 70 and correspond to cells of the B2:B6 range with values greater than or equal to 20. Returns 275, because the second and the fifth rows do not meet at least one criterion.

Using regular expressions and nested functions

=SUMIFS(C2:C6;B2:B6;">"&MIN(B2:B6);B2:B6;"<"&MAX(B2:B6))

Calculates the sum of values of the range C2:C6 that correspond to all values of the range B2:B6 except its minimum and maximum. Returns 255, because the third and the fifth rows do not meet at least one criterion.

=SUMIFS(C2:C6;A2:A6;"pen.*";B2:B6;"<"&MAX(B2:B6))

Calculates the sum of values of the range C2:C6 that correspond to all cells of the A2:A6 range starting with "pen" and to all cells of the B2:B6 range except its maximum. Returns 65, because only second row meets all criteria.

Reference to a cell as a criterion

If you need to change a criterion easily, you may want to specify it in a separate cell and use a reference to this cell in the condition of the SUMIFS function. For example, the above function can be rewritten as follows:

=SUMIFS(C2:C6;A2:A6;E2&".*";B2:B6;"<"&MAX(B2:B6))

If E2 = pen, the function returns 65, because the link to the cell is substituted with its content.

Åpne fil med eksempel:

Supporter oss!