入力支援

ここでは入力支援の登録内容に対する、作成、編集、および挿入が行えます。入力支援の項目としては、書式設定を施されたテキストを始め、図や表やフィールドなどを含めたテキストブロック全体を登録できます。個々の入力支援の登録項目は、ドキュメント上で対応するショートカット文字を入力して F3 キーを押すことで、簡単に挿入できます。

ヒント

挿入 バーの 入力支援 アイコンの横にある矢印をクリックして、挿入する入力支援を選択することもできます。


このコマンドの見つけ方

メニュー 編集 → 入力支援...

+ (F3)

挿入ツールバーでクリック

アイコン

入力支援


テキストブロックを入力支援として使用する

入力支援

入力支援 ダイアログには、入力支援のグループとブロック名のリストが表示されます。

入力中にテキストブロック名をヒント表示する

ユーザーがテキストを入力する際に、入力支援にあるブロック名の最初の 3 文字がタイプされた時点で、該当するブロック名をヒントヘルプの形で表示させます。提示された入力支援の登録データを挿入させるには、Enter キーを押します。一致するブロック名が複数存在する場合、次の候補をヒントヘルプに表示させるには、(Ctrl) + (Tab) を押します。たとえば、「ダミー」と入力して Enter キーを押すと、事前定義されているダミーテキストが挿入されます。

To display the list in reverse order, press +Shift+Tab.

名前

選択中の入力支援の項目名が表示されます。ドキュメント上でテキストが選択中であれば、ここに新規の項目名を入力し、入力支援 をクリックして表示される 新規作成 を選択することで、新規の入力支援の項目として登録できます。

ショートカットキー

選択中の入力支援の項目に対するショートカットキーが表示されます。入力支援の項目を新規に作成する場合は、該当するショートカットキーをここに指定します。

リストボックス

入力支援のグループが表示されます。グループ内の入力支援のブロック名を表示するには、グループをダブルクリックするか、グループの前にあるプラス記号 (+) をクリックします。入力支援を現在のドキュメントに挿入するには、リストからブロック名を選択して、挿入 をクリックします。

ヒント

あるグループから別のグループに入力支援のブロック名を移動するには、そのブロック名をドラッグ&ドロップします。


挿入

選択した入力支援を現在のドキュメントに挿入します。

注マーク

書式設定されていない入力支援を挿入した場合、その入力支援は挿入先の段落のスタイルで書式設定されます。


閉じる

ダイアログを閉じ、すべての変更を保存します。

入力支援

入力支援の項目に対する各種の操作コマンドを、サブメニュー形式で表示します。たとえば、ドキュメント上の選択範囲を基に入力支援の項目を新規作成する機能などが用意されています。

新規作成

ドキュメント上の現在の選択範囲を基にして、新規に入力支援の項目を作成します。項目の登録先は、現在選択中の入力支援グループになります。

新規作成 (テキストのみ)

現在の文書で選択した文字だけを新しい入力支援として追加します。画像、表などその他のオブジェクトは含まれません。この機能を有効にするにはまずブロック名を入力する必要があります。

コピー

選択中の入力支援を、クリップボードにコピーします。

置換

選択した入力支援の内容を、ドキュメント上の現在の選択範囲の内容で置き換えます。

名前の変更

選択中の入力支援の項目名を変更するための、テキストブロックの名前の変更 ダイアログを開きます。

削除

確認メッセージの後、選択した要素 (複数可) を削除します。

編集

選択中の入力支援の項目を、編集用に独立したドキュメントとして開きます。必要な編集を施した後、ファイル → テキストブロックの保存 で変更内容を保存してから、ファイル → 閉じる を選択します。

マクロ

選択中の入力支援へのマクロ割り当てを行うための、マクロの割り当て ダイアログが開きます。

作成する入力支援の項目では、事前に用意されている入力支援の項目の一部にリンクされているマクロを使用することもできます。こういった入力支援の項目は「テキストのみ」オプションで作成する必要があります。たとえば、入力支援の項目に <field:company> という文字列を挿入しておくと、LibreOffice により、この文字列は対応するデータベースフィールドの内容で置き換えられます。

インポート

Microsoft Word (バージョン 97/2000/XP) のドキュメントやテンプレートから入力支援の項目をインポートするためのダイアログを開きます。

グループ...

ここでは入力支援のグループに対する、新規作成、削除、および名前の変更が行えます。

グループの編集

ここでは入力支援のグループに対する、新規作成、削除、および名前の変更が行えます。

グループ名

選択中の入力支援のグループ名が表示されます。グループの名前を変更するのであれば、新しい名前を入力して、名前の変更 をクリックします。新しいグループを作成するのであれば、グループ名を入力して、新規作成をクリックします。

パス

選択中の入力支援のグループが使用している、データファイルの保存用ディレクトリへのパスが表示されます。新規にグループを作成する場合は、グループのデータファイルの保存ディレクトリをここで選択します。

新規作成

新しいグループを作成します。グループ名には、グループ名 ボックスに入力した名前が使用されます。

名前の変更

グループ名 ボックスに入力した名前に、選択中の入力支援のグループの名を変更します。

選択リスト

既存の入力支援のグループおよび該当パスが一覧表示されます。

削除

確認メッセージを表示せず、選択した要素 (複数可) を削除します。

パス

入力支援のデータ保存用ディレクトリを選択するための、パスの編集 ダイアログを開きます。

新しいパスを入力支援ディレクトリに追加するには、入力支援 ダイアログの パス ボタンをクリックします。

リンクの相対保存

ここでは、LibreOffice が入力支援ディレクトリへのリンクを挿入する方法を設定します。

ファイルシステム内

ユーザーのコンピューターにある入力支援ディレクトリへのリンクを、相対パス形式にさせます。

インターネット内

インターネット上にある入力支援ディレクトリへのリンクを、相対パス形式にさせます。

ご支援をお願いします!