Report Builder

Report Builder は、ユーザー独自のデータベースレポートを作成するためのツールです。レポートウィザードと違って、Report Builder を使用すると、レポートを思いどおりにデザインすることができます。生成されたレポートは、編集可能な Writer ドキュメントにもなります。

注マーク

To use the Report Builder, the Report Builder component must be installed. In addition, the Java Runtime Environment (JRE) software must be installed, and this software must be selected in LibreOffice.


JRE ソフトウェアをインストールする

Report Builder では、Java Runtime Environment (JRE) があらかじめインストールされている必要があります。

  1. Choose - LibreOffice - Advanced.

  2. LibreOffice によってシステムの Java ソフトウェアにインストールされている情報が収集されるまで最大 1 分間待ちます。

    システムで JRE の最新バージョンが検出された場合には、リストにその項目があります。

  3. 項目の手前にあるオプションボタンをクリックすると、LibreOffice でこの JRE バージョンが使用できるようになります。

  4. 「Java 実行環境を使用」 が有効になっていることを確認します。

If no JRE version is found on your system, open your web browser and download the JRE software from http://www.java.com. Install the JRE software. Then restart LibreOffice and open - LibreOffice - Advanced again.

Report Builder を開く

  1. ベースファイルを開くか、新しいデータベースを作成します。 データベースには 1 つ以上のデータフィールドと 1 つのプライマリキーフィールドがある 1 つ以上のテーブルを含む必要があります。

  2. Base ウィンドウでレポートのアイコンをクリックし、次にデザイン表示で「レポートの作成」を選択します。

    「Report Builder」ウィンドウが開きます。

Report Builder は 3 つの部分に分かれています。最上部にメニューが表示され、その下にツールバーが表示されます。

右側に、現在選択されているオブジェクトのプロパティ値を示す「プロパティ」ウィンドウが表示されます。

「Report Builder」ウィンドウの左部分に「Report Builder」ビューが表示されます。「Report Builder」ビューは、最初、上から下へ 3 つの部分に分かれています。

  1. ページヘッダー → 固定テキストを持ったコントロールフィールドをページヘッダー領域にドラッグ

  2. 詳細 → そのデータベースフィールドを詳細領域にドラッグ & ドロップ

  3. ページフッター → 固定テキストのコントロールフィールドをページフッター領域にドラッグ

追加の レポートヘッダー および レポートフッター エリアを挿入するには、編集 → レポートヘッダー/フッターの挿入 を選択します。 これらのエリアには、レポート全体の最初と最後に表示されるテキストが含まれます。

エリア名の前の「-」アイコンをクリックすると、そのエリアが「Report Builder」ビューで 1 行に折りたたまれます。「-」アイコンが「+」アイコンに変わり、このアイコンをクリックすると、このエリアは再び展開されます。

「詳細」エリアにドラッグ&ドロップして、データベースフィールドを挿入します。 下の「レポートにフィールドを挿入する」セクションを参照してください。

さらに、ツールバーで「ラベル」フィールドまたはテキストボックスのアイコンをクリックし、ページヘッダーまたはページフッターエリアに四角形をドラッグして、すべてのページで同じなるテキストを指定できます。 対応する「プロパティ」ウィンドウの「ラベル」ボックスにテキストを入力します。 「グラフィックス」アイコンを使用して、グラフィックスを追加することもできます。

レポートをデータベーステーブルに接続する

  1. マウスを「プロパティ」表示に移動させます。 「全般」と「データ」の 2 つのタブページが表示されます。

  2. データタブページで、「内容」をクリックして、コンボボックスを開きます。

  3. レポートを作成するテーブルを選択します。

  4. テーブルを選んだあと、タブキーを押してコンテントボックスから移動します。

The Add fields to report window opens automatically and shows all fields of the selected table.

Add fields to report

The Add Field window helps you to insert the table entries in the report.

「詳細」表示でフィールドを挿入すると、レポートの実行準備が整います。

レポートを実行する

  1. ツールバーのレポートの実行アイコン アイコン をクリックします。

Writer ドキュメントが開いて、作成したレポートが表示されます。このレポートには挿入したデータベーステーブルのすべての値が含まれます。

データベースの内容が変更された場合、もう一度レポートを実行して結果のレポートを更新します。

レポートを編集する

最初に、スタティックな Writer ドキュメントである生成済みのレポートを編集するか、「Report Builder」ビューを編集して、新しいデザインに基づいて新しいレポートを生成するかを決めます。

The Writer document is opened read-only. To edit the Writer document, click Edit Document on the information bar, or choose Edit - Edit Mode.

Report Builder の表示を編集する場合、いくつかのプロパティを変更できます。

「詳細」エリアをクリックします。そして、「プロパティ」ウィンドウで背景の色などの一部のプロパティを変更します。

完了したら、レポートの実行アイコンアイコン をクリックして、新しいレポートを作成します。

Report Builder を閉じると、レポートを保存するかどうかを尋ねられます。「はい」をクリックし、レポートに名前を付けて、「OK」をクリックします。

レポートの並べ替え

並べ替えまたはグループ化を使用しないと、レコードはデータベースから取得した順序でレポートに挿入されます。

  1. Report Builder ビューを開いて、ツールバーの並べ替えおよびグループ化アイコンアイコン をクリックします。並べ替えおよびグループ化 ダイアログが表示されます。

  2. 「グループ」ボックスで、最初の並べ替えフィールドにするフィールドをクリックして、「並べ替え」プロパティを設定します。

  3. レポートを実行します。

グループ化

  1. Report Builder ビューを開いて、ツールバーの並べ替えおよびグループ化アイコン アイコン をクリックします。並べ替えおよびグループ化ダイアログが表示されます。

  2. 「グループ」ボックスで「グループヘッダー」リストボックスを開き、グループヘッダーを表示するように選択します。

  3. フィールドの追加アイコン アイコン をクリックして、フィールドの追加ウィンドウを開きます。

  4. グループ化するフィールドエントリをグループヘッダーセクションにドラッグ&ドロップします。 次に残りのフィールドを「詳細」セクションにドラッグ&ドロップします。

  5. レポートを実行します。 このレポートには、グループ化されたレコードが表示されます。

並べ替えやグループ化を実行する場合は、「Report Builder」ビューを開いて、「並べ替えとグループ化」ダイアログを開きます。グループ化するフィールドのグループヘッダーを表示するように選択し、並べ替えするフィールドのグループヘッダーを非表示にするように選択します。「並べ替えおよびグループ化」ウィンドウを閉じて、レポートを実行します。

データの更新と印刷

新しいデータを挿入するか、テーブルのデータを編集すると、新しいレポートが更新されたデータを表示します。

レポート アイコンアイコン をクリックし、最後に保存したレポートをダブルクリックします。新しいデータを表示している新しい Wrter ドキュメントが作成されます。

レポートを印刷するには、Writer ドキュメントから 「ファイル」 → 「印刷」 を選択します。

ご支援をお願いします!