グラフの種類、株価

On the first page of the Chart Wizard you can choose a chart type.

このコマンドの見つけ方

Choose Insert - Chart...

Icon

Insert Chart


株価

株価チャートは、始値、安値、高値、および終値を要因とした市場動向を示します。 取引高も表示できます。

株価チャートでは、データ系列の順序が重要です。 データは、次のテーブル例で示すように配置してください。

A

B

C

D

E

F

1

取引高

始値

安値

高値

終値

2

月曜日

2500

20

15

25

17

3

火曜日

3500

32

22

37

30

4

水曜日

1000

15

15

17

17

5

木曜日

2200

40

30

47

35

6

金曜日

4600

27

20

32

31


行の始値、安値、高値、および終値が、グラフ内の 1 つのデータ単位を構築します。 株価データ系列は、このようなデータ単位を含む複数の行から構成されます。 取引高を含む列は、オプションの第 2 データ系列を構築します。

選択したバリエーションによっては、すべての列が必要でない場合があります。

株価チャートのバリエーション

Choose the Stock chart type on the first page of the Chart Wizard. Then select one of the four variants.

タイプ1

Based on low and high column the Type 1 shows the distance between bottom price (low) and top price (high) by a vertical line.

Based on low, high, and close column Type 1 shows an additional horizontal mark for the closing price.

タイプ2

始値、安値、高値、終値列に基づいて、タイプ 2 は典型的なローソク足グラフを作成します。タイプ 2 では、安値と高値が縦線で結ばれ、始値と終値の幅が長方形で示されます。長方形をクリックすると、ステータスバーに詳しい情報が表示されます。LibreOffice は始値より終値が高い長方形と始値より終値が低い長方形を異なる色で表示します。

タイプ3

出来高、安値、高値、終値に基づいて、タイプ 3 の縦棒グラフはタイプ 1 のグラフに、出来高を示す縦棒グラフを加えたようなグラフになります。

タイプ4

出来高、始値、安値、高値、終値の 5 つすべてのデータに基づいて、タイプ 4 のグラフは、タイプ 2 のグラフと出来高を示す縦棒グラフを 1 つにします。

出来高の測定は特定の単位に基づいて行われる場合があるので、タイプ 3 グラフとタイプ 4 グラフでは、第 2 y 軸が使われています。株価軸が右側に表示され、出来高軸が左側に表示されます。

データソースの設定

独自のデータに基づくグラフ

To change the data series of a chart having its own data, choose Chart Data Table from the View menu or from the context menu of the chart in edit mode.

埋め込みグラフのデータテーブルでは、データ系列が常に列で管理されます。

For a new stock chart first use a column chart. Add the columns you need and enter your data in the order which is shown in the example, omitting any columns not required for the desired variant. Use Move Series Right to change the column order. Close the chart data table. Now use the Chart Type dialog to change to the stock chart variant.

株価チャートがすでにあり、そのバリエーションを変更する場合は、最初にグラフの種類を縦棒グラフに変更し、そのバリエーションに合わせて列を追加または削除してから、グラフの種類を株価チャートにふたたび変更します。

行にデータ系列の名前を書き込まないでください。 名前は、ロール名の上のフィールドに書き込んでください。

行の順序によって、カテゴリがグラフ内でどのように配置されるかが決まります。順序を変更するには、「行の入れ替え」を使用します。

Calc または Writer テーブルに基づくグラフ

You can choose or alter a data range on the second page of the Chart Wizard or in the Data Range dialog. For fine tuning use the Data Series dialog.

データ範囲を指定するには、次のいずれかの操作を行います。

  1. このテキストボックスには、データ範囲を入力します。

    Calc では、データ範囲の例は「$Sheet1.$B$3:$B$14」です。 データ範囲は、表計算ドキュメントの複数の範囲から構成される場合があります。たとえば、「$Sheet1.A1:A5;$Sheet1.D1:D5」も有効なデータ範囲です。 Writer では、データ範囲の例は「Table1.A1:E4」です。

    構文が正しくないと、LibreOffice はテキストを赤で表示します。

  1. In Calc, click Select data range to minimize the dialog, then drag to select the data range. When you release the mouse, the data are entered. Click Select data range again to add a data range. In the input field of the minimized dialog, click after the entry and type a semicolon. Then drag to select the next range.

行または列で、データ系列のオプションの 1 つをクリックします。

行の情報が同じ「ローソク足」に属する場合、株価チャートデータは、「列内」にあります。

表に基づく株価チャートのデータ範囲の微調整

You can organize data series and edit the source for parts of single data series on the third page of the Chart Wizard or on the page Data Series in the Data Range dialog.

データ系列の管理

ダイアログ左側のデータ系列領域で、実際のグラフのデータ系列を整理することができます。株価グラフは、少なくとも 1 つの株価データ系列を含んでいる必要があります。そのほかに、出来高のデータ系列を含んでいることもあります。

1 つ以上の価格データがある場合には、上矢印と下矢印のボタンを使ってデータを並べ替えてください。並び順はグラフでの配置に反映されます。売上高データについても同じことを行なってください。株価データと出来高データを交換することはできません。

データ系列を削除するには、リストからそのデータ系列を選んで、削除をクリックします。

データ系列を追加する場合は、既にあるデータ系列のうちの 1 つを選択し、追加をクリックします。選択したものの直下に、同じタイプの空のエントリが作られます。価格と売上高のデータがない場合には、初めに、データ範囲ダイアログで、これらのデータの範囲を選択する必要があります。

データ範囲の設定

「データ範囲」ダイアログで、選択したデータ系列の各コンポーネントのデータ範囲を設定または変更できます。

上部のリストには、コンポーネントのロール名と現在値が示されます。「ロール」の1つを選択すると、リストの下のテキストボックスの値を変えることができます。ラベルは選択されたロールを示しています。

テキストボックスに範囲を入力するか、データ範囲の選択 をクリックして、ダイアログを最小化し、マウスで範囲を選択します。

「始値」、「終値」、「高値」、および「安値」を任意の順序で選択します。 株価チャートの選択したバリエーションに必要なロールの範囲のみ指定します。 範囲は、テーブル内で隣どうしにある必要はありません。

凡例

凡例には、最初の行、最初の列、またはデータ系列ダイアログで指定した特定の範囲で使われているラベルが表示されます。作成したグラフにラベルがない場合、凡例には、グラフデータの行番号や列名に従って、「行 1」「行 2」...、「列 A」「列 B」...などと表示されます。

データ範囲ダイアログのデータ範囲フィールドに入力した範囲名が凡例に表示されます。フィールドにはデフォルト値として、終値列の見出しが入力されています。

位置オプションのいずれかを選択します。 グラフが完成したら、「書式」メニューを使用して、ほかの位置を指定できます。

ご支援をお願いします!