Képlet

Képletszintaxis- és betöltési beállításokat ad meg a LibreOffice Calchoz.

Ennek a parancsnak az eléréséhez...

Open a spreadsheet document, choose - LibreOffice Calc - Formula.


Képlet beállításai

Képletszintaxis

Három lehetőség van, ezeket példákon keresztül mutatjuk be. Egy példa munkafüzetben két munkalap van, a Munkalap1 és Munkalap2. A Munkalap1 A1 cellájában található egy hivatkozás a Munkalap2 C4 cellájára.

Angol függvénynevek használata

A LibreOffice Calc függvénynevek lokalizálhatók. Alapértelmezésben a négyzet nincs bejelölve, vagyis a lokalizált függvénynevek lesznek használva. Ezen négyzet bejelölése a lokalizált függvényneveket lecseréli az angol megfelelőikre. Ez a változtatás a következő területek mindegyikén életbe lép: képletbevitel és -megjelenítés, függvénytündér és képlettippek. Az ismételt törlésével természetesen visszatérhet a lokalizált függvénynevekhez.

Elválasztó jelek

Ez a beállításcsoport lehetővé teszi az elválasztó jelek beállítását a képletkifejezésekben. Ez akkor hasznos, amikor például a függvényparamétereket vesszőkkel (,) szeretné elválasztani pontosvesszők (;) helyett.

A =SZUM(A1;B1;C1) helyett írhat például =SZUM(A1,B1,C1)-et.

Hasonlóképpen megváltoztathatja a sor- és oszlopelválasztókat a beágyazott tömbökhöz. Korábban a beágyazott tömbök pontosvesszőket (;) használtak oszlopelválasztóként, és a cső szimbólumát (|) sorelválasztóként, így egy tipikus beágyazott tömbkifejezés például a következőképpen nézett ki egy 5X2-es mátrixtömb esetén:

={1;2;3;4;5|6;7;8;9;10}

Az oszlopelválasztók vesszőkre (,) és a sorelválasztók pontosvesszőkre (;) cserélésével ugyanez a kifejezés így fog kinézni:

={1,2,3,4,5;6,7,8,9,10}

Detailed Calculation Settings

Sets the rules for conversion from strings values to numeric values, string values to cell references, and strings values to date and time values. This affects built-in functions such as INDIRECT that takes a reference as a string value or date and time functions that takes arguments as string values in local or ISO 8601 formats.

Újraszámolás fájlbetöltéskor

Ennek a parancsnak az eléréséhez...

Choose - LibreOffice Calc - Formula.


A képletek újraszámolása jelentős időt vehet igénybe nagy fájlok betöltése esetén.

Excel 2007 és újabb:

Loading a large spreadsheet file can take a long time. If you don't need to update your large spreadsheet data immediately, you can postpone the recalculation at a better time. LibreOffice allows you to defer recalculation of Excel 2007 (and above) spreadsheets to speedup loading time.

ODF táblázat (nem a(z) LibreOffice által mentett):

Recent versions of LibreOffice caches spreadsheet formula results into its ODF file. This feature helps LibreOffice to recalculate a large ODF spreadsheet saved by LibreOffice faster.

A más programok által mentett ODF-fájlokban nem feltétlenül van jelen ez az előre kiszámított eredmény, ezért az újraszámolást el lehet halasztani a gyorsabb fájlbetöltés érdekében az Excel 2007-es fájlokhoz hasonló módon.

A fentiekhez a következő választási lehetőségek tartoznak:

Tipp ikon

A LibreOffice által mentett ODF-munkafüzetek figyelembe veszik a Ne számolja újra és az Újraszámolás mindig beállításokat.


Please support us!