Címek és hivatkozások, abszolút és relatív

Relatív címzés

Az A oszlop 1. sorában levő cella címe A1. Egymás melletti cellák tartományát úgy lehet megcímezni, hogy először megadja a bal felső cella koordinátáit, majd beír egy kettőspontot, amelyet a jobb alsó cella koordinátáinak kell követnie. Például a bal felső sarokban levő cellák által formált négyzet megcímzéséhez a következőt kell beírni: A1:B2.

Egy terület ilyen módon megcímzésével egy relatív hivatkozást hoz létre az A1:B2 tartományhoz. A relatív itt azt jelenti, hogy e terület hivatkozása a képletek másolásánál automatikusan módosul.

Abszolút címzés

Absolute referencing is the opposite of relative addressing. A dollar sign is placed before each letter and number in an absolute reference, for example, $A$1:$B$2.

Tipp ikon

LibreOffice can convert the current reference, in which the cursor is positioned in the input line, from relative to absolute and vice versa by pressing F4. If you start with a relative address such as A1, the first time you press this key combination, both row and column are set to absolute references ($A$1). The second time, only the row (A$1), and the third time, only the column ($A1). If you press the key combination once more, both column and row references are switched back to relative (A1)


LibreOffice Calc shows the references to a formula. If, for example, you click the formula =SUM(A1:C5;D15:D24) in a cell, the two referenced areas in the sheet will be highlighted in color. For example, the formula component "A1:C5" may be in blue and the cell range in question bordered in the same shade of blue. The next formula component "D15:D24" can be marked in red in the same way.

Mikor használandó a relatív és az abszolút címzés

Mi különbözteti meg a relatív hivatkozásokat? Tegyük fel, hogy az E1 cellában ki kívánja számítani az A1:B2 cellatartományban található cellák összegét. Az E1 cellába a következő képlet kell beírnia: =SZUM(A1:B2). Ha később úgy dönt, hogy egy új oszlopot szúr be az A oszlop elé, akkor az összeadni kívánt elemek a B1:C2 tartományban lesznek, a képlet pedig az F1 cellában lesz, nem az E1 cellában. Így az új oszlop beszúrása után a munkalap valamennyi képletét le kellene ellenőriznie, és talán ki is kellene javítania, esetleg a többi munkalapon lévőkkel együtt.

Szerencsére a LibreOffice ezt elvégzi a felhasználó helyett. Az új A oszlop beszúrását követően a =SZUM(A1:B2) képlet automatikusan frissítésre kerül, és =SZUM(B1:C2) lesz belőle. A sorszámok hasonlóképpen automatikusan beállításra kerülnek akkor, amikor egy új 1. sor kerül beszúrásra. A LibreOffice Calc programban használt abszolút és relatív hivatkozások a hivatkozott területek áthelyezésekor mindig beállításra kerülnek. Azonban a képletek másolásakor gondosan járjon el, mivel ebben az esetben csak a relatív hivatkozások kerülnek beállításra, az abszolút hivatkozások nem.

Az abszolút hivatkozásokat akkor használja, ha egy számítás a munkalap egy megadott cellájára hivatkozik. Ha egy olyan képletet, amely pontosan erre a cellára hivatkozik, az eredeti cella alatti cellába másol, akkor a hivatkozás is lejjebb kerül abban az esetben, ha a cellakoordinátákat nem abszolút módon határozta meg.

A sorok, illetve oszlopok beszúrásán kívül a hivatkozások akkor is változhatnak, amikor egy adott cellákra hivatkozó meglévő képletet átmásol a munkalap egy másik területére. Tegyük fel, hogy a 10. sorba a következő képletet írta: =SZUM(A1:A9). Ha a jobbra található szomszédos oszlop összegét kívánja kiszámítani, akkor egyszerűen másolja a képletet a jobbra található cellába. A képlet B oszlopba való másolásakor az automatikusan a következőre módosul: =SZUM(B1:B9).

Támogasson minket!