Üres cellák kezelése

A szoftver régebbi verzióiban az üres cellák bizonyos kontextusban numerikus 0 értéket kaptak, míg más esetekben üres karakterláncot, kivéve a közvetlen összehasonlítás esetén, ahol az =A1=0 és az =A1="" egyaránt IGAZ értéket eredményezett, ha A1 üres volt. Az üresség most öröklődik a használatig, így az =FKERES(...)=0 és az =FKERES(...)="" függvény IGAZ értéket ad vissza, ha a keresés üres cellát talál.

Az üres cellára mutató egyszerű hivatkozás még mindig numerikus 0-ként jelenik meg, de nem feltétlenül numerikus típusként, így a hivatkozó cellával történő összehasonlítás az elvárt módon működik.

Az alábbi példák esetén az A1 egy számot tartalmaz, a B1 üres, a C1 hivatkozik a B1-re:

Case

Formula

Results and comments

A1: 1
B1: <Empty>

C1: =B1

Displays 0

=B1=0

TRUE

=B1=""

TRUE

=C1=0

TRUE

=C1=""

TRUE (previously was FALSE)

=ISNUMBER(B1)

FALSE

=ISNUMBER(C1)

FALSE (previously was TRUE)

=ISNUMBER(VLOOKUP(1;A1:C1;2))

FALSE (B1)

=ISNUMBER(VLOOKUP(1;A1:C1;3))

FALSE (C1, previously was TRUE)

=ISTEXT(B1)

FALSE

=ISTEXT(C1)

TRUE

=ISTEXT(VLOOKUP(1;A1:C1;2))

FALSE (B1, previously was TRUE)

=ISTEXT(VLOOKUP(1;A1:C1;3))

FALSE (C1)

=ISBLANK(B1)

TRUE

=ISBLANK(C1)

TRUE

=ISBLANK(VLOOKUP(1;A1:C1;2))

TRUE (B1, previously was FALSE)

=ISBLANK(VLOOKUP(1;A1:C1;3))

FALSE (C1)


Jegyzet ikon

Megjegyzés: a Microsoft Excel eltérő módon viselkedik, és mindig számot ad vissza egy üres cellára vagy egy üres cellát eredményező képletcellára történő hivatkozás esetén. Például:


Case

Formula

Results and comments

A1: <Empty>

B1: =A1

Displays 0, but is just a reference to an empty cell.

=ISNUMBER(A1)

FALSE

=ISTEXT(A1)

FALSE

=A1=0

TRUE

=A1=""

TRUE

=ISNUMBER(B1)

FALSE (Microsoft Excel: TRUE)

=ISTEXT(B1)

FALSE

=B1=0

TRUE

=B1=""

TRUE (Microsoft Excel: FALSE)

C1: =VLOOKUP(...) with empty cell result

displays empty (Microsoft Excel: displays 0)

=ISNUMBER(VLOOKUP(...))

FALSE

=ISTEXT(VLOOKUP(...))

FALSE

=ISNUMBER(C1)

FALSE (Microsoft Excel: TRUE)

=ISTEXT(C1)

FALSE


Please support us!