HIBA.TÍPUS függvény

Visszaad egy konkrét hibatípust képviselő számot, vagy a #HIÁNYZIK hibaértéket, ha nincs hiba.

tip

This function is available since LibreOffice 5.0.


Syntax

HIBA.TÍPUS(hibaérték)

hibaérték - kötelező argumentum. A hibaérték, vagy hivatkozás a feldolgozandó értéket tartalmazó cellára.

Hibaérték

Visszatér

Hiba:511

1

#ZÉRÓOSZTÓ!

2

#ÉRTÉK!

3

#HIV!

4

#NÉV?

5

#SZÁM!

6

#HIÁNYZIK

7

Bármi más

#HIÁNYZIK


note

Ez a függvény az Open Document Format for Office Applications (OpenDocument) szabvány 1.2-es verziójának része. (ISO/IEC 26300:2-2015)


Example

Egyszerű használat

=HIBA.TÍPUS(#HIÁNYZIK)

7-et ad vissza, mert ez az indexérték tartozik a #HIÁNYZIK hibaértékhez.

=HIBA.TÍPUS(A3)

Ha az A3 a nullával osztással egyenértékű kifejezést tartalmaz, akkor a függvény 2-t ad vissza, mert ez az indexérték tartozik a #ZÉRÓOSZTÓ! hibaértékhez.

Speciálisabb mód

Ha az A1 A2-vel osztása esetén az A2 felvehet nulla értéket, akkor ezt a helyzetet a következőképpen kezelheti:

=HA(HIBÁS(A1/A2);HA(HIBA.TÍPUS(A1/A2)=2;"A nevező nem lehet nulla");A1/A2)

A HIBÁS függvény IGAZ vagy HAMIS értékkel tér vissza attól függően, hogy történt-e hiba. Ha hiba történik, a HA függvény a második argumentumot veszi elő, ha nincs hiba, akkor visszaadja az osztás végeredményét. A második argumentum ellenőrzi az adott hibatípust képviselő indexértéket, és ha egyenlő 2-vel, akkor visszaadja a megadott szöveget, ellenkező esetben 0-t. Így a nullával osztást egy szöveg jelzi, sikeres osztás esetén az osztás eredménye jelenik meg, vagy más típusú hiba esetén 0.

Figyelmeztetés ikon

Ha a HIBA.TÍPUS függvény a HA függvény feltételeként kerül felhasználásra, és a HIBA.TÍPUS függvény a #HIÁNYZIK értéket adja vissza, akkor a HA függvény is a #HIÁNYZIK értéket adja vissza. Ennek elkerülése érdekében a HIBÁS függvényt kell használni, mint a fenti példában.


Please support us!