Logikai függvények

This category contains the Logical functions.

Handling non-logical arguments in logical functions

Ennek a parancsnak az eléréséhez...

Válassza a Beszúrás - Függvény - Kategória: Logikai lehetőséget.


NINCS

IGAZ értéket ad vissza, ha a cella a #HIÁNYZIK (nincs érték) hibaértéket tartalmazza.

Ha hiba történik, ez a függvény HAMIS eredményt ad vissza.

Syntax

NINCS(érték)

Az érték az ellenőrizni kívánt érték, illetve kifejezés.

Example

A =NINCS(D3) függvény a HAMIS értéket ad vissza.

HAHIBA

Visszaadja az értéket, ha a cella nem tartalmaz hibaértéket, vagy az alternatív értéket.

tip

Ez a funkció a LibreOffice 4.0 óta érhető el.


Syntax

IFERROR(Value; Alternate_value)

Az érték a visszaadni kívánt érték, illetve kifejezés, ha az nem azonos vagy hibát eredményez.

Az alternatív_érték a visszaadni kívánt érték vagy kifejezés, ha az érték kifejezése vagy értéke azonos vagy hibát eredményez.

Example

Az =HAHIBA(C8;C9), ahol a C8 cella tartalma =1/0, a C9 értékét adja vissza, mert az 1/0 hibás kifejezés.

Az =HAHIBA(C8;C9), ahol a C8 cella tartalma =13, a C8 értékét adja vissza, mert az nem hiba.

IFS

IFS is a multiple IF-function.

SWITCH

SWITCH compares expression with value1 to valuen and returns the result belonging to the first value that equals expression. If there is no match and default_result is given, that will be returned.

HA

Egy logikai vizsgálatot végez el.

Syntax

IF(Test [; [ThenValue] [; [OtherwiseValue]]])

A teszt egy tetszőleges érték, illetve kifejezés, amely IGAZ vagy HAMIS értéket vehet fel.

Az akkor_érték (opcionális) az eredményül adott érték, ha a logikai vizsgálat eredménye IGAZ.

A különben_érték (opcionális) az eredményül adott érték, ha a logikai vizsgálat eredménye HAMIS.

A LibreOffice Calc függvényekben az opcionálisként jelölt paraméterek csak akkor hagyhatók el, ha nem következik paraméter. Például egy négy paramétert tartalmazó függvényben, ahol az utolsó két paraméter opcionálisként van jelölve, elhagyhatja a 4. paramétert vagy a 3. és 4. paramétert, de a 3. paramétert önmagában nem hagyhatja ki.

Example

=IF(A1>5;100;"too small") If the value in A1 is greater than 5, the value 100 is returned; otherwise, the text too small is returned.

=IF(A1>5;;"too small") If the value in A1 is greater than 5, the value 0 is returned because empty parameters are considered to be 0; otherwise, the text too small is returned.

=IF(A1>5;100;) If the value in A1 is less than 5, the value 0 is returned because the empty OtherwiseValue is interpreted as 0; otherwise 100 is returned.

HAMIS

A HAMIS logikai értéket adja vissza. A HAMIS() függvénynek nincsenek argumentumai, és mindig a logikai HAMIS értéket adja vissza.

Syntax

HAMIS()

Example

A =HAMIS() képlet a HAMIS értéket adja vissza.

A =NEM(HAMIS()) képlet az IGAZ értéket adja vissza.

IGAZ

Az IGAZ logikai értéket adja vissza. Az IGAZ() függvénynek nincsenek argumentumai, és mindig a logikai IGAZ értéket adja vissza.

Syntax

IGAZ()

Example

Legyen A=IGAZ és B=HAMIS. Ekkor:

Az =ÉS(A;B) képlet HAMIS értéket ad vissza.

A =VAGY(A;B) képlet IGAZ értéket ad vissza.

A =NEM(ÉS(A;B)) képlet IGAZ értéket ad vissza.

NEM

Invertál egy logikai értéket.

Syntax

NEM(logikai_érték)

A logikai_érték tetszőleges, ellentettjére állítható érték.

Example

A =NEM(A) képlet esetén, ha A=IGAZ, akkor NEM(A) HAMIS lesz.

VAGY

Ez a függvény IGAZ értéket ad vissza, ha legalább egy argumentuma IGAZ. A HAMIS értéket adja vissza, ha minden argumentum logikai értéke HAMIS.

Az argumentumok vagy logikai kifejezések maguk is (IGAZ, 1<5, 2+3=7, B8<10), amelyek logikai értékeket adnak vissza, vagy tömbök (A1:C3), amelyek logikai értékeket tartalmaznak.

Syntax

OR(Logical 1 [; Logical 2 [; … [; Logical 255]]])

Logical 1, Logical 2, … , Logical 255 are boolean values, references to cells or to cell ranges of logical values.

note

This function ignores any text or empty cell within a data range. If you suspect wrong results from this function, look for text in the data ranges. To highlight text contents in a data range, use the value highlighting feature.


Example

A program a 12<11; 13>22 és 45=45 logikai értéket fogja ellenőrizni.

A =VAGY(12<11;13>22;45=45) képlet IGAZ értéket ad vissza.

A =VAGY(HAMIS;IGAZ) képlet IGAZ értéket ad vissza.

XVAGY

Igaz értéket ad vissza, ha páratlan számú argumentum IGAZ értékre értékelhető ki.

Az argumentumok vagy logikai kifejezések maguk is (IGAZ, 1<5, 2+3=7, B8<10), amelyek logikai értékeket adnak vissza, vagy tömbök (A1:C3), amelyek logikai értékeket tartalmaznak.

tip

Ez a funkció a LibreOffice 4.0 óta érhető el.


Syntax

XOR(Logical 1 [; Logical 2 [; … [; Logical 255]]])

Logical 1, Logical 2, … , Logical 255 are boolean values, references to cells or to cell ranges of logical values.

Example

Az =XVAGY(IGAZ;IGAZ) képlet HAMIS értéket ad vissza

Az =XVAGY(IGAZ;IGAZ;IGAZ) képlet IGAZ értéket ad vissza

Az =XVAGY(HAMIS;IGAZ) képlet IGAZ értéket ad vissza

ÉS

IGAZ értéket ad vissza, ha minden argumentuma IGAZ. Ha az egyik elem HAMIS, ez a függvény a HAMIS értéket adja vissza.

Az argumentumok vagy logikai kifejezések maguk is (IGAZ, 1<5, 2+3=7, B8<10), amelyek logikai értékeket adnak vissza, vagy tömbök (A1:C3), amelyek logikai értékeket tartalmaznak.

Syntax

AND(Logical 1 [; Logical 2 [; … [; Logical 255]]])

Logical 1, Logical 2, … , Logical 255 are boolean values, references to cells or to cell ranges of logical values.

note

This function ignores any text or empty cell within a data range. If you suspect wrong results from this function, look for text in the data ranges. To highlight text contents in a data range, use the value highlighting feature.


Example

A program a 12<13; 14>12 és 7<6 logikai értéket fogja ellenőrizni.

Az =ÉS(12<13;14>12;7<6) képlet HAMIS értéket ad vissza.

Az =ÉS(HAMIS;IGAZ) képlet HAMIS értéket ad vissza.

Támogasson minket!