Formla

Definuje nastajenja formloweje syntaksy a při začitowanju nastajenjow za LibreOffice Calc.

Přistup k tutomu přikazej …

Wočińće tabelowy dokument, wubjerće – LibreOffice Calc – Formla.


Formlowe nastajenja

Formlowa syntaksa

Su tři móžnosće. Přikład: W přikładowym tabelowym dokumenće stej dwě dźěłowej tabeli, Tabela1 a Tabela2. W celi A1 tabele Tabela1 je poćah k celi C4 tabele Tabela2.

Jendźelske mjena funkcijow wužiwać

W LibreOffice Calc dadźa so funkciske mjena přełožić. Po standardźe kontrolny kašćik markěrowany njeje, štož rěka, zo so přełožene funkciske mjena wužiwaja.Hdyž so tutón kontrolny kašćik markěruje, so město toho jendźelske funkciske mjena wužiwaja. To so na wšě slědowacych wobłukow wuskutkuje: formlowe zapodaće a pokazanje, funkciski asistent a formlowe pokiwy. Móžeće wězo jón znjemóžnić, zo byšće so k přełoženym mjenam funkcijow wróćił.

Dźělatka

Z tutej skupinu opciskich tłóčatkow móžeće dźělatka w swojich formlowych wurazach konfigurować. To je na přikład praktiske, hdyž chceće swoje funkciske parametry přez komy (,) město semikolonow (;) wotdźělić.

Móžeće na přikład město =SUMA(A1;B1;C1) =SUMA(A1,B1,C1) zapodać.

Tohorunja móžeće tež špaltowe a linkowe dźělatka za pólne wariable inline změnić. Do toho je pólna wariabla inline semikolony (;) jako špaltowe dźělatko a padorunu smužku (|) jako linkowe dźělatko wužiwała; typiski wuraz pólneje wariable inline kaž tutón by za pólnu wariablu 5 x 2 takle wupadała:

={1;2;3;4;5|6;7;8;9;10}

Hdyž špaltowe dźělatko do komy (,) změniće a linkowe dźělatko do semikolona (;) budźe samsny wuraz takle wupadać:

={1,2,3,4,5;6,7,8,9,10}

Nastajenja za podrobne wobličenje

Postaja prawidła za přetworjenje znamješkowych rjećazkow do numeriskich hódnotow, znamješkowe rjećazki do celowych poćahow a znamješkowe rjećazki do datumowych a časowych hódnotow. To nastupa zatwarjene funkcije kaž INDIREKTNY, kotrež sej poćah jako znamješkowy rjećazk wužaduja, abo datumowe a časowe funkcije, kotrež sej argumenty jako znamješkowe rjećazki w lokalnym formaće abo w formaće ISO 8601 wužaduja.

Znowawobličenje při začitanju dataje

Znowawobličenje formlow móže někotry čas trać, hdyž jara wulke dataje začitaće.

Excel 2007 a nowši:

Začitanje wulkeje dateje tabeloweho dokumenta móže dołho trać. Jeli njetrjebaće daty swojeho wulkeho tabeloweho dokumenta hnydom aktualizować, móžeće znowawobličenje hač do lěpšeho časoweho dypka wotstorčić. LibreOffice wam zmóžnja, znowawobličenje tabelowych dokumentow Excel 2007 (a nowšeho) wotstorčić, zo by so čas začitanja pospěšił.

Tabelowy dokument ODF (z LibreOffice njeskładowany):

Najnowše wersije LibreOffice formlowe wuslědki tabelowych dokumentow w swojich ODF-dataji mjezyskładuja. Tuta funkcija LibreOffice pomha, wulki tabelowy dokument ODF, kotryž je so přez LibreOffice składował, spěšnišo znowa wobličić.

Za tabelowe dokumenty ODF, kotrež su so přez druhe programy składowali a hdźež tajke mjezskładowane formlowe wuslědki njekesistuja, da so znowawobličenje wotstorčić, zo by so začitanje dataje z datajemi Excel 2007 pospěšiło.

Za zapiski horjeka su slědowace wuběry móžne:

tip

Tabelowe dokumenty ODF, kotrež su so přez LibreOffice składowali, budu nastajeni Ženje znowa njewuličić a Přeco znowa wuličić respektować.


Prošu podpěrajće nas!