Tratamento das celas baleiras

Nas versións antigas do software, as celas baleiras tiñan, forzosamente, o valor numérico de 0 nalgúns contextos e dunha cadea baleira noutros, excepto nas comparacións directas, nas que =A1=0 e =A1="" resultasen VERDADEIRO se A1 estiver baleira. Agora, a propiedade de estar baleiro hérdase até que se utiliza, de xeito que tanto =PROCV(...)=0 como =PROCV(...)="" dan o valor de VERDADEIRO se a procura resultou nunha devolución dunha cela baleira.

Unha referencia simple a unha cela baleira segue a mostrase como 0 numérico, mais non é que necesariamente sexa de tipo numérico, polo que tamén se agardan comparacións coa cela referenciada.

Nos exemplos seguintes, A1 contén un número, B1 está baleira e C1 contén a referencia a B1:

Case

Fórmula

Resultados e comentarios

A1: 1
B1: <Baleiro>

C1: =B1

Mostra 0

=B1=0

VERDADEIRO

=B1=""

VERDADEIRO

=C1=0

VERDADEIRO

=C1=""

VERDADEIRO (anteriormente era FALSO)

=ÉNÚMERO(B1)

FALSO

=ÉNÚMERO(C1)

FALSO (anteriormente era VERDADEIRO)

=ÉNÚMERO(PROCV(1;A1:C1;2))

FALSO (B1)

=ÉNÚMERO(PROCV(1;A1:C1;3))

FALSO (C1, anteriormente era VERDADEIRO)

=ÉTEXTO(B1)

FALSO

=ÉTEXTO(C1)

VERDADEIRO

=ÉTEXTO(PROCV(1;A1:C1;2))

FALSO (B1, anteriormente era VERDADEIRO)

=ÉTEXTO(PROCV(1;A1:C1;3))

FALSO (C1)

=ENBRANCO(B1)

VERDADEIRO

=ENBRANCO(C1)

VERDADEIRO

=ENBRANCO(PROCV(1;A1:C1;2))

VERDADEIRO (B1, anteriormente era FALSO)

=ENBRANCO(PROCV(1;A1:C1;3))

FALSO (C1)


Icona Nota

Teña en conta que o Excel da Microsoft se comporta de maneira diferente e sempre devolve un número como resultado dunha referencia a unha cela baleira ou unha cela de fórmula que resulte nunha cela baleira. Por exemplo:


Case

Fórmula

Resultados e comentarios

A1: <Empty>

B1: =A1

Mostra 0, mais é só unha referencia a unha cela baleira.

=ÉNÚMERO(A1)

FALSO

=ÉTEXTO(A1)

FALSO

=A1=0

VERDADEIRO

=A1=""

VERDADEIRO

=ÉNÚMERO(B1)

FALSO (Excel da Microsoft: VERDADEIRO

=ÉTEXTO(B1)

FALSO

=B1=0

VERDADEIRO

=B1=""

VERDADEIRO (Excel da Microsoft: VERDADEIRO)

C1:=PROCV(...) con resultado de cela baleira

mostra baleiro (Excel da Microsoft: mostra 0)

=ÉNÚMERO(PROCV(...))

FALSO

=ÉTEXTO(PROCV(...))

FALSO

=ÉNÚMERO(C1)

FALSO (Excel da Microsoft: VERDADEIRO)

=ÉTEXTO(C1)

FALSO


Precisamos da súa axuda!