Gérer les modèles

La boîte de dialogue du gestionnaire de modèles rend facile la gestion des modèles et permet de démarrer de nouveaux documents utilisant des modèles.

Pour accéder à cette commande...

Choisissez le menu Fichier - Nouveau - Modèles.

Choisissez le menu Fichier - Modèle - Gérer les modèles.

Saisissez +Maj+N dans n'importe quel module LibreOffice.

Appuyez sur le bouton Modèles dans le centre de démarrage.

Sélectionnez n'importe quel type de modèles à partir du bouton Modèles dans le centre de démarrage.


Les modèles économisent du temps d'édition en permettant de commencer de nouveaux documents pré-remplis avec du contenu et des formatages. Le gestionnaire de modèles permet d'organiser et d'accéder aux modèles dans LibreOffice.

LibreOffice vient avec un ensemble de modèles qui peuvent être utilisés pour créer des documents, des présentations, des classeurs ou des dessins. Vous pouvez utiliser les modèles disponibles dans le gestionnaire de modèles, créer vos propres modèles ou naviguer en ligne pour obtenir des modèles supplémentaires.

Fenêtre principales - Choix de modèles

Des aperçus des modèles disponibles sont affichés dans la fenêtre principale basés sur votre recherche et les choix de filtres. Double-cliquez sur n'importe quelle icône de modèle pour ouvrir un nouveau document qui contiendra le contenu et les formatages du modèle.

Choisissez Affichage vignettes ou Affichage liste en haut à droite pour modifier l'affichage des modèles.

IcĂ´ne Affichage vignette

Affichage vignette

IcĂ´ne Affichage liste

Affichage liste

note

Pour afficher les modèles d'un autre dossier dans la catégorie Mes modèles, choisissez LibreOffice - Chemins, sélectionnez Modèles, appuyez sur Éditer, puis sur Ajouter pour ouvrir la boîte de dialogue de fichier afin de sélectionner le dossier à ajouter.


Rechercher

Vous pouvez rechercher un modèle en saisissant du texte dans la zone de recherche en haut à gauche. La fenêtre principale affiche les modèles trouvés.

Filtrer

Vous pouvez filtrer par : Toutes les applications, Documents, Classeurs, Présentations ou Dessins en choisissant un option à partir de la liste déroulante en haut au milieu. La fenêtre principale affiche les modèles filtrés.

Catégories

Les catégories sont des dossiers dans lesquels sont placés les modèles. Vous pouvez choisir parmi les catégories par défaut Mes modèles, Correspondance commerciale, MediaWiki, Autres documents professionnels, Correspondance et documents personnels, Présentations ou Style. Vous pouvez créer des catégories pour votre utilisation personnelle. Utilisez l'icône Outils du gestionnaire de modèles pour créer une nouvelle catégorie.

note

Les catégories à l'intérieur d'une catégorie ne sont pas autorisées.


Outils

Cliquez sur l'icône Outils en bas à gauche pour ouvrir le menu Outils. Les options sont : Nouvelle catégorie, Renommer la catégorie, Supprimer la catégorie et Rafraîchir. Si le modèle par défaut d'une application est modifié par rapport au paramétrage initial, alors une option supplémentaire, Restaurer le modèle par défaut, est disponible, permettant de restaurer le modèle par défaut d'une application à son état initial.

IcĂ´ne Outils

IcĂ´ne Outils

DĂ©placer

Si vous voulez déplacer les modèles dans une catégorie différente, choisissez alors un modèle, ou utilisez +clic pour sélectionner des modèles supplémentaires, puis appuyez sur le bouton Déplacer en bas à droite pour ouvrir une boîte de dialogue permettant de déplacer la sélection dans une catégorie différente ou dans une nouvelle catégorie. Les modèles par défaut ne peuvent pas être déplacés, mais peuvent être copiés dans d'autres catégories.

Exporter

Choisissez un modèle dans la fenêtre principale, ou utilisez +clic pour sélectionner des modèles supplémentaires et appuyez sur le bouton Exporter en bas à droite pour exporter la sélection dans un dossier de l'ordinateur.

IcĂ´ne Exporter

Bouton Exporter

tip

Pour déplacer ou exporter tous les modèles d'une catégorie, appuyez sur +A, puis choisissez Déplacer ou Exporter.


Importer

Si vous souhaitez importer un ou plusieurs modèles dans le gestionnaire de modèles, appuyez sur le bouton Importer en bas à droite, choisissez la catégorie dans laquelle les modèles doivent être importés, puis sélectionnez les fichiers à importer.

IcĂ´ne Importer

Bouton importer

Extensions

Pour trouver des modèles supplémentaires en ligne, cliquez sur l'icône Extensions en bas à droite pour ouvrir une fenêtre de recherche. Vous pouvez également rechercher des modèles sur https://extensions.libreoffice.org.

IcĂ´ne Extensions

IcĂ´ne Extensions

Actions avec les modèles individuels

Ouvrir

Sélectionnez un modèle dans la fenêtre principale et faites un clic droit puis choisissez Ouvrir, appuyez sur Entrée ou double cliquez pour ouvrir un nouveau document utilisant ce modèle.

Vous pouvez également utiliser le bouton Ouvrir en bas à gauche pour ouvrir un nouveau document utilisant le modèle sélectionné.

Éditer

Sélectionnez un modèle dans la fenêtre principale et faites un clic droit puis choisissez Éditer pour éditer le modèle. Cette fonction n'est disponible que pour les modèles qui ne sont pas fournis à l'origine.

Définir par défaut

Sélectionnez un modèle dans la fenêtre principale et faites un clic droit puis choisissez Définir par défaut pour définir ce modèles comme modèle par défaut. Cela fera apparaître une coche verte sur le modèle et le modèle se chargera automatiquement lorsqu'un nouveau document est créé par l'application correspondante.

Renommer

Sélectionnez un modèle dans la fenêtre principale et faites clic droit puis choisissez Renommer pour renommer le modèle. Une boîte de dialogue s'ouvre alors permettant de choisir un nouveau nom pour le modèle. Saisissez le nom et choisissez OK ou Annuler pour revenir au nom défini précédemment.

Supprimer

Sélectionnez un ou plusieurs modèles dans la fenêtre principale et appuyez sur le bouton Supprimer ou faites un clic droit et choisissez Supprimer pour supprimer le ou les modèles. Une boîte de dialogue demandant une confirmation s'ouvre. Choisissez Oui pour le supprimer ou Non pour annuler.

note

Les modèles fournis par défaut ne peuvent pas être édités, renommés ou supprimés.


Exemples

Exemple 1 - Création d'une lettre professionnelle

  1. Ouvrez LibreOffice Writer

  2. Appuyez sur +Maj+N ou sur Fichier - Nouveau - Modèles pour ouvrir le Gestionnaire de modèles

  3. Saisissez "lettre professionnelle" dans la zone de recherche

  4. Choisissez l'un des modèles dans la fenêtre principale en double-cliquant dessus pour le sélectionner et appuyez sur Entrée.

  5. Un nouveau document utilisant ce modèle est créé dans une nouvelle instance de LibreOffice Writer

  6. Modifiez le texte et le logo comme souhaité

Exemple 2 - Importer un modèle - Classeur de budget personnel

  1. Ouvrez LibreOffice Calc

  2. Appuyez sur +Maj+N ou sur Fichier - Nouveau - Modèles pour ouvrir le Gestionnaire de modèles

  3. Cliquez sur l'icône Extensions pour naviguer vers des modèles en ligne.

  4. Recherchez le modèle de budget personnel, puis téléchargez-le

  5. Ouvrez le Gestionnaire de modèles et cliquez sur le bouton Importer

  6. Sélectionnez une catégorie pour enregistrer le nouveau modèle, par exemple Mes modèles et appuyez sur OK.

  7. Naviguez jusqu'au dossier où le modèle a été téléchargé, sélectionnez-le et appuyez sur Ouvrir

  8. Le modèle est maintenant disponible dans la catégorie que vous avez choisie.

Exemple 3 - LibreOffice Impress - Modèle de présentation

  1. Ouvrez LibreOffice Impress

  2. Le gestionnaire de modèle s'ouvre automatiquement lorsque vous ouvrez LibreOffice Impress

  3. Choisissez un modèle pour votre présentation, filtrez par catégories ou recherchez-le

  4. Vous pouvez également utiliser le menu contextuel pour importer un modèle ou rechercher un modèle en ligne.

  5. Certaines fonctionnalités du gestionnaire de modèles ne sont pas disponibles à la première ouverture automatique. Après avoir démarré LibreOffice Impress, vous devez de nouveau ouvrir le gestionnaire de modèles pour accéder à toutes ses fonctionnalités.

tip

Utilisez les catégories pour organisez les modèles. Créez de nouveaux modèles ou téléchargez-les et organisez-les dans le gestionnaire de modèles. Utilisez les modèles pour économiser du temps avec les documents répétitifs.


Référez-vous à https://extensions.libreoffice.org pour télécharger des modèles.

Voir le chapitre 3 - Utilisez les styles et les modèles dans le Guide du débutant

Voir Créer un modèle de document pour des informations relatives.

Voir Modèles et styles pour des informations relatives.

Aidez-nous !