Fonctions logiques

Cette catégorie contient les fonctions Logiques.

Manipulation d'arguments non logiques dans les fonctions logiques

Pour accéder à cette commande...

Insertion - Fonction - Catégorie Logique


ESTNA

Renvoie VRAI si la cellule contient la valeur d'erreur #N/A (valeur non disponible).

Si une erreur survient, la fonction renvoie FAUX.

Syntaxe

ESTNA(valeur)

valeur représente la valeur ou une expression à examiner.

Exemple

=ESTNA(D3) renvoie le résultat FAUX.

SIERREUR

Renvoie la valeur si la cellule ne contient pas une valeur d'erreur, ou la valeur alternative dans le cas contraire.

tip

Cette fonction est disponible depuis la version 4.0 de LibreOffice.


Syntaxe

SIERREUR(valeur;valeur_alternative)

valeur est la valeur ou l'expression à retourner si elle n'est pas égale ou si elle résulte en une erreur.

valeur_alternative est la valeur ou l'expression à retourner si l'expression ou la valeur de valeur est égale ou résulte en une erreur.

Exemple

=SIERREUR(C8;C9) o√Ļ la cellule C8 contient =1/0 renvoie la valeur de C9, parce que 1/0 est une erreur.

=SIERREUR(C8;C9) o√Ļ la cellule C8 contient 13 renvoie 13, la valeur de C8, qui n'est pas une erreur.

SI.CONDITIONS

SI.CONDITIONS est une fonction SI multiple.

SI.MULTIPLE

SI.MULTIPLE compare une expression de valeur1 à valeurn et renvoie le résultat appartenant à la première valeur qui est égale à l'expression. S'il n'y a pas de correspondance et que le résultat par défaut est donné, il sera renvoyé.

ET

Renvoie VRAI si tous les arguments sont VRAI. Si l'un des éléments est FAUX, cette fonction renvoie la valeur FAUX.

Les arguments sont soit des expressions logiques (VRAI, 1<5, 2+3=7, B8<10) qui renvoient des valeurs logiques, soit des matrices (A1:C3) contenant des valeurs logiques.

Syntaxe

ET(logique1[;logique2[;...;[logique255]]])

logique1;logique2;...;logique255 sont des valeurs booléennes, des références à des cellules ou des plages de cellules de valeurs logiques.

note

Cette fonction ignore tout texte ou cellule vide dans une plage de données. Si vous soupçonnez des résultats erronés de cette fonction, recherchez du texte dans les plages de données. Pour mettre en évidence le contenu du texte dans une plage de données, utilisez la fonction Mise en évidence des valeurs.


Exemple

La valeur logique des entrées 12<13, 14>12 et 7<6 doit être vérifiée :

=ET(12<13;14>12;7<6) renvoie FAUX.

=ET(FAUX;VRAI) renvoie FAUX.

FAUX

Renvoie la valeur logique FAUX. La fonction FAUX() ne requiert aucun argument et renvoie toujours la valeur logique FAUX.

Syntaxe

FAUX()

Exemple

=FAUX() renvoie FAUX

=NON(FAUX()) renvoie VRAI

NON

Complète (inverse) une valeur logique.

Syntaxe

NON(valeur_logique)

ValeurLogique correspond à toute valeur devant être complétée.

Exemple

=NON(A). Si A=VRAI alors NON(A) sera évalué FAUX.

OU

Renvoie VRAI si au moins un argument est VRAI. Cette fonction renvoie la valeur FAUX si tous les arguments possèdent la valeur logique FAUX.

Les arguments sont soit des expressions logiques (VRAI, 1<5, 2+3=7, B8<10) qui renvoient des valeurs logiques, soit des matrices (A1:C3) contenant des valeurs logiques.

Syntaxe

OU(logique1[;logique2[;...;[logique255]]])

logique1;logique2;...;logique255 sont des valeurs booléennes, des références à des cellules ou des plages de cellules de valeurs logiques.

note

Cette fonction ignore tout texte ou cellule vide dans une plage de données. Si vous soupçonnez des résultats erronés de cette fonction, recherchez du texte dans les plages de données. Pour mettre en évidence le contenu du texte dans une plage de données, utilisez la fonction Mise en évidence des valeurs.


Exemple

La valeur logique des entrées 12<11; 13>22 et 45=45 doit être vérifiée.

=OU(12<11;13>22;45=45) renvoie VRAI.

=OU(FAUX;VRAI) renvoie VRAI.

SI

Indique un test logique à effectuer.

Syntaxe

SI(test[;[alors_valeur][;[sinon_valeur]]])

test représente toute valeur ou expression pouvant renvoyer VRAI ou FAUX.

alors_valeur (facultatif) est la valeur qui est renvoyée si le test logique est VRAI.

sinon_valeur (facultatif) est la valeur qui est renvoyée si le test logique est FAUX.

Dans les fonctions LibreOffice Calc, les param√®tres marqu√©s comme "facultatifs" peuvent √™tre ignor√©s lorsqu'ils ne sont pas suivis d'autres param√®tres. Par exemple, dans une fonction comportant quatre param√®tres, o√Ļ les deux derniers param√®tres sont marqu√©s comme "facultatifs", le param√®tre 4 ou les param√®tres 3 et 4 peuvent √™tre ignor√©s, mais le param√®tre 3 seul ne peut √™tre ignor√©.

Exemple

=SI(A1>5;100;"trop petit") Si la valeur dans A1 est supérieure à 5, la valeur 100 est renvoyée ; sinon, le texte trop petit est renvoyé.

=SI(A1>5;;"trop petit") Si la valeur dans A1 est supérieure à 5, la valeur 0 est renvoyée car les paramètres vides sont considérés comme étant 0 ; sinon, le texte trop petit est renvoyé.

=SI(A1>5;100;) Si la valeur dans A1 est inférieure à 5, la valeur 0 est renvoyée car la valeur sinon vide est interprétée comme 0 ; sinon 100 est renvoyé.

VRAI

La valeur logique est définie sur VRAI. La fonction VRAI() ne requiert aucun argument et renvoie toujours la valeur logique VRAI.

Syntaxe

VRAI()

Exemple

Si A=VRAI et B=FAUX, les exemples suivants s'affichent :

=ET(A;B) renvoie FAUX

=OU(A;B) renvoie VRAI

=NON(ET(A;B)) renvoie VRAI

XOR

Renvoie vrai si un nombre impair d'arguments est évalué à VRAI.

Les arguments sont soit des expressions logiques (VRAI, 1<5, 2+3=7, B8<10) qui renvoient des valeurs logiques, soit des matrices (A1:C3) contenant des valeurs logiques.

tip

Cette fonction est disponible depuis la version 4.0 de LibreOffice.


Syntaxe

XOR(logique1[;logique2[;...;[logique255]]])

logique1;logique2;...;logique255 sont des valeurs booléennes, des références à des cellules ou des plages de cellules de valeurs logiques.

Exemple

=XOR(VRAI;VRAI) renvoie FAUX

=XOR(VRAI;VRAI;VRAI) renvoie VRAI

=XOR(FAUX;VRAI) renvoie VRAI

Aidez-nous !