Glosario general

Para facilitarle el comienzo con LibreOffice, en este glosario le explicamos los términos más importantes con los que se encontrará casi siempre.

Recurra al glosario para consultar los términos que desconozca de cualquier aplicación de LibreOffice.

Menú contextual

Para activar el menú contextual de un objeto, pulse en el objeto con el botón del ratón para seleccionarlo. A continuación, . Algunos menús contextuales se pueden abrir aunque no se haya seleccionado el objeto. Los menús contextuales se encuentran en casi todas partes en LibreOffice.

ASCII

Siglas correspondientes a American Standard Code for Information Interchange. ASCII es un juego de caracteres concebido para la visualización de los mismos en los PC. Está formado por 128 caracteres, entre los que se incluyen letras, cifras, signos de puntuación y símbolos. El juego de caracteres ASCII ampliado contiene 256 caracteres. Cada uno de ellos tiene asignado un número irrepetible, que recibe el nombre de código ASCII.

En las páginas HTML solo deben aparecer caracteres del conjunto de caracteres ASCII de 7 bits. El resto de los caracteres, como el umlaut del alemán, se indican mediante códigos específicos. El filtro de exportación de LibreOffice efectúa las conversiones necesarias de forma automática.

Acoplar

Algunas ventanas de LibreOffice, como Estilos y el Navegador, son ventanas «acoplables». Puede desplazar estas ventanas, cambiar su tamaño o acoplarlas a un borde. En cada uno de los bordes se pueden acoplar ventanas sobre o junto a otras; luego puede cambiar las proporciones relativas de cada ventana al mover sus bordes.

To undock and re-dock, holding down the key, double-click a vacant area in the window. In the Styles window, you can also double-click a gray part of the window next to the icons, while you hold down the key.

Acoplar (Ocultación automática)

En el borde de cualquier ventana que tenga una ventana acoplada hay un botón que permite mostrarla u ocultarla.

Ajuste entre caracteres

El interletraje, o «kerning», se refiere a aumentar o disminuir la cantidad de espacio entre pares de letras para mejorar la apariencia general del texto.

Las tablas de ajuste entre caracteres contienen información sobre los pares de letras que requieren más espaciado. Dichas tablas suelen formar parte de la fuente.

Base de datos SQL / Servidor SQL

Una base de datos SQL es un sistema con una interfaz SQL. Las bases de datos SQL se pueden usar en redes cliente-servidor en las cuales varios clientes disponen de acceso a un servidor central (por ejemplo, un servidor SQL), de ahí que también se denominen bases de datos de servidor SQL o servidores SQL para abreviar.

En LibreOffice, se pueden integrar bases de datos SQL externas. Se pueden ubicar tanto en el sistema local como en red. El acceso se consigue mediante ODBC o un Native Driver integrado en LibreOffice .

Base de datos relacional

Una base de datos relacional es una colección de elementos de datos organizada como un conjunto de tablas descritas formalmente, mediante el cual se puede acceder a los datos y reorganizarlos de muchas maneras distintas, sin que sea necesario volver a ordenar las tablas de la base de datos.

Un sistema de gestión de bases de datos relacional (RDBMS) es un programa que permite crear, actualizar y administrar una base de datos relacional. Un RDBMS utiliza expresiones SQL (Structured Query Language, Lenguaje de consulta estructurado) que el usuario escribe o que se encuentran en un programa de aplicación y crea, actualiza o proporciona acceso a la base de datos.

Un buen ejemplo de base de datos relacional es una base de datos de compras con tablas de Cliente, Compra y Factura. La tabla Factura no contiene realmente datos de clientes ni de compras; no obstante, sí contiene, a través de un vínculo relacional o relación, referencias a los campos correspondiente de las tablas de clientes y de compras (por ejemplo, el campo ID cliente de la tabla de clientes).

Botón de selección

  1. En los controles de formulario, un botón de selección es una propiedad de un campo numérico, de moneda, de fecha o de hora. Si la propiedad «Botón de selección» está activada, el campo muestra símbolos de flecha que apuntan en direcciones opuestas, ya sea vertical u horizontalmente.

  2. En el EID de Basic, un botón de selección es el nombre usado por el campo numérico con dos símbolos de flechas.

Puede escribir un valor numérico en el campo o seleccionarlo con los botones Aumentar o Disminuir del campo. En el teclado puede accionar y para incrementar o reducir el valor. Es posible utilizar las teclas Re Pág y Av Pág para definir el valor máximo o mínimo.

If the field next to the spin button defines numerical values, you can also define a measurement unit, for example, 1 cm or 5 mm, 12 pt or 2".

Caracteres de anchura media y completa

«Anchura media» y «anchura completa» son propiedades que diferencian caracteres en determinados sistemas de escritura e idiomas del Este asiático, sobre todo chino, japonés y coreano (CJK, siglas en inglés).

The Han characters, Hiragana and Katakana characters, as well as Hangul characters used by these scripts are usually of square shape, and on fixed-width (monospace) display they occupy space of two Latin/ASCII characters. They are therefore called full-width characters, while the letters in Latin alphabet, digits, and punctuation marks included in ASCII character set are called half-width characters.

For historical reasons, a set of square-shaped Latin letters, digits, and punctuation marks are also defined and used in CJK typography, in addition to or in place of their half-width counterparts. They are called full-width forms. Similarly, there are also half-width forms of the usually full-width Katakanas and Hangul Jamos, and they have narrower shapes instead of square ones. A character's half-width and full-width forms are essentially two ways of writing the same character, just like uppercase and lowercase forms of Latin alphabet. LibreOffice supports conversion between half-width and full-width, as well as ignoring width difference when matching text strings.

Clave primaria

Una clave principal actúa como identificador exclusivo de campos de bases de datos. La identificación exclusiva de campos de bases de datos se emplea enbases de datos relacionales para poder acceder a los datos de otras tablas. Si una referencia a una clave principal se efectúa desde otra tabla, se denomina clave externa.

En LibreOffice las claves primarias se definen en la vista de diseño de una tabla al seleccionar, en el menú contextual de una cabecera de fila, la orden adecuada para el campo seleccionado.

DDE

DDE significa «Dynamic Data Exchange» (‘Intercambio dinámico de datos’), un precursor de OLE, «Object Linking and Embedding» (‘Vinculación e incrustación de objetos’). DDE enlaza los objetos a través de referencias de archivo, no los incrusta.

Es posible crear un enlace DDE mediante este procedimiento: Seleccione las celdas de una hoja de Calc, cópielas en el portapapeles, cambie de hoja y vaya a Editar ▸ Pegado especial. Seleccione la opción Enlace para insertar el contenido como un enlace DDE. Cuando se active el enlace, el área de la celda insertada se leerá a partir del archivo original.

Disposición compleja de textos (CTL)

Los idiomas con disposición compleja de textos pueden poseer alguna o todas las características siguientes:

Actualmente, LibreOffice admite como idiomas CTL el hindi, el tailandés, el hebreo y el árabe.

Enable CTL support using - Language Settings - Languages.

Enlace

The Links to External Files command is found in the Edit menu. The command can only be activated when at least one link is contained in the current document. When you insert a picture, for example, you can either insert the picture directly into the document or insert the picture as a link.

Al copiar el objeto directamente en el documento, el tamaño del mismo se incrementa (como mínimo) en una proporción equivalente al tamaño del objeto en bytes. Si guarda el documento y luego lo abre en otro equipo, el objeto insertado seguirá en el mismo lugar del documento.

Si inserta el objeto como enlace, el programa solamente introduce en ese punto una referencia al nombre de archivo. El tamaño de archivo del documento se incrementa solo en la proporción que requiera la inclusión de la ruta y archivo. Ahora bien, si abre el documento con otro equipo, para que el objeto pueda visualizarse es imprescindible que el archivo al cual está enlazado se encuentre exactamente en la misma ubicación definida en la referencia.

Use Edit - Links to External Files to see which files are inserted as links. The links can be removed if required. This will break the link and insert the object directly.

Formato

El formato se refiere a la distribución visual del texto mediante un procesador de texto o un programa de autoedición. Ello incluye la definición del formato de papel, los bordes de página, los tipos de letra y los efectos de tipo de letra, así como las sangrías y los espacios. Se puede dar formato a texto directamente o con los estilos que proporciona LibreOffice.

Formatos manuales y automáticos

A style is a set of formatting attributes, grouped and identified by a name (the style name). When you apply a style to an object, the object is formatted with the set of attributes of the style. Several objects of same nature can have the same style. As consequence, when you change the set of formatting attributes of the style, all objects associated with the style also change their formatting attributes accordingly. Use styles to uniformly format a large set of paragraphs, cells, and objects and better manage the formatting of documents.

When you do not use styles, and apply formatting attributes to parts of text directly, this is called Direct formatting (also called manual formatting). The formatting is applied only to the selected area of the document. If the document has several paragraphs, frames, or any other object, you apply direct formatting on each object. Direct formatting is available with the Format menu and with the Formatting toolbar.

A direct formatting attribute applied on a object overrides the corresponding attribute of the style applied to the object.

Guardado relativo y absoluto

In various dialogs (for example, Tools - AutoText) you can select whether you want to save files relatively or absolutely.

Si opta por guardar de forma relativa, las referencias a los gráficos incrustados o a otros objetos del documento se guardarán de forma relativa respecto a su ubicación en el sistema de archivos. En tal caso, no importa el lugar donde se haya grabado el directorio de referencia. Los archivos se encontrarán con independencia de su ubicación, siempre y cuando la referencia permanezca en la misma unidad o volumen. Esto es importante para que un documento esté disponible para otros equipos con una estructura de directorios, nombres de unidad o volumen totalmente distintos. También se recomienda guardar de forma relativa si se quiere crear una estructura de directorios en un servidor de Internet.

Si prefiere guardar de forma absoluta, todas las referencias a otros archivos se definirán también como absolutas y se basarán en la unidad, volumen o directorio raíz respectivos. La ventaja es que el documento que contiene las referencias se puede mover a otros directorios o carpetas y las referencias continuarán siendo válidas.

Huérfanas y viudas

Las huérfanas y las viudas son términos tipográficos que se vienen utilizando desde hace mucho tiempo. Una viuda es el último renglón de un párrafo que se queda aislado en la parte superior de la página siguiente. Por su lado, la huérfana es el primer renglón de un párrafo que se queda aislado en la parte inferior de la página anterior. LibreOffice permite evitar estos efectos antiestéticos de modo automático, en función de un determinado estilo de párrafo. Incluso se puede configurar el número mínimo de renglones que deben aparecer siempre juntos en una página.

IME

IME significa «Input Method Editor» (‘editor de métodos de entrada’). Se trata de un programa que permite al usuario escribir caracteres complejos de juegos de caracteres no occidentales a través de un teclado estándar.

JDBC

La API Java Database Connectivity (JDBC) se puede usar para conectarse con una base de datos desde LibreOffice. Los controladores de JDBC se escriben en el lenguaje de programación Java y no son exclusivos de ninguna plataforma.

ODBC

Conectividad abierta de bases de datos (ODBC, Open Database Connectivity) es un protocolo que permite a las aplicaciones acceder a sistemas de bases de datos. El lenguaje de consulta empleado es el Lenguaje de consultas estructurado (SQL, Structured Query Language). LibreOffice permite determinar si se utilizarán órdenes SQL para ejecutar consultas para una base de datos específica. Otra posibilidad es utilizar la ayuda interactiva para definir la consulta mediante pulsaciones del ratón y hacer que LibreOffice la traduzca a SQL automáticamente.

OLE

Los objetos OLE pueden enlazarse a un documento de destino o incrustarse. La incrustación inserta una copia del objeto y detalles del programa de origen en el documento de destino. Si desea editar el objeto, simplemente active el programa de origen haciendo una doble pulsación en el objeto.

Objeto

Un objeto es un elemento situado en la pantalla y que contiene informaciones. Puede tratarse, por ejemplo, de los datos de una aplicación, como textos o imágenes.

Los objetos son independientes y no se influyen recíprocamente. A cada objeto que contiene datos se le asignan determinadas órdenes. Así, un objeto de imagen incluye órdenes para la edición de imágenes; una hoja de cálculo, órdenes para realizar cálculos, etc.

Objeto Bézier

Las curvas de Bézier —así llamadas en honor de Pierre Bézier, el matemático francés que las desarrolló— son curvas definidas matemáticamente que se utilizan en aplicaciones gráficas bidimensionales. La curva está definida por cuatro puntos: la posición inicial, la posición final y dos posiciones intermedias. Los objetos de Bézier se pueden modificar moviendo dichos puntos con el ratón.

OpenGL

OpenGL es un lenguaje de gráficos 3D desarrollado inicialmente por la empresa SGI (Silicon Graphics Inc). Se suelen utilizar dos dialectos de este lenguaje: Microsoft OpenGL, desarrollado para utilizarse en Windows NT, y Cosmo OpenGL, creado por SGI. Este último representa un lenguaje de gráficos independiente para todas las plataformas y cualquier tipo de equipo que se puede utilizar, incluso, en máquinas no equipadas con hardware de gráficos 3D específico.

PNG

PNG (Portable Network Graphics, Imágenes de red portátiles) es un formato de archivos gráficos cuyo uso se extiende cada vez más en Internet. Los archivos están comprimidos con un factor de compresión seleccionable y, a diferencia del formato JPG, los archivos PNG se comprimen sin pérdida de información. PNG puede guardar imágenes de 24 y 8 bits en color, escala de grises y blanco y negro y, si se desea, incluir canales alfa que se pueden utilizar como atributos de transparencia. Las imágenes PNG entrelazadas se pueden cargar de modo que se muestre, por ejemplo, 1 fila (o columna) de cada 10. El resto de la imagen se carga a continuación.

Page line-spacing (register-true)

In LibreOffice, the register-true feature is called Page line-spacing.

Page line-spacing refers to the coincident imprint of the lines within a type area on the front and the back side of a page. The page line-spacing feature makes a page easier to read by preventing gray shadows from shining through between the lines of text. The page line-spacing term also refers to lines in adjacent text columns, where lines in different columns use the same vertical grid, thereby aligning them vertically with each other.

Page line-spacing printing is particularly useful for documents that will have two pages set next to each other (for example, in a book or brochure), for multi-column layouts, and for documents intended for double-sided printing.

RTF

RTF («Rich Text Format», ‘Formato de texto enriquecido’) es un formato de archivo desarrollado para el intercambio de archivos de texto. Una de sus características especiales es que el formato se convierte en información de texto legible directamente. Desafortunadamente, esto crea archivos relativamente grandes en comparación con otros formatos.

SQL

El Lenguaje de consultas estructurado (SQL) se utiliza para crear consultas de base de datos. LibreOffice permite formular consultas en SQL o de forma interactiva mediante el ratón.

Sistema numérico

Un sistema numérico lo determina el número de caracteres disponibles para representar números. El sistema decimal, por ejemplo, se basa en los números del 0 al 9, el sistema binario, en los números 1 y 2, y el hexadecimal, en un conjunto de 16 caracteres (del 0 al 9 y de la A a la F).

¡Necesitamos su ayuda!