Tratamiento de celdas vacías

Previamente, las celdas vacías estaban forzadas al número 0 en algunos contextos y a cadenas vacías en otros, excepto en comparaciones directas donde =A1=0 y =A1="" ambas resultaban en VERDADERO si A1 estaba vacía. Ahora el cualidad de vacío se hereda hasta que sea utilizada, así es que ambos =BUSCARV(...)=0 y =BUSCARV(...)="" dan VERDADERO si el resultado de la búsqueda devuelve una celda vacía.

Una simple referencia para una celda vacía aún se visualiza como un número 0 pero no es necesariamente de tipo numérico, de tal modo que las comparaciones con referencia a la celda funcionan como se espera.

Para el siguiente ejemplo, A1 contiene un numero, B1 esta vacio, C1 contiene la referencia a B1:

Caso

Fórmula

Resultados y comentarios

A1: 1
B1:

C1: =B1

Muestra 0

=B1=0

VERDADERO

=B1=""

VERDADERO

=C1=0

VERDADERO

=C1=""

VERDADERO (previamente era FALSO)

=ESNUMERO(B1)

FALSO

=ESNUMERO(C1)

FALSO (previamente era VERDADERO)

=ESNUMERO(BUSCARV(1;A1:C1;2))

FALSO (B1)

=ESNUMERO(BUSCARV(1;A1:C1;3))

FALSO (C1, previamente era VERDADERO)

=ESTEXTO(B1)

FALSO

=ESTEXTO(C1)

VERDADERO

=ESTEXTO(BUSCARV(1;A1:C1;2))

FALSO (B1, previamente era VERDADERO)

=ESTEXTO(BUSCARV(1;A1:C1;3))

FALSO (C1)

=ESBLANCO(B1)

VERDADERO

=ESBLANCO(C1)

VERDADERO

=ESBLANCO(BUSCARV(1;A1:C1;2))

VERDADERO (B1, previamente era FALSO)

=ESBLANCO(BUSCARV(1;A1:C1;3))

FALSO (C1)


Icono de nota

Tenga en cuenta que Microsoft Excel se comporta de diferente manera y siempre devuelve un número como el resultado de una referencia a una celda vacía o una fórmula en la celda que da como resultado una celda vacía. Por ejemplo:


Caso

Fórmula

Resultados y comentarios

A1:

B1: =A1

Muestra 0, pero es solamente una referencia a una celda vacía.

=ESNUMERO(A1)

FALSO

=ESTEXTO(A1)

FALSO

=A1=0

VERDADERO

=A1=""

VERDADERO

=ESNUMERO(B1)

FALSO (Microsoft Excel: VERDADERO)

=ESTEXTO(B1)

FALSO

=B1=0

VERDADERO

=B1=""

VERDADERO (Microsoft Excel: FALSO)

C1: =BUSCARV(…) con resultado de celda vacía

no muestra nada (Microsoft Excel: muestra 0)

=ESNUMERO(BUSCARV(…))

FALSO

=ESTEXTO(BUSCARV(…))

FALSO

=ESNUMERO(C1)

FALSO (Microsoft Excel: VERDADERO)

=ESTEXTO(C1)

FALSO


¡Necesitamos su ayuda!