General Shortcut Keys in LibreOffice

Note Icon

Some of the shortcut keys may be assigned to your desktop system. Keys that are assigned to the desktop system are not available to LibreOffice. Try to assign different keys either for LibreOffice, in Tools - Customise - Keyboard, or in your desktop system.


Using Shortcut Keys

A great deal of your application's functionality can be called up by using shortcut keys. For example, the shortcut keys are shown next to the Open entry in the File menu. If you want to access this function by using the shortcut keys, press and hold down and then press the O key. Release both keys after the dialogue box appears.

When operating your application, you can choose between using the mouse or the keyboard for almost all of the operations available.

Entering Unicode Characters

You can enter arbitrary Unicode characters in the document typing the Unicode hexadecimal code point and then pressing (default). Type the Unicode hexadecimal notation and press to toggle between the Unicode character and its hexadecimal notation. Selection is not necessary but the conversion will apply to the selected characters. Toggling occurs on the characters prior to the cursor position when these characters form a valid Unicode hexadecimal point. Hexadecimal code points with value in the range U+0000 to U+0020 are not converted.

The default Unicode conversion shortcut is and in some locales where the default Unicode shortcut interferes with the main menu shortcut. To reassign the shortcut, choose Tools > Customize > Keyboard and select Category:Options with Function:Toggle Unicode Notation.

Using Shortcut Keys to Control Dialogue Boxes

There is always one element highlighted in any given dialogue box - usually shown by a broken frame. This element, which can be either a button, an option field, an entry in a list box or a check box, is said to have the focus on it. If the focal point is a button, pressing Enter runs it as if you had clicked it. A check box is toggled by pressing the Spacebar. If an option field has the focus, use the arrow keys to change the activated option field in that area. Use the Tab key to go from one element or area to the next one, use Shift+Tab to go in the reverse direction.

Pressing Esc closes the dialogue box without saving changes.

Shortcut Keys for Mouse Actions

If you are using drag-and-drop, selecting with the mouse or clicking objects and names, you can use the keys Shift, and occasionally to access additional functionality. The modified functions available when holding down keys during drag-and-drop are indicated by the mouse pointer changing form. When selecting files or other objects, the modifier keys can extend the selection - the functions are explained where applicable.

Practical Text Input Fields

  1. You can open a context menu, which contains some of the most often-used commands.

  2. Use +A to select the entire text. Use the right or left arrow key to remove the selection.

  3. Double-click a word to select it.

  4. A triple-click in a text input field selects the entire field. A triple-click in a text document selects the current sentence.

  5. Use +Del to delete everything from the cursor position to the end of the word.

  6. By using and right or left arrow key, the cursor will jump from word to word; if you also hold down the Shift key, one word after the other is selected.

  7. INSRT is used to switch between the insert mode and the overwrite mode and back again.

  8. Drag-and-drop can be used within and outside of a text box.

  9. The +Z shortcut keys are used to undo modifications one step at a time; the text will then have the status it had before the first change.

  1. LibreOffice has an AutoComplete function which activates itself in some text and list boxes. For example, enter into the URL field and the AutoComplete function displays the first file or first directory found that starts with the letter "a".

  2. Use the Down Arrow key to scroll through the other files and directories. Use the Right Arrow key to also display an existing subdirectory in the URL field. Quick AutoComplete is available if you press the End key after entering part of the URL. Once you find the document or directory you want, press Enter.

Interrupting Macros

If you want to terminate a macro that is currently running, press +Shift+Q.

List of General Shortcut Keys in LibreOffice

The shortcut keys are shown on the right hand side of the menu lists next to the corresponding menu command.

Shortcut keys for controlling dialogue boxes

Shortcut Keys

Effect

Enter key

Activates the focused button in a dialogue box.

Esc

Terminates the action or dialogue box. If in LibreOffice Help: goes up one level.

Spacebar

Toggles the focused check box in a dialogue box.

Arrow keys

Changes the active control field in an option section of a dialogue box.

Tab

Advances focus to the next section or element in a dialogue box.

Shift+Tab

Moves the focus to the previous section or element in a dialogue box.

+Down Arrow

Opens the list of the control field currently selected in a dialogue box. These shortcut keys apply not only to combo boxes but also to icon buttons with pop-up menus. Close an opened list by pressing the Esc key.


Shortcut keys for controlling documents and windows

Shortcut Keys

Effect

+O

Opens a document.

+S

Saves the current document.

+N

Creates a new document.

+Shift+N

Opens the Templates dialogue box.

+P

Prints document.

+F

Activates the Find toolbar.

+H

Calls the Find & Replace dialogue box.

+Shift+F

Searches for the last entered search term.

+Shift+R

Redraws the document view.

+Shift+I

Enable or disable the selection cursor in read-only text.

In the LibreOffice Help: jumps to main help page.

Shift+F2

Turns on Extended Tips for the currently selected command, icon or control.

F6

Sets focus in next sub-window, for example, document/data source view.

Shift+F6

Sets focus in previous subwindow.

F10

Activates the first menu (File menu).

Shift+F10

Opens the context menu.

Ctrl+Alt+Shift+Home

Shows/hides main menu.

+F4 or +F4

Closes the current document. Closes LibreOffice when the last open document is closed.

+Q

Exits application.


Shortcut keys for editing or formatting documents

Shortcut Keys

Effect

+Tab

When positioned at the beginning of a header, a tab is inserted.

Enter (if an OLE object is selected)

Activates the selected OLE object.

Enter (if a drawing object or text object is selected)

Activates text input mode.

+X

Cuts out the selected elements.

+C

Copies the selected items.

+V

Pastes from the clipboard.

+Shift+V

Pastes unformatted text from the clipboard. The text is pasted using the format that exists at the insertion point.

+Shift+V

Opens the Paste Special dialogue box.

+A

Selects all.

+Z

Undoes last action.

Redoes last action.

+Shift+Y

Repeats last command.

+I

The "Italic" attribute is applied to the selected area. If the cursor is positioned in a word, this word is also marked in italic.

+B

The "Bold" attribute is applied to the selected area. If the cursor is positioned in a word, this word is also put in bold.

+U

The "Underlined" attribute is applied to the selected area. If the cursor is positioned in a word, this word is also underlined.

Removes direct formatting from selected text or objects (as in Format - Clear Direct Formatting).


Shortcut keys in the Gallery

Shortcut keys

Effect

Tab

Moves between areas.

Shift+Tab

Moves backward between areas.


Shortcut keys in the New Theme area of the Gallery:

Shortcut keys

Effect

Up Arrow

Moves the selection up one.

Down Arrow

Moves the selection down.

+Enter

Opens the Properties dialogue box.

Shift+F10

Opens a context menu.

+U

Refreshes the selected theme.

+R

Opens the Enter Title dialogue box.

+D

Deletes the selected theme.

Insert

Inserts a new theme.


Shortcut keys in the Gallery Preview area:

Shortcut keys

Effect

Home

Jumps to the first entry.

End

Jumps to the last entry.

Left Arrow

Selects the next Gallery element on the left.

Right Arrow

Selects the next Gallery element on the right.

Up Arrow

Selects the next Gallery element above.

Down Arrow

Selects the next Gallery element below.

Page Up

Scrolls up one screen.

Page Down

Scrolls down one screen.

+Shift+Insert

Inserts the selected object as a linked object into the current document.

+I

Inserts a copy of the selected object into the current document.

+T

Opens the Enter Title dialogue box.

+P

Switches between themes view and object view.

Spacebar

Switches between themes view and object view.

Enter

Switches between themes view and object view.

Step backward (only in object view).

Switches back to main overview.


Selecting Rows and Columns in a Database Table (opened by +Shift+F4 keys)

Shortcut keys

Effect

Spacebar

Toggles row selection, except when the row is in edit mode.

+Spacebar

Toggles row selection.

Shift+Spacebar

Selects the current column.

+Page Up

Moves pointer to the first row.

+Page Down

Moves pointer to the last row.


Shortcut Keys for Drawing Objects

Shortcut keys

Effect

Select the toolbar with F6. Use the Down Arrow and Right Arrow keys to select the desired toolbar icon and press +Enter.

Inserts a Drawing Object.

Select the document with +F6 and press Tab.

Selects a Drawing Object.

Tab

Selects the next Drawing Object.

Shift+Tab

Selects the previous Drawing Object.

+Home

Selects the first Drawing Object.

+End

Selects the last Drawing Object.

Esc

Ends Drawing Object selection.

Esc (in Handle Selection Mode)

Exits Handle Selection Mode and return to Object Selection Mode.

Up/Down/Left/Right Arrow

Moves the selected point (the snap-to-grid functions are temporarily disabled, but end points still snap to each other).

+Up/Down/Left/Right Arrow

Moves the selected drawing object one pixel (in Selection Mode).

Resizes a drawing object (in Handle Selection Mode).

Rotates a drawing object (in Rotation Mode).

Opens the properties dialogue box for a drawing object.

Activates the Point Selection mode for the selected drawing object.

Spacebar

Selects a point of a drawing object (in Point Selection mode) / Cancel selection.

The selected point blinks once per second.

Shift+Spacebar

Selects an additional point in Point Selection mode.

+Tab

Selects the next point of the drawing object (Point Selection mode).

In Rotation mode, the centre of rotation can also be selected.

+Shift+Tab

Selects the previous point of the drawing object (Point Selection mode)

+Enter

A new drawing object with default size is placed in the centre of the current view.

+Enter at the Selection icon

Activates the first drawing object in the document.

Esc

Leaves the Point Selection mode. The drawing object is selected afterwards.

Edits a point of a drawing object (Point Edit mode).

Any text or numeric key

If a drawing object is selected, switches to edit mode and places the cursor at the end of the text in the drawing object. A printable character is inserted.

key while creating or scaling a graphic object

The position of the object's centre is fixed.

Shift key while creating or scaling a graphic object

The ratio of the object's width to height is fixed.


Please support us!