Formula

Definěrujo nastajenja formuloweje syntakse a pśi zacytowanju nastajenjow za LibreOffice Calc.

Pśistup k toś tomu pśikazoju …

Wócyńśo tabelowy dokument, wubjeŕśo – LibreOffice Calc – Formula.


Nastajenja formulow

Formulowa syntaksa

Dajo tśi móžnosći. Pśikład: W pśikładowem tabelowem dokumenśe stej dwě źěłowej tabeli, Tabela1 a Tabela2. W celi A1 tabele Tabela1 jo póśěg k celi C4 tabele Tabela2.

Engelske mjenja funkcijow wužywaś

W LibreOffice Calc daju se funkciske mjenja pśełožyś. Pó standarźe kontrolny kašćik njejo markěrowany, což groni, až se pśełožone funkciske mjenja wužywaju. Gaž se toś ten kontrolny kašćik markěrujo, se město togo engelske funkciske mjenja wužywaju. To se na wšykne slědujucych wobceŕkow wustatkujo: formulowe zapódaśe a pokazanje, funkciski asistent a formulowe pokaze. Móžośo zawěsće jen znjemóžniś, aby se k pśełožonym mjenjam funkcijow wrośił.

Źěleńske znamuška

Z toś teju kupku opciskich tłocaškow móžośo źěleńske znamuška w swójich formulowych wurazach konfigurěrowaś. To jo na pśikład praktiske, gaž cośo swóje funkciske parametry pśez komy (,) město semikolonow (;) wótźěliś.

Móžośo na pśikład město =SUMA(A1;B1;C1) =SUMA(A1,B1,C1) zapódaś.

Tejerownosći móžośo teke słupowe a smužkowe źěleńske znamuška za pólne wariable inline změniś. Do togo jo pólna wariabla inline semikolony (;) ako słupowe źěleńske znamuško a padorownu ceru (|) ako smužkowe źěleńske znamuško wužywała; typiski wuraz pólneje wariable inline ako toś ten by za pólnu wariablu 5 x 2 tak wuglědała:

={1;2;3;4;5|6;7;8;9;10}

Gaž słupowe źěleńske znamuško do komy (,) změnijośo a smužkowe źěleńske znamuško do semikolona (;) buźo ten samski wuraz tak wuglědaś:

={1,2,3,4,5;6,7,8,9,10}

Nastajenja za nadrobne woblicenje

Póstaja pšawidła za pśetwórjenje znamjenjowych rjeśazkow do numeriskich gódnotow, znamjenjowe rjeśazki do celowych póśěgow a znamjenjowe rjeśazki do datumowych a casowych gódnotow. To nastupa zatwarjone funkcije ako INDIREKTNY, kótarež se póśěg ako znamjenjowy rjeśazk pominaju, abo datumowe a casowe funkcije, kótarež se argumenty ako znamjenjowe rjeśazki w lokalnem formaśe abo w formaśe ISO 8601 pominaju.

Znowegowoblicenje pśi zacytanju dataje

Znowegowoblicenje formulow móžo bejny cas traś, gaž wjelgin wjelike dataje zacytajośo.

Excel 2007 a nowšy:

Zacytanje wjelikeje dateje tabelowego dokumenta móžo dłujko traś. Jolic njetrjebaśo daty swójogo wjelikego tabelowego dokumenta ned aktualizěrowaś, móžośo znowegowoblicenje až do lěpšego casoweho dypka wótstarcyś. LibreOffice wam zmóžnja, znowegowoblicenje tabelowych dokumentow Excel 2007 (a nowšego) wótstarcyś, aby se cas zacytanja póspěšył.

Tabelowy dokument ODF (z LibreOffice njeskłaźony):

Nejnowše wersije LibreOffice formulowe wuslědki tabelowych dokumentow w swójich ODF-dataji mjazywótkładuju. Toś ta funkcija LibreOffice pomaga, wjeliki tabelowy dokument ODF, kótaryž jo se składł pśez LibreOffice, malsnjej znowego woblicyś.

Za tabelowe dokumenty ODF, kótarež su se składli pśez druge programy a źož take mjazywótkłaźone formulowe wuslědki njeeksistěruju, dajo se znowegowoblicenje wótstarcyś, aby se zacytanje dataje z datajami Excel 2007 póspěšyło.

Za zapiski górjejce su slědujuce wuběrki móžne:

tip

Tabelowe dokumenty ODF, kótarež su se składli pśez LibreOffice, budu nastajeni Nigda znowego njewulicyś a Pśecej znowego wulicyś respektěrowaś.


Pšosym pódprějśo nas!