Formel

Legt Optionen zur Formel-Syntax und beim Laden für LibreOffice Calc fest.

So greifen Sie auf diesen Befehl zu:

Öffnen Sie ein Tabellendokument, wählen Sie – LibreOffice Calc – Formel.


Formel-Einstellungen

Formel-Syntax

Es gibt drei Optionen. Ein Beispiel: In einem Beispiel-Tabellendokument befinden sich zwei Tabellen: Tabelle1 und Tabelle2. In Zelle A1 der Tabelle1 befindet sich ein Verweis auf Zelle C4 der Tabelle2.

Englische Funktionsnamen verwenden

In LibreOffice Calc können Funktionsnamen übersetzt werden. Standardmäßig ist das Markierfeld deaktiviert, sodass übersetzte Funktionsnamen verwendet werden. Wird das Markierfeld aktiviert, werden stattdessen die englischen Funktionsnamen verwendet. Diese Änderung betrifft folgende Bereiche: Eingabe und Anzeige von Formeln, den Funktionsassistenten und Formeltipps. Wenn das Markierfeld wieder deaktiviert wird, werden erneut übersetzte Funktionsnamen verwendet.

Trennzeichen

Mit dieser Option können Sie die Trennzeichen in Formeln selber festlegen. Dies ist praktisch, wenn Sie beispielsweise anstatt des Semikolons (;) lieber ein Doppelkreuz (#) als Trennzeichen verwenden.

Statt =SUMME(A1;B1;C1) können Sie dann zum Beispiel =SUMME(A1#B1#C1) eingeben.

Ebenso können Sie die Spalten- und Zeilentrennzeichen für Inline-Matrizen ändern. Standardmäßig verwenden Inline-Matrizen das Semikolon (;) für Spalten- und den senkrechten Strich (|) als Zeilentrennzeichen. Eine typische 5x2-Inline-Matrix würde deshalb wie folgt eingegeben werden:

={1;2;3;4;5|6;7;8;9;10}

Wenn Sie als Spaltentrennzeichen das Doppelkreuz (#) und als Zeilentrennzeichen das Semikolon (;) definieren, sieht die Matrix so aus:

={1#2#3#4#5;6#7#8#9#10}

Einstellungen für detaillierte Berechnung

Setzt die Regeln für die Konvertierung von Zeichenketten in numerische Werte, Zeichenketten in Bezüge und Zeichenketten in Daten und Zeiten. Die betrifft eingebaute Funktionen wie INDIREKT, welche Bezüge als Zeichenketten erfordern, oder Datums- oder Zeitfunktionen, welche Argumente als Zeichenketten in lokalem oder ISO 8601-Format erfordern.

Neuberechnung beim Laden einer Datei

So greifen Sie auf diesen Befehl zu:

Wählen Sie – LibreOffice Calc – Formel.


Die Neuberechnung von Formeln kann einige Zeit beanspruchen, wenn sehr große Dateien geöffnet werden.

Excel 2007 und neuer:

Das Laden eines großen Tabellendokuments kann viel Zeit in Anspruch nehmen. Wenn Sie nicht auf eine sofortige Neuberechnung Ihres großen Tabellendokuments angewiesen sind, können Sie diese zu einem besseren Zeitpunkt nachholen. LibreOffice ermöglicht es Ihnen, die Neuberechnung von Excel 2007 (und später) Tabellendokumenten aufzuschieben, um die Ladezeit zu beschleunigen.

ODF-Tabellendokument (nicht mit LibreOffice gespeichert)

Aktuelle Versionen von LibreOffice speichern Formelergebnisse in ihrer ODF-Datei zwischen. Diese Funktion beschleunigt LibreOffice beim Neuberechnen eines großen ODF-Tabellendokuments, welches von LibreOffice gespeichert wurde.

Für von anderen Programmen gespeicherte ODF-Tabellendokumente, für die zwischengespeicherte Formelergebnisse möglicherweise nicht existieren, kann die Neuberechnung aufgeschoben werden, um die Ladezeit von beispielsweise Excel 2007-Dateien zu beschleunigen.

Für die obigen Einträge sind die folgenden Auswahlen möglich:

Tippsymbol

Die in LibreOffice gespeicherten ODF-Tabellendokumente werden die Optionen Nie neu berechnen und Immer neu berechnen respektieren.


Bitte unterstützen Sie uns!