Adressen und Bezüge, absolut und relativ

Relative Adressierung

Mit A1 wird die Zelle in Spalte A und Zeile 1 adressiert. Einen Bereich von benachbarten Zellen sprechen Sie an, indem Sie die linke obere Ecke des Bereichs angeben, dann einen Doppelpunkt setzen, und schließlich die rechte untere Zelle des Bereichs nennen. Der quadratische Bereich der ersten vier Zellen in der Ecke links oben heißt demnach A1:B2.

Bei dieser Art der Adressierung eines Bereichs ist der Bezug auf A1:B2 ein relativer Bezug. Relativ bedeutet hierbei, dass der Bezug auf diesen Bereich angepasst wird, wenn Sie die Formeln kopieren.

Absolute Adressierung

Im Gegensatz zur relativen Adressierung gibt es den absoluten Bezug, der auf folgende Weise geschrieben wird: $A$1:$B$2. Vor jeder Angabe, die absolut verwendet werden soll, steht also ein Dollarzeichen.

Tippsymbol

LibreOffice Calc kann den aktuellen Bezug, in dem der Cursor in der Eingabezeile steht, von relativ nach absolut und zurück umschreiben, wenn Sie F4 drücken. Wenn Sie mit einer relativen Adresse wie A1 beginnen, gilt Folgendes: Beim ersten Tastendruck wird Zeile und Spalte auf absolut gesetzt ($A$1), beim nächsten Tastendruck nur die Zeile (A$1), dann nur die Spalte ($A1), dann wird der Bezug wieder in beiden Richtungen relativ (A1)


LibreOffice Calc zeigt die Bezüge zu einer Formel an. Wenn Sie beispielsweise die Formel =SUMME(A1:C5;D15:D24) in einer Zelle anklicken, werden die beiden referenzierten Bereiche in der Tabelle farblich hervorgehoben. Beispielsweise kann der Formelbestandteil "A1:C5" in blau zu sehen sein und der fragliche Zellbereich ist im selben Blauton umrandet. Der nächste Formelbestandteil "D15:D24" kann in derselben Weise in rot markiert sein.

Wann relative, wann absolute Bezüge verwendet werden

Was zeichnet einen relativen Bezug aus? Angenommen, Sie möchten in Zelle E1 die Summe der Zellen im Bereich A1:B2 berechnen lassen. Die Formel, die Sie in E1 eingeben, wäre also =SUMME(A1:B2). Nun entscheiden Sie sich aber später, vor der Spalte A noch eine neue Spalte einzufügen. Die Elemente, die Sie summieren möchten, stehen dann plötzlich in B1:C2, und die Formel steht nicht mehr in E1, sondern in F1. Sie müssten also nach dem Einfügen der neuen Spalte alle Formeln in der Tabelle – und eventuell in anderen Tabellen – kontrollieren und korrigieren.

Diese Arbeit nimmt Ihnen LibreOffice Calc aber glücklicherweise ab. Nachdem eine neue Spalte A eingefügt wurde, wird die Formel =SUMME(A1:B2) automatisch aktualisiert. Sie lautet dann =SUMME(B1:C2). Ebenso werden beim Einfügen einer neuen Zeile 1 die Zeilennummern automatisch aktualisiert. Wann immer ein referenzierter Bereich verschoben wird, korrigiert LibreOffice Calc absolute und relative Bezüge. Beachten Sie aber, dass beim Kopieren von Formeln ausschließlich die relativen Bezüge aktualisiert werden. Die absoluten Bezüge bleiben unverändert.

Absolute Bezüge werden für Berechnungen eingesetzt, die sich auf eine bestimmte Zelle in der Tabelle beziehen. Wird eine Formel mit einem Bezug auf exakt diese Zelle in eine Zelle unter der ursprünglichen Zelle kopiert, so wird auch der Bezug nach unten verschoben, sofern Sie die Zellenkoordinaten nicht als absolut definiert haben.

Außer beim Einfügen neuer Zeilen und Spalten können sich Bezüge auch ändern, wenn vorhandene Formeln mit Bezügen auf bestimmte Zellen in andere Tabellenbereiche kopiert werden. Gehen wir davon aus, Sie haben die Formel =SUMME(A1:A9) in Zeile 10 eingegeben. Um nun auch die Summe der rechts benachbarten Spalte zu ermitteln, kopieren Sie diese Formel einfach in die Zelle rechts neben dieser Zelle. Die Kopie der Formel in Spalte B wird automatisch in =SUMME(B1:B9) abgeändert.

Bitte unterstützen Sie uns!