Umwandeln von Text in Zahlen

Die Standardeinstellungen in Calc konvertieren Text in Zellen in die entsprechenden numerischen Werte, wenn eine eindeutige Konvertierung möglich ist. Wenn keine Konvertierung möglich ist, gibt Calc den Fehler #WERT! zurück.

Nur ganze Zahlen einschließlich Exponenten werden konvertiert und ISO-8601-Datums- und Uhrzeitangaben in ihren erweiterten Formaten mit Trennzeichen. Alles andere, wie zum Beispiel Bruchteile mit Dezimaltrennzeichen oder andere Datumsangaben als ISO-8601, wird nicht konvertiert, da die Textzeichenfolge vom Gebietsschema abhängt. Führende und nachfolgende Leerzeichen werden ignoriert.

Die folgenden ISO 8601 Formate werden umgewandelt:

Der Jahrhundertcode CC darf nicht entfallen. Statt des Datums- und Zeittrennzeichens T kann auch genau ein Leerzeichen stehen.

Wenn das Datum gegeben ist, muss es ein gültiges gregorianisches Kalenderdatum enthalten. In diesem Fall muss die optionale Zeit im Bereich von 00:00 bis 23:59:59,99999… sein.

Wenn nur ein Zeittext vorhanden ist, kann dieser einen Wert größer als 24 enthalten. Minuten und Sekunden können aber maximal den Wert 59 haben.

note

Die Konvertierung erfolgt nur fĂĽr einzelne Skalarwerte, nicht innerhalb von Bereichen.


Die Umrechnung erfolgt für einzelne Skalarwerte wie in =A1+A2 oder ="1E2"+1. Zellbereichsargumente sind nicht betroffen, daher unterscheidet sich SUMME(A1:A2) von A1+A2, wenn mindestens eine der beiden Zellen eine konvertierbare Zeichenfolge enthält.

Texte innerhalb von Formeln werden auch umgewandelt, so zum Beispiel in ="1999-11-22"+42, was den 42. Tag nach dem 22.11.1999 ergibt. Berechnungen, welche ein Datum in lokalem Format enthalten, liefern einen Fehler. Zum Beispiel kann der Datumstext "11/22/1999" oder "22.11.1999" nicht fĂĽr eine automatische Umwandlung verwendet werden.

warning

Wenn Sie Funktionen verwenden, bei denen ein oder mehrere Argumente Suchkriterien-Zeichenfolgen sind, die einen regulären Ausdruck darstellen, besteht der erste Versuch darin, die Zeichenfolgen-Kriterien in Zahlen umzuwandeln. Zum Beispiel wird in bestimmten Gebietsschemen ".0" in "0.0" konvertiert und so weiter. Bei Erfolg handelt es sich bei der Übereinstimmung nicht um eine Übereinstimmung mit regulären Ausdrücken, sondern um eine numerische Übereinstimmung. Wenn Sie jedoch zu einem Gebietsschema wechseln, in dem das Dezimaltrennzeichen nicht der Punkt ist, funktioniert die Konvertierung regulärer Ausdrücke. Um die Auswertung des regulären Ausdrucks anstelle eines numerischen Ausdrucks zu erzwingen, verwenden Sie einen Ausdruck, der nicht als numerisch falsch verstanden werden kann, beispielsweise ".[0]" oder ".\0" oder "(?i).0".


Beispiel

Geben Sie in A1 den Text '1e2 ein (der intern in die Zahl 100 konvertiert wird).

Geben Sie in A2 =A1+1 ein (was zu 101 fĂĽhrt).

Die Formel =SUMME(A1:A2) gibt 101 anstelle von 201 zurĂĽck, da die Konvertierung nicht in einem Bereich erfolgt, sondern nur fĂĽr einzelne skalare Werte. Hier wird '1e2 als Zeichenfolge behandelt, die fĂĽr die Funktion SUMME den Wert 0 hat.

=SUMME("1E2";1) gibt #WERT! zurĂĽck, weil SUMME() und einige andere, ĂĽber Zahlenfolgen iterierende Funktionen, den Argumenttyp explizit ĂĽberprĂĽfen.

Ă„ndern der Standardeinstellungen fĂĽr die Konvertierung von Text in Zahlen

Die Konvertierung von Text in Zahlen kann mit der Option Einstellungen fĂĽr detaillierte Berechnung angepasst werden.

Bitte unterstĂĽtzen Sie uns!