Funktion FEHLER.TYP

Ergibt eine Zahl, die dem Fehlertyp entspricht, oder den Fehlerwert #NV, wenn kein Fehler vorliegt.

tip

Diese Funktion ist seit LibreOffice 5.0 verfügbar.


Syntax

FEHLER.TYP(Fehlerwert)

Fehlerwert – erforderliches Argument. Der Fehlerwert oder ein Bezug zu einer Zelle, deren Wert untersucht werden soll.

Fehlerwert

Ergibt

Err:511

1

#DIV/0!

2

#WERT!

3

#REF!

4

#NAME?

5

#NUM!

6

#NV

7

Alles andere

#NV


Notizsymbol

Diese Funktion ist Teil des OpenDocument-Standards (Open Document Format for Office Applications) Version 1.2. (ISO/IEC 26300:2-2015)


Beispiel

Einfache Verwendung

=FEHLER.TYP(#NV)

Ergibt 7, da 7 der Index für den Fehlerwert #NV ist.

=FEHLER.TYP(A3)

Wenn A3 einen Ausdruck enthält, der einer Division durch Null entspricht, ergibt die Funktion 2, da 2 der Index für den Fehlerwert #DIV/0! ist.

Fortgeschrittene Möglichkeit

Wenn bei der Division von A1 durch A2 die Zelle A2 den Wert Null annehmen kann, können Sie die Situation wie folgt steuern:

=WENN(ISTFEHLER(A1/A2);WENN(FEHLER.TYP(A1/A2)=2;"Der Divisor darf nicht Null sein");A1/A2)

Die Funktion ISTFEHLER ergibt WAHR oder FALSCH, abhängig davon, ob ein Fehler vorliegt oder nicht. Wenn ein Fehler vorliegt, leitet die Funktion WENN zum zweiten Argument weiter, wenn kein Fehler vorliegt, ergibt sie das Ergebnis der Division. Das zweite Argument überprüft den Index, der den Fehlertyp darstellt, und ergibt, wenn dieser gleich 2 ist, den Text "Der Divisor darf nicht Null sein" oder andernfalls 0. Somit wird durch Text auf die Division durch Null hingewiesen, das Ergebnis der Division, wenn diese möglich ist, ausgegeben oder Null zurückgegeben, wenn beispielsweise ein anderer Fehlertyp vorliegt.

Warnsymbol

Wenn die Funktion FEHLER.TYP als Bedingung in einer Funktion WENN verwendet wird und FEHLER.TYP #NV ergibt, ergibt die Funktion WENN ebenfalls #NV. Verwenden Sie ISTFEHLER, um dieses Verhalten zu vermeiden, wie im Beispiel oben gezeigt.


Bitte unterstützen Sie uns!