COUNTIFS

Gibt die Anzahl an Zellen zurück, welche Bedingungen in mehreren Bereichen erfüllen.

tip

Diese Funktion ist seit LibreOffice 4.0 verfügbar.


Syntax

COUNTIFS(Range; Criterion[; Range2; Criterion2][; ... ; [Range127; Criterion127]])

Bereich 1 – erforderliches Argument. Ist ein Zellbereich, ein Name eines Bereichs oder eine Spalten-/Zeilenbeschriftung, welche(r) die Werte enthält, die bei erfüllter Bedingung gezählt werden sollen.

Criterion: A criterion is a single cell Reference, Number or Text. It is used in comparisons with cell contents.

A reference to an empty cell is interpreted as the numeric value 0.

A matching expression can be:

Bereich 2 – optional. Für Bereich 2 und folgende gilt dasselbe wie für Bereich 1.

Criterion2 – Optional. Criterion2 and all the following mean the same as Criterion.

Die Suche unterstützt Platzhalter oder Reguläre Ausdrücke. Wenn "Reguläre Ausdrücke" aktiviert sind, können Sie "ein. *" eingeben, um beispielsweise die erste Position von "ein" gefolgt von beliebigen Zeichen zu finden. Wenn Sie nach einem Text suchen möchten, der auch ein regulärer Ausdruck ist, müssen Sie entweder jedem Zeichen ein "\" voranstellen oder den Text in "\Q...\E" einschließen. Um die automatische Auswertung von Platzhaltern oder regulären Ausdrücken in ein- und ausschalten, wählen Sie – LibreOffice Calc – Berechnen.

warning

Wenn Sie Funktionen verwenden, bei denen ein oder mehrere Argumente Suchkriterien-Zeichenfolgen sind, die einen regulären Ausdruck darstellen, besteht der erste Versuch darin, die Zeichenfolgen-Kriterien in Zahlen umzuwandeln. Zum Beispiel wird in bestimmten Gebietsschemen ".0" in "0.0" konvertiert und so weiter. Bei Erfolg handelt es sich bei der Übereinstimmung nicht um eine Übereinstimmung mit regulären Ausdrücken, sondern um eine numerische Übereinstimmung. Wenn Sie jedoch zu einem Gebietsschema wechseln, in dem das Dezimaltrennzeichen nicht der Punkt ist, funktioniert die Konvertierung regulärer Ausdrücke. Um die Auswertung des regulären Ausdrucks anstelle eines numerischen Ausdrucks zu erzwingen, verwenden Sie einen Ausdruck, der nicht als numerisch falsch verstanden werden kann, beispielsweise ".[0]" oder ".\0" oder "(?i).0".


Range, Range2, ... and Criterion, Criterion2, ... must have the same size, otherwise the function returns err:502 - Invalid argument.

note

Die logische Beziehung zwischen Bedingungen kann als logisches UND (Konjunktion) definiert werden. In anderen Worten, wenn und nur wenn alle angegebenen Bedingungen zutreffen, wird ein Wert von der zugehörigen Zelle aus dem angegebenen Funktionsbereich in der Berechnung berücksichtigt.


Die Funktion kann bis zu 255 Argumente verarbeiten, bedeutet, dass Sie 127 Bereiche und Bedingungen angeben können.

Wenn die Zelle WAHR enthält, wird sie wie 1 behandelt, wenn FALSCH, wie 0 (Null).

note

Diese Funktion ist Teil des OpenDocument-Standards (Open Document Format for Office Applications) Version 1.2. (ISO/IEC 26300:2-2015)


Beispiel

Betrachten Sie folgende Tabelle

A

B

C

1

Produktname

Absatz

Einnahmen

2

Buntstift

20

65

3

Stift

35

85

4

Schulbuch

20

190

5

Buch

17

180

6

Buntstift-Set

nicht

nicht


warning

In allen unten stehenden Beispielen enthält der Bereich für die Berechnung der Summe die Zeile 6, diese wird aber ignoriert, da sie Text enthält.


Einfache Verwendung

=ZÄHLENWENNS(B2:B6;">=20")

Zählt die Anzahl der Zeilen im Bereich B2:B6, deren Wert größer oder gleich 20 ist. Ergibt 3, da die fünfte und sechste Zeile die Bedingung nicht erfüllen.

=ZÄHLENWENNS(B2:B6;">=20";C2:C6;">70")

Zählt die Anzahl der Zeilen die gleichzeitig Werte größer als 70 im Bereich C2:C6 und Werte größer oder gleich 20 im Bereich B2:B6 enthalten. Ergibt 2, da die zweite, fünfte und sechste Zeile je mindestens eine Bedingung nicht erfüllen.

Verwendung mit regulären Ausdrücken und verschachtelten Funktionen

Damit diese Beispiele richtig funktionieren, stellen Sie sicher, dass Reguläre Ausdrücke in Formeln ermöglichen in – LibreOffice Calc – Berechnen ausgewählt ist .

=ZÄHLENWENNS(B2:B6;"[:alpha:]*")

Zählt die Anzahl der Zeilen im Bereich B2:B6, die nur Buchstaben enthalten. Ergibt 1, da nur die sechste Zeile die Bedingung erfüllt.

=ZÄHLENWENNS(B2:B6;">"&MIN(B2:B6);B2:B6;"<"&MAX(B2:B6))

Zählt die Anzahl der Zeilen im Bereich B2:B6, außer der Zeilen mit Maximal- und Minimalwerten in diesem Bereich. Ergibt 2, da die dritte, fünfte und sechste Zeile je mindestens eine Bedingung nicht erfüllen.

=ZÄHLENWENNS(A2:A6;".*stift";B2:B6;"<"&MAX(B2:B6))

Zählt die Anzahl der Zeilen, deren Zellen im Bereich A2:A6 auf "stift" enden und deren Zellen im Bereich B2:B6 nicht den Maximalwert enthalten. Ergibt 1, da nur die zweite Zeile alle Bedingungen erfüllt.

Bezüge zu einer Zelle mit einer Bedingung

Um eine Bedingung einfach zu ändern, bietet es sich an, diese in einer separaten Zelle festzulegen und für die Bedingung der Funktion ZÄHLENWENNS einen Bezug zur Zelle anzugeben. Beispielsweise kann obige Funktion geschrieben werden als:

=ZÄHLENWENNS(A2:A6;".*"&E2;B2:B6;"<"&MAX(B2:B6))

Wenn E2 = stift ist, ergibt die Funktion 1, da der Bezug zur Zelle derem Inhalt entspricht und wie die Funktion oben funktioniert.

Datei mit Beispiel öffnen:

Bitte unterstützen Sie uns!