FEJL.TYPE-funktion

Returnerer et tal, som repræsenterer en specifik fejltype, eller fejlværdien #N/A, hvis der ikke er nogen fejl.

tip

Denne funktion er tilgængelig siden LibreOffice 5.0.


Syntaks

FEJL.TYPE(Fejl_værdi)

Fejl_værdi – påkrævet argument. Fejlværdi eller reference til en celle, hvis værdi skal valideres.

Fejlværdi

Returnerer

Err:511

1

#DIV/0!

2

#VÆRDI!

3

#REF!

4

#NAVN?

5

#NUM!

6

#N/A

7

Andet

#N/A


note

Denne funktion er en del af Open Document Format for Office Applications (OpenDocument) standard Version 1.2. (ISO/IEC 26300:2-2015)


Eksempel

Simpelt brug

=FEJL.TYPE(#N/A)

Returnerer 7, fordi 7 er indeksnummeret for fejlværdien #N/A.

=FEJL.TYPE(A3)

Hvis A3 indeholder et udtryk tilsvarende division med nul, returnerer funktionen 2, fordi 2 er indekstallet for fejlværdien #DIV/0!

Mere avanceret mĂĄde

Hvis ved division af A1 med A2, kan A2 blive nul, hvilket du kan håndtere på følgende måde:

=HVIS(ER.FEJL(A1/A2);HVIS(FEJL.TYPE(A1/A2)=2;"Nævneren kan ikke være nul");A1/A2)

Funktionen ER.FEJL returnerer enten SAND eller FALSK afhængigt af, om der er en fejl eller ikke. Hvis der er en fejl, vil funktionen HVIS adressere det andet argument, og hvis der ikke er en fejl, returneres resultatet af beregningen. Det andet argument kontrollerer indeksnummeret for den konkrete fejltype, og hvis den er lig med 2, returnerer den teksten "Nævneren må ikke være nul" og ellers 0. Således vil tekst ikke tilfredsstille division med nul, og divisionens resultat vil blive returneret korrekt, og hvis der f.eks. er er en fejl af en anden type, returneres nul.

Advarselsikon

Hvis funktionen FEJL.TYPE bruges som betingelse i funktionen HVIS og FEJL.TYPE returnerer #N/A, returnerer funktionen HVIS ogsĂĄ #N/A. Benyt ER.FEJL for at undgĂĄ dette som vist i eksemplet herover.


Støt os venligst!