Relace

Tento příkaz otevře okno Návrh relace, kde je možné nastavit relace mezi různými tabulkami databáze.

Pomocí společných datových polí je možné navzájem propojit tabulky aktuální databáze. Klepněte na ikonu Nová relace pro vytvoření relace nebo pole jednoduše přetáhněte.

Pro přístup k tomuto příkazu...

V okně databázového souboru zvolte Nástroje - Relace.


Ikona poznámky

Tato funkce je dostupná jen tehdy, pokud pracujete s relační databází.


Pokud klepnete na příkaz Nástroje - Relace, otevře se okno se všemi existujícími relacemi mezi tabulkami současné databáze. Pokud nejsou určeny žádné relace nebo chcete propojit jiné tabulky databáze, klepněte na ikonu Přidat tabulky. Otevře se dialogové okno Přidat tabulky, ve kterém je možné vybrat tabulky, pro které chcete relaci vytvořit.

Ikona Přidat tabulku

Vložit tabulky

Ikona poznámky

Je-li otevřeno okno Návrh relace, nelze vybrané tabulky upravovat ani v návrhovém režimu. To zajišťuje, že se během vytváření relací nezmění tabulky.


Vybrané tabulky se zobrazí v horní části okna návrhu relace. Okno tabulky je možné zavřít pomocí místní nabídky nebo klávesy Delete.

Posunutí a změna velikosti tabulky

Tabulky je možné podle potřeby uspořádávat a měnit jejich velikost. Jestliže chcete tabulku posunout, přetáhněte její horní okraj na požadovanou pozici. Okno tabulky zvětšíte nebo zmenšíte tak, že umístíte kurzor myši na jeho ohraničení nebo roh a tažením myši jej upravíte na požadovanou velikost.

Primární klíč a cizí klíče

Pokud chcete nastavit relaci mezi dvěma různými tabulkami, měli byste určit primární klíč, který jednoznačně identifikuje záznamy existující tabulky. Na primární klíč je možné se odkazovat z jiných tabulek při přístupu k údajům v této tabulce. Všechna datová pole odkazující na tento primární klíč se označí jako cizí klíče.

Všechna datová pole odkazující na primární klíč budou označena v okně tabulek malým symbolem klíče.

Definování relací

Všechny existující relace jsou zobrazeny v okně relací jako čára spojující primární a cizí klíče. Relaci je možné přidat přetáhnutím pole z jedné tabulky na pole jiné tabulky. Relaci odstraníte vybráním a stiskem klávesy Delete.

Je také možné klepnout na ikonu Nová relace v horní části okna relací a určit relaci mezi dvěma tabulkami v dialogu Relace.

Ikona Nová relace

Nová relace

Ikona upozornění

Pokud používáte LibreOffice jako rozhraní k relační databázi, neukládá se vytvoření a odstranění relací do přechodné paměti LibreOffice, ale přeposílá se přímo databázi.


Poklepáním na spojnici je možné relaci přiřadit vlastnosti. Otevře se dialog Relace.

Podpořte nás!