Adreces i refer猫ncies, absolutes i relatives

Refer猫ncies a cel路les

An individual cell is fully identified by the sheet it belongs, the column identifier (letter) located along the top of the columns and a row identifier (number) found along the left-hand side of the spreadsheet. On spreadsheets read from left to right, the complete reference for the upper left cell of the sheet is Sheet.A1.

Intervals de cel路les

You can reference a set of cells by referencing them in ranges. Ranges can be a block of cells, entire set of columns and entire set of rows. The range A1:B2 is the first four cells in the upper left corner of the sheet. Range A:E contains all the cells of column A, B, C, D and E. Range 2:5 contains all the cells of row 2, 3, 4 and 5.

The reference to a cell of another document contains the fully qualified name of the other document between single quotes ('), then a hash #, then the name of the sheet of the other document, followed by a period and the name or reference of the cell.

Per exemple, .

note

The path and document name URI must always be enclosed in single quotes. If the name contains single quotes (') they must be escaped using two single quotes (''). Only a sheet name may not be quoted if it does not contain a space or a character that would be an operator or the name would be pure numeric (for example, '123' must be quoted).


Operadors de refer猫ncia

Aquests operadors retornen un interval de cel路les de zero, una o m茅s cel路les.

L'interval t茅 la preced猫ncia m茅s alta, tot seguit ve la intersecci贸, i finalment la uni贸.

Operador

Nom

Exemple

:

Interval

A1:C108, A:D or 3:13

!

Intersecci贸

SUMA(A1:B6!B5:C12)

Calcula la suma de totes les cel路les a la intersecci贸; en aquest exemple, el resultat dona la suma de les cel路les B5 i B6.

~

Concatenaci贸 o uni贸

Takes two references and returns a reference list, which is a concatenation of the left reference followed by the right reference. Double entries are referenced twice.

=COUNT(A1:B2~B2:C3) counts values of A1:B2 and B2:C3. Note that the cell B2 is counted twice.

=INDEX(A1:B2~C1:D2;2;1;2) selects cell C2, that is, the first cell of the second row, first column, of the second range (C1:D2) of the range list.


note

A reference list is not allowed inside an array expression.


Adreces relatives

La cel路la de la columna A, fila 1 s'anomena A1. Podeu assignar un interval de cel路les adjacents introduint abans les coordenades de la cel路la superior esquerra de l'脿rea i a continuaci贸 dos punts seguits per les coordenades de la cel路la inferior dreta. Per exemple, el quadrat format per les quatre primeres cel路les de l'angle superior esquerre s'assigna com a A1:B2.

Si assigneu una 脿rea d'aquesta manera, esteu fent una refer猫ncia relativa a A1:B2. Aqu铆, relativa vol dir que la refer猫ncia a aquesta 脿rea s'ajustar脿 autom脿ticament quan copieu les f贸rmules.

Adreces absolutes

Les refer猫ncies absolutes s贸n les oposades a l'assignaci贸 d'adreces relatives. En una refer猫ncia absoluta el signe del d貌lar se situa davant de cada lletra i de cada nombre, per exemple, $A$1:$B$2.

tip

LibreOffice can convert the current reference, in which the cursor is positioned in the input line, from relative to absolute and vice versa by pressing F4. If you start with a relative address such as A1, the first time you press this key combination, both row and column are set to absolute references ($A$1). The second time, only the row (A$1), and the third time, only the column ($A1). If you press the key combination once more, both column and row references are switched back to relative (A1)


El LibreOffice Calc mostra les refer猫ncies a una f贸rmula. Si, per exemple, feu clic a la f贸rmula =SUMA(A1:C5;D15:D24) a una cel路la, les dues 脿rees referenciades en el full es real莽aran amb un color. Per exemple, el component de la f贸rmula 芦A1:C5禄 pot estar en blau i l'interval de la cel路la en q眉esti贸 pot tenir vores del mateix to de blau. El seg眉ent component de la f贸rmula 芦D15:D24禄 pot estar marcat en vermell de la mateixa manera.

Quan s'han d'utilitzar les refer猫ncies relatives i absolutes

Qu猫 distingeix una refer猫ncia relativa? Suposeu que a la cel路la E1 voleu calcular la suma de les cel路les de l'interval A1:B2. La f贸rmula que caldria introduir a E1 seria: =SUMA(A1:B2). Si m茅s tard decidiu inserir una columna nova davant de la columna A, els elements que voleu afegir es trobarien a B1:C2 i la f贸rmula seria a F1, no a E1. Despr茅s d'inserir la columna nova, haur铆eu de revisar i corregir totes les f贸rmules del full, i possiblement les d'altres fulls.

Afortunadament, el LibreOffice fa aquesta feina de manera autom脿tica. Despr茅s d'haver inserit la columna nova A, la f贸rmula =SUMA(A1:B2) s'actualitzar脿 autom脿ticament a =SUMA(B1:C2). Els nombres de les files tamb茅 s'ajustaran autom脿ticament quan s'insereixi una fila 1 nova. Les refer猫ncies absolutes i relatives s'ajusten al LibreOffice Calc sempre que es mou l'脿rea referenciada, per貌 aneu amb compte quan copieu una f贸rmula, ja que en aquest cas nom茅s s'ajustaran les refer猫ncies relatives, no les absolutes.

Les refer猫ncies absolutes s'utilitzen quan un c脿lcul es refereix a una cel路la espec铆fica del full. Si una f贸rmula que es refereix exactament a aquesta fila es copia de manera relativa a una cel路la sota de l'original, la refer猫ncia tamb茅 es mour脿 cap avall si no heu definit les coordenades de la cel路la com a absolutes.

A banda de quan s'insereixen files i columnes noves, les refer猫ncies tamb茅 poden canviar quan una f贸rmula existent que es refereix a cel路les particulars es copia a una altra 脿rea del full. Suposeu que heu introdu茂t la f贸rmula =SUMA(A1:A9) a la fila 10. Si voleu calcular la suma per a la columna adjacent a la dreta, simplement copieu la f贸rmula a la cel路la de la dreta. La c貌pia de la f贸rmula a la columna B s'ajustar脿 autom脿ticament a =SUMA(B1:B9).

Ens cal la vostra ajuda!