Conversió de text a nombres

Defaults settings in Calc converts text inside cells to the respective numeric values if an unambiguous conversion is possible. If no conversion is possible, Calc returns a #VALUE! error.

Només els nombres enters inclosos els exponents es converteixen i ISO 8601 dates i hores en els seus formats ampliats amb separadors. Qualsevol altra cosa com els nombres fraccionaris amb separadors decimals o dates diferents de l'ISO 8601 no es convertirà ja que la cadena de text dependrà de la localització. S'ignoren els espais en blanc inicials i finals.

Els formats ISO 8601 següents es converteixen:

El codi de segle SS no es pot ometre. En lloc del separador de data i hora T, es pot utilitzar exactament un caràcter d'espai.

Si s'introdueix una data, ha de ser una data vàlida del calendari gregorià. En aquest cas, l'hora opcional ha de ser dins l'interval de 00:00 a 23:59:59,99999...

Si només s'introdueix una cadena d'hora, pot tenir un valor d'hora superior a 24, però els minuts i els segons han de tenir un valor màxim de 59.

note

The conversion is done for single scalar values only, not within ranges.


The conversion is done for single scalar values, as in =A1+A2, or ="1E2"+1. Cell range arguments are not affected, so SUM(A1:A2) differs from A1+A2 if at least one of the two cells contain a convertible string.

Les cadenes dins de fórmules també es converteixen, com ara ="1999-11-22"+42, que retorna la data corresponent a 42 dies posteriors al 22 de novembre de 1999. Els càlculs que impliquin dates localitzades com a cadenes dins de la fórmula retornen un error. Per exemple, la cadena de data localitzada "11/22/1999" o "22.11.1999" no es pot utilitzar per a la conversió automàtica.

warning

When using functions where one or more arguments are search criteria strings that represents a regular expression, the first attempt is to convert the string criteria to numbers. For example, ".0" will convert to 0.0 and so on. If successful, the match will not be a regular expression match but a numeric match. However, when switching to a locale where the decimal separator is not the dot makes the regular expression conversion work. To force the evaluation of the regular expression instead of a numeric expression, use some expression that can not be misread as numeric, such as ".[0]" or ".\0" or "(?i).0".


Exemple

In A1 enter the text '1e2 (which is converted to the number 100 internally).

In A2 enter =A1+1 (which correctly results in 101).

The formula =SUM(A1:A2), returns 101 instead of 201 because the conversion does not occur in a range, only for single scalar values. Here, '1e2 is treated as string which is ignored for the SUM function.

=SUMA("1E2";1) retorna #VALUE! perquè SUM() i alguns altres que iteren sobre seqüències de nombres verifiquen explícitament el tipus d'argument.

Changing the default text to number conversion settings

The text to number conversion can be customized in the Detailed Calculation Settings option.

Ens cal la vostra ajuda!