F贸rmula

Defineix les opcions de sintaxi de la f贸rmula per al LibreOffice Calc.

Per accedir a esta orde...

Obri un document de full de c脿lcul trieu - LibreOffice Calc - F贸rmula


Opcions de f贸rmula

Sintaxi de la f贸rmula

There are three options. Let's see it by example. In a sample spreadsheet there are two worksheets, Sheet1 and Sheet2. In A1 cell of Sheet1 there is a reference to C4 cell of Sheet2.

Utilitza els noms de les funcions en angl茅s

In LibreOffice Calc function names can be localized. By default, the check box is off, which means the localized function names are used. Checking this check box will swap localized function names with the English ones. This change takes effect in all of the following areas: formula input and display, function wizard, and formula tips. You can of course uncheck it to go back to the localized function names.

Separadors

This option group lets you configure separators in your formula expressions. This comes in handy when, for instance, you want to separate your function parameters by commas (,) instead of semicolons (;).

Per exemple, en comptes de =SUMA(A1;B1;C1) podeu escriure =SUMA(A1,B1,C1).

Likewise, you can also change the column and row separators for in-line arrays. Previously, an in-line array used semicolons (;) as the column separators and the pipe symbols (|) as the row separators, so a typical in-line array expression looked like this for a 5 x 2 matrix array:

={1;2;3;4;5|6;7;8;9;10}

By changing the column separators to commas (,) and the row separators to semicolons (;), the same expression will look like this:

={1,2,3,4,5;6,7,8,9,10}

Configuraci贸 detallada de c脿lcul

Estableix les regles per a la conversi贸 des de valors de cadenes a valors num猫rics valors de cadena a refer猫ncies de cel路les i valors de cadenes a valors de data i hora. Aix貌 afecta funcions integrades com INDIRECTE que pren una refer猫ncia com a valor de cadena o funcions de data i hora que prenen arguments com a valors de cadena en formats locals o ISO 8601.

Torna a calcular en carregar el fitxer

Recalculating formulas can take significant time while loading very large files.

Excel 2007 i posteriors:

La c脿rrega d'un fitxer de full de c脿lcul gran pot trigar molt de temps. Si no necessiteu actualitzar les dades del full de c脿lcul gran immediatament podeu posposar el recalculaci贸 en un temps millor. El LibreOffice permet ajornar el recalculament dels fulls de c脿lcul de l'Excel 2007 (i superiors) per accelerar el temps de c脿rrega.

Full de c脿lcul ODF (no guardat amb el LibreOffice):

Recent versions of LibreOffice caches spreadsheet formula results into its ODF file. This feature helps LibreOffice to recalculate a large ODF spreadsheet saved by LibreOffice faster.

For ODF spreadsheets saved by other programs, where such cached formula results may not exist, recalculation can be deferred to speedup file loading as with Excel 2007 files.

For the entries above the following choices are possible:

tip

LibreOffice saved ODF spreadsheets will honor Never recalculate and Always recalculate options.


Ens cal la vostra ajuda!