Adreces i referències, absolutes i relatives

Adreces relatives

La cel·la de la columna A, fila 1 s'anomena A1. Podeu assignar un interval de cel·les adjacents introduint abans les coordenades de la cel·la superior esquerra de l'àrea i a continuació dos punts seguits per les coordenades de la cel·la inferior dreta. Per exemple, el quadrat format per les quatre primeres cel·les de l'angle superior esquerre s'assigna com a A1:B2.

Si assigneu una àrea d'esta manera, esteu fent una referència relativa a A1:B2. Ací, relativa vol dir que la referència a esta àrea s'ajustarà automàticament quan copieu les fórmules.

Adreces absolutes

Absolute referencing is the opposite of relative addressing. A dollar sign is placed before each letter and number in an absolute reference, for example, $A$1:$B$2.

Icona de consell

LibreOffice can convert the current reference, in which the cursor is positioned in the input line, from relative to absolute and vice versa by pressing F4. If you start with a relative address such as A1, the first time you press this key combination, both row and column are set to absolute references ($A$1). The second time, only the row (A$1), and the third time, only the column ($A1). If you press the key combination once more, both column and row references are switched back to relative (A1)


LibreOffice Calc shows the references to a formula. If, for example, you click the formula =SUM(A1:C5;D15:D24) in a cell, the two referenced areas in the sheet will be highlighted in color. For example, the formula component "A1:C5" may be in blue and the cell range in question bordered in the same shade of blue. The next formula component "D15:D24" can be marked in red in the same way.

Quan s'han d'utilitzar les referències relatives i absolutes

Què distingeix una referència relativa? Suposeu que a la cel·la E1 voleu calcular la suma de les cel·les de l'interval A1:B2. La fórmula que caldria introduir a E1 seria: =SUMA(A1:B2). Si més tard decidiu inserir una columna nova davant de la columna A, els elements que voleu afegir es trobarien a B1:C2 i la fórmula seria a F1, no a E1. Després d'inserir la columna nova, hauríeu de revisar i corregir totes les fórmules del full, i possiblement les d'altres fulls.

Afortunadament, el LibreOffice fa esta faena de manera automàtica. Després d'haver inserit la columna nova A, la fórmula =SUMA(A1:B2) s'actualitzarà automàticament a =SUMA(B1:C2). Els nombres de les files també s'ajustaran automàticament quan s'inserisca una fila 1 nova. Les referències absolutes i relatives s'ajusten al LibreOffice Calc sempre que es mou l'àrea referenciada, però aneu amb compte quan copieu una fórmula, ja que en este cas només s'ajustaran les referències relatives, no les absolutes.

Les referències absolutes s'utilitzen quan un càlcul es refereix a una cel·l'específica del full. Si una fórmula que es refereix exactament a esta fila es copia de manera relativa a una cel·la sota de l'original, la referència també es mourà cap avall si no heu definit les coordenades de la cel·la com a absolutes.

A banda de quan s'insereixen files i columnes noves, les referències també poden canviar quan una fórmula existent que es refereix a cel·les particulars es copia a una altra àrea del full. Suposeu que heu introduït la fórmula =SUMA(A1:A9) a la fila 10. Si voleu calcular la suma per a la columna adjacent a la dreta, simplement copieu la fórmula a la cel·la de la dreta. La còpia de la fórmula a la columna B s'ajustarà automàticament a =SUMA(B1:B9).

Please support us!