Fórmula

Define les opciones de sintaxis de la fórmula pa LibreOffice Calc.

P'aportar a esti comandu...

Open a spreadsheet document, choose - LibreOffice Calc - Formula.


Opciones de fórmula

Sintaxis de la formula

Hai trés opciones. Veamos un exemplu. Una fueya de cálculu d'exemplu tien dos fueyes de trabayu, Fueya1 y Fueya2. Na caxella A1 de la Fueya1 hai una referencia a la caxella C4 de la Fueya2.

Use English function names

In LibreOffice Calc function names can be localized. By default, the check box is off, which means the localized function names are used. Checking this check box will swap localized function names with the English ones. This change takes effect in all of the following areas: formula input and display, function wizard, and formula tips. You can of course uncheck it to go back to the localized function names.

Separadores

This option group lets you configure separators in your formula expressions. This comes in handy when, for instance, you want to separate your function parameters by commas (,) instead of semicolons (;).

Por exemplu, en llugar de =SUMA(A1;B1;C1) pue escribise =SUMA(A1,B1,C1).

Del mesmu mou, tamién pue camudar los separadores de columna y filera nes matrices en llinia. Anteriormente, una matriz en llinia usaba puntos y comes (;) como separadores de columna y símbolos de tubería (|) como separadores de filera, de mou qu'una espresión típica de matriz en llinia paecíase a esto pa una matriz de 5 x 2:

={1;2;3;4;5|6;7;8;9;10}

Camudando los separadores de columna a comes (,) y los separadores de filera a puntu y coma (;), la mesma espresión veráse d'esti mou:

={1,2,3,4,5;6,7,8,9,10}

Detailed Calculation Settings

Sets the rules for conversion from strings values to numeric values, string values to cell references, and strings values to date and time values. This affects built-in functions such as INDIRECT that takes a reference as a string value or date and time functions that takes arguments as string values in local or ISO 8601 formats.

Recalculation on File Load

P'aportar a esti comandu...

Choose - LibreOffice Calc - Formula.


Recalculating formulas can take significant time while loading very large files.

Excel 2007 and newer:

Loading a large spreadsheet file can take a long time. If you don't need to update your large spreadsheet data immediately, you can postpone the recalculation at a better time. LibreOffice allows you to defer recalculation of Excel 2007 (and above) spreadsheets to speedup loading time.

ODF Spreadsheet (not saved by LibreOffice):

Recent versions of LibreOffice caches spreadsheet formula results into its ODF file. This feature helps LibreOffice to recalculate a large ODF spreadsheet saved by LibreOffice faster.

For ODF spreadsheets saved by other programs, where such cached formula results may not exist, recalculation can be deferred to speedup file loading as with Excel 2007 files.

For the entries above the following choices are possible:

Iconu de conseyu

LibreOffice saved ODF spreadsheets will honor Never recalculate and Always recalculate options.


Please support us!