Direiciones y referencies, absolutes y relatives

Referencia relativa

A1 fai referencia a la caxella na columna A y filera 1. La referencia a una área allegante consíguese indicando la esquina cimera esquierda del área, depués dos puntos y finalmente la caxella inferior derecha del área. La área cuadrada de les primeres cuatro caxelles na esquina cimera esquierda llamaríase d'esta miente A1:B2.

Nesta forma de referencia a una área, la referencia a A1:B2 va ser una referencia relativa. Relativa significa nesti contestu que la referencia axustaráse al área al copiar les fórmules.

Referencia absoluta

Absolute referencing is the opposite of relative addressing. A dollar sign is placed before each letter and number in an absolute reference, for example, $A$1:$B$2.

Iconu de conseyu

LibreOffice can convert the current reference, in which the cursor is positioned in the input line, from relative to absolute and vice versa by pressing F4. If you start with a relative address such as A1, the first time you press this key combination, both row and column are set to absolute references ($A$1). The second time, only the row (A$1), and the third time, only the column ($A1). If you press the key combination once more, both column and row references are switched back to relative (A1)


LibreOffice Calc shows the references to a formula. If, for example, you click the formula =SUM(A1:C5;D15:D24) in a cell, the two referenced areas in the sheet will be highlighted in color. For example, the formula component "A1:C5" may be in blue and the cell range in question bordered in the same shade of blue. The next formula component "D15:D24" can be marked in red in the same way.

¿Cuándo usar referencies relatives y cuándo absolutes?

¿Cómo s'estrema una referencia relativa? Supongamos que deseya calcular na caxella Y1 la suma de les caxelles nel área A1:B2. La fórmula que tien d'introducir en Y1 ten de ser: =SUMA(A1:B2). Si más tarde decide inxertar una columna nueva delantre de la columna A, los elementos que quier sumar van apaecer entós en B1:C2 y la fórmula en F1, en llugar d'en Y1. Poro, n'inxertando la nueva columna, tendría de comprobar y correxir toles fórmules de la fueya, y posiblemente n'otres fueyes.

Afortunadamente, LibreOffice encargar d'ello. Dempués d'inxertar una nueva columna A, la fórmula SUMA(A1:B2) anovar a =SUMA(B1:C2) de forma automática. Los númberos de filera tamién s'axusten automáticamente al inxertar una nueva filera 1. Les referencies absolutu y relativu axústense en LibreOffice Calc siempres que se mueve l'área a la que se fai referencia. Tenga curiáu, sicasí, al copiar una fórmula, yá que nesi casu namái afáense les referencies relatives, non les absolutes.

Les referencies absolutes utilícense cuando un cálculu fai referencia a una caxella específica de la fueya. Si una fórmula que fai referencia precisamente a esa caxella copiar a una caxella asitiada más embaxo que la orixinal, la referencia va movese escontra baxo si nun se definieron les coordenaes como absolutes.

Amás de col inxertamientu de nueves files y columnes, les referencies tamién puen camudar si una fórmula que fai referencia a caxelles específiques copiase n'otru área de la fueya. Suponemos qu'escribió la fórmula =SUMA(A1:A9) na filera 10. Si quier calcular la suma de la columna axacente a la derecha, namái tien que copiar esta fórmula na caxella de la derecha. La copia de la fórmula na columna B axustaráse automáticamente pa llograr =SUMA(B1:B9).

Please support us!