Manexu de caxelles baleres

Primeramente, les caxelles baleres taben forzaes al númberu 0 en dellos contestos y a cadenes baleres n'otros, sacante en comparances directes onde =A1=0 y =A1="" dambes resultaben en VERDADERU si A1 taba balera. Agora la cualidá de baleru heredar hasta que seya utilizada, asina ye que dambos =BUSCARV(...)=0 y =BUSCARV(...)="" dan VERDADERU si la resultancia de la busca devuelve una caxella balera.

Una simple referencia pa una caxella balera entá se visualiza como un númberu 0 pero nun ye necesariamente de tipu numbéricu, de cuenta que les comparances con referencia a la caxella funcionen como s'espera.

Pal siguiente exemplu, A1 contién un númberu, B1 esta vacio, C1 contién la referencia a B1:

Case

Formula

Results and comments

A1: 1
B1: <Empty>

C1: =B1

Displays 0

=B1=0

TRUE

=B1=""

TRUE

=C1=0

TRUE

=C1=""

TRUE (previously was FALSE)

=ISNUMBER(B1)

FALSE

=ISNUMBER(C1)

FALSE (previously was TRUE)

=ISNUMBER(VLOOKUP(1;A1:C1;2))

FALSE (B1)

=ISNUMBER(VLOOKUP(1;A1:C1;3))

FALSE (C1, previously was TRUE)

=ISTEXT(B1)

FALSE

=ISTEXT(C1)

TRUE

=ISTEXT(VLOOKUP(1;A1:C1;2))

FALSE (B1, previously was TRUE)

=ISTEXT(VLOOKUP(1;A1:C1;3))

FALSE (C1)

=ISBLANK(B1)

TRUE

=ISBLANK(C1)

TRUE

=ISBLANK(VLOOKUP(1;A1:C1;2))

TRUE (B1, previously was FALSE)

=ISBLANK(VLOOKUP(1;A1:C1;3))

FALSE (C1)


Iconu de nota

Note que Microsoft Excel pórtase distintu y siempres devuelve un númberu como la resultancia d'una referencia pa una caxella balera o una fórmula na caxella cola resultancia d'una caxella balera. Por exemplu:


Case

Formula

Results and comments

A1: <Empty>

B1: =A1

Displays 0, but is just a reference to an empty cell.

=ISNUMBER(A1)

FALSE

=ISTEXT(A1)

FALSE

=A1=0

TRUE

=A1=""

TRUE

=ISNUMBER(B1)

FALSE (Microsoft Excel: TRUE)

=ISTEXT(B1)

FALSE

=B1=0

TRUE

=B1=""

TRUE (Microsoft Excel: FALSE)

C1: =VLOOKUP(...) with empty cell result

displays empty (Microsoft Excel: displays 0)

=ISNUMBER(VLOOKUP(...))

FALSE

=ISTEXT(VLOOKUP(...))

FALSE

=ISNUMBER(C1)

FALSE (Microsoft Excel: TRUE)

=ISTEXT(C1)

FALSE


Please support us!