入力支援を使用する

From LibreOffice Help
Jump to: navigation, search

LibreOffice Writer の入力支援の機能を利用すると、ユーザーの指定するテキストを登録しておき、必要時にドキュメントに挿入することができます。登録内容には、テキストの書式設定や、図、表、フィールドを含めることもできます。

入力支援項目を作成する

  1. 入力支援の項目として登録するテキスト、画像付きテキスト、表、フィールドを選択します。登録できる画像は、1 つの文字としてアンカーされ前後に最低 1 文字が置かれているものだけです。
  2. ファイル → エクスポート を選択します。
  3. 入力支援の登録カテゴリを選択します。
  4. 最低 4 文字以上の名前を入力します。これにより 入力中にテキストブロック名をヒント表示する オプションの設定が適用されます。ショートカットの候補文字は自動で入力されますが、必要であればユーザーによる変更ができます。
  5. 入力支援 ボタンをクリックして、新規作成 を選択します。
  6. 閉じる ボタンをクリックします。

入力支援の項目を挿入する

  1. ドキュメント上で、入力支援の項目を挿入する位置にカーソルを移動します。
  2. 編集 → 入力支援 を選択します。
  3. 挿入したい入力支援項目を選択し、挿入をクリックします。

また、入力支援の項目のショートカットを入力して F3 キーを押すか、挿入バーにある入力支援アイコンの横にある矢印をクリックして、入力支援の項目を選択することもできます。

Tip.png fnと入力してから F3 キーを押すと、LibreOffice Math で作成した数式が挿入できます。数式を複数挿入すると、自動的に連番が付けられます。dtと入力してから F3 キーを押すと、ダミーテキストが挿入されます。

入力支援の項目を印刷する

  1. ツール → マクロ → マクロの管理→ LibreOffice Basic を選択します。
  2. In the Macro from tree control, select LibreOffice Macros - Gimmicks - AutoText.
  3. Select "Main" in the Existing macros in: AutoText list and then click Run. A list of the current AutoText entries is generated in a separate text document.
  4. ファイル → 印刷 を選択します。

ネットワーク上での入力支援

入力支援の項目は、ネットワーク上にある他のディレクトリに保存することもできます。

たとえば、自社関連の「読み取り専用」の入力支援項目は中央サーバーに格納し、ユーザー定義の入力支援項目はローカルディレクトリに格納するなどの管理が行えます。

入力支援ディレクトリへのパスは、設定で編集できます。

ここには、2 つのディレクトリがリストに表示されます。最初の項目はサーバーインストール用のもので、2 番目の項目はユーザーディレクトリです。両方のディレクトリに同じ名前の入力支援項目がある場合、ユーザーディレクトリのものが使用されます。


Related Topics

編集 → 入力支援

ワードコンプリーション