使用 Microsoft Office 和 LibreOffice

From LibreOffice Help
Jump to: navigation, search

LibreOffice can open and save documents in the Microsoft Office file formats, including Microsoft Office Open XML formats.

開啟 Microsoft Office 檔案

  1. 選擇[檔案] - [開啟舊檔]。在 LibreOffice 檔案開啟對話方塊中選取 Microsoft Office 檔案。
MS Office 檔案... ...將在 LibreOffice 模組中開啟
MS Word、*.doc、*.docx LibreOffice Writer
MS Excel、*.xls、*.xlsx LibreOffice Calc
MS PowerPoint、*.ppt、*.pps、*.pptx LibreOffice Impress

儲存為 Microsoft Office 檔案

  1. 選擇[檔案] - [另存新檔]
  2. [檔案類型]方塊中,選取 Microsoft Office 檔案格式。

文件依預設儲存為 Microsoft Office 格式

  1. 選擇 [工具] - [選項] - [載入/儲存] - [一般]
  2. [預設檔案格式及 ODF 設定] 區域中,先選取文件類型,然後選取用於儲存的檔案類型。

從今以後,如果您儲存文件,[檔案類型]將依照您的選擇而定。當然,您仍可以在檔案儲存對話方塊中選取其他的檔案類型。

將多個 Microsoft Office 檔案轉換成 Open Office 格式

[文件轉換器精靈] 可將資料夾中所有的 Microsoft Office 檔案加以複製並轉換成 Open Office 檔案格式的 LibreOffice 文件。您可以指定要讀取的資料夾,以及儲存已轉換檔案的資料夾。

  1. 選擇 [檔案] - [精靈] - [文件轉換器] 以啟動精靈。

Microsoft Office 和 LibreOffice 中的巨集

除了一部分例外情況,Microsoft Office 與 LibreOffice 無法執行相同的巨集程式碼。Microsoft Office 使用 VBA (Visual Basic for Applications) 程式碼,LibreOffice 則使用以 LibreOffice API (應用程式介面) 環境為基礎的 Basic 程式碼。雖然程式設計語言相同,但物件與方法不同。

Note.png The most recent versions of LibreOffice can run some Excel Visual Basic scripts if you enable this feature at Tools - Options' - Load/Save - VBA Properties'.

如果您在其中一個應用程式中使用巨集,並要在其他應用程式中使用同一功能,則必須編輯這些巨集。LibreOffice 可以載入在 Microsoft Office 檔案內包含的巨集,然後您即可在 LibreOffice Basic IDE 編輯器中檢視和編輯巨集程式碼。

您可以選擇保留或刪除 VBA 巨集

開啟包含 VBA 巨集程式碼的 Microsoft Office 文件。僅變更一般內容 (文字、儲存格、圖形),不要編輯巨集。將文件儲存為 Microsoft Office 檔案類型。在 Microsoft Office 中開啟此檔案,VBA 巨集將如以前一樣執行。

您可以在載入或儲存 Microsoft Office 檔案時刪除其中的 VBA 巨集。

  1. 選擇 [工具] - [選項] - [載入/儲存] - [VBA 特性],以設定 LibreOffice 的 VBA 巨集處理。

相關主題

關於轉換 Microsoft Office 文件

開啟文件

開啟以其他格式儲存的文件

以其他格式儲存文件