Microsoft Office と LibreOffice の併用

From LibreOffice Help
Jump to: navigation, search

LibreOffice can open and save documents in the Microsoft Office file formats, including Microsoft Office Open XML formats.

Microsoft Office 形式のファイルを開く

  1. ファイル → 開く を選択します。LibreOffice のファイルオープンダイアログで、Microsoft Office 形式のファイルを選択します。
Microsoft Office 形式のファイルは... ...LibreOffice モジュールで開かれます。
MS Word、*.doc、*.docx LibreOffice Writer
MS Excel、*.xls、*.xlsx LibreOffice Calc
MS PowerPoint、*.ppt、*.pps、*.pptx LibreOffice Impress

Microsoft Office のファイル形式で保存する

  1. メニュー ファイル → 名前を付けて保存 を選択します。
  2. ボックス ファイルの種類 で、Microsoft Office のファイル形式を選択します。

ドキュメントを標準で Microsoft Office ファイル形式で保存する

  1. ツール → オプション → 読み込み / 保存 → 全般 を選択します。
  2. 標準のファイル形式と ODF 設定 領域でドキュメントの種類を選択して、その保存ファイル形式を指定します。

これ以降、ドキュメントを保存する際の ファイルの種類 は、ここで指定したファイル形式に設定されます。ただし、ファイル保存ダイアログで他のファイル形式を指定することも可能です。

多数の Microsoft Office ファイルを OpenDocument 形式に変換

ドキュメント変換ウィザード は、フォルダー内のすべての Microsoft Office 形式ファイルをコピーし、OpenDocument ファイル形式の LibreOffice ドキュメントに変換します。読み取りフォルダー、および変換後のファイルを保存するフォルダーを指定できます。

  1. ファイル → ウィザード → ドキュメント変換 を選択します

Microsoft Office および LibreOffice のマクロの扱い

若干の例外を除いて、Microsoft Office と LibreOffice では、使用できるマクロが異なります。Microsoft Office で使用するマクロは VBA (Visual Basic for Applications) コードで記述され、LibreOffice で使用するマクロは LibreOffice API (Application Program Interface) 環境がベースの Basic コードで記述されます。プログラミング言語は共通でも、使用するオブジェクトやメソッドが異なっています。

Note.png The most recent versions of LibreOffice can run some Excel Visual Basic scripts if you enable this feature at Tools - Options' - Load/Save - VBA Properties'.

一方のアプリケーションで使用されているマクロを、他方のアプリケーションで利用するには、マクロを修正する必要があります。LibreOffice は、Microsoft Office 形式のファイルに含まれているマクロも読み込むことができ、読み込んだマクロは、LibreOffice の Basic IDE エディターで表示および編集ができます。

こうした VBA マクロは、削除することも残すこともできます。

VBA マクロのコードが記録された Microsoft Office ドキュメントを開きます。通常の内容 (テキスト、セル、図) のみを変更し、マクロは編集しません。Microsoft Office のファイル形式で保存します。Microsoft Office でファイルを開き、VBA マクロを以前と同様に実行させます。

読み込み時または保存時に Microsoft Office ファイルから VBA マクロを削除できます。

  1. ツール → オプション → 読み込み / 保存 → VBA 属性 を選択して、 LibreOffice での VBA マクロの取扱いを設定できます。

関連項目

Microsoft Office ドキュメントの変換について

ドキュメントを開く

別の形式で保存されたドキュメントを開く

ドキュメントの別形式での保存